none
Central Administration returns blank page after installation on Windows 7

    Question

  • Hi, I have successfully installed SharePoint 2010 on Windows 7.  However when I browse to Central Administration, I just get a blank page.  I have been able to create a new web application and teamwork site using PowerShell, and that site also returns a blank page.  In the IIS log, I can see that the requests produce a 500 error.  Rerunning the Configuration Wizard has not helped.  Other ASP.NET sites run ok.

    Any suggestions?
    Wednesday, November 25, 2009 1:18 PM

Answers

  • I installed Sharepoint Foundation 2010 on Windows7 Home Premium following the instructions at http://msdn.microsoft.com/en-us/library/ee554869(office.14).aspx. Everything looked fine but I got a blank page when accessing the Central Admin site. I fixed this in IIS:

    1. Give iis at the command prompt
    2. In the left pane: expand until you see the Central Admin website
    3. Click on it
    4. In the middle pane: doubleclick on IIS-Authentication
    5. Enable Basic Authentication
    6. Restart IIS

    Tuesday, October 26, 2010 11:43 AM

All replies

  • I have the exact same problem, having installed on Windows 7 Home Premium.  Is this edition of Windows 7 supported given that Windows Authentication is not available in IIS 7?

    Andy
    Wednesday, February 17, 2010 11:16 PM
  • Hi Andy

    Good to know that I am not the only one who has this problem - there is a solution out there for us somewhere!  However, I don't think the problem is that you're using the Home edition (I have Ultimate installed).

    Marcus
    Thursday, February 18, 2010 10:23 AM
  • did you follow the steps on msdn?
    http://msdn.microsoft.com/en-us/library/ee554869(office.14).aspx

    esp step 8:
    start /w pkgmgr /iu:IIS-WebServerRole;IIS-WebServer;IIS-CommonHttpFeatures;
    IIS-StaticContent;IIS-DefaultDocument;IIS-DirectoryBrowsing;IIS-HttpErrors;
    IIS-ApplicationDevelopment;IIS-ASPNET;IIS-NetFxExtensibility;
    IIS-ISAPIExtensions;IIS-ISAPIFilter;IIS-HealthAndDiagnostics;
    IIS-HttpLogging;IIS-LoggingLibraries;IIS-RequestMonitor;IIS-HttpTracing;IIS-CustomLogging;
    IIS-Security;IIS-BasicAuthentication;IIS-WindowsAuthentication;IIS-DigestAuthentication;
    IIS-RequestFiltering;IIS-Performance;IIS-HttpCompressionStatic;IIS-HttpCompressionDynamic;
    IIS-WebServerManagementTools;IIS-ManagementConsole;IIS-IIS6ManagementCompatibility;
    IIS-Metabase;IIS-WMICompatibility;WAS-WindowsActivationService;WAS-ProcessModel;
    WAS-NetFxEnvironment;WAS-ConfigurationAPI;WCF-HTTP-Activation;
    WCF-NonHTTP-Activation
    Lack of necessary IIS authentication models could lead to a blank page.
    Thursday, February 18, 2010 5:01 PM
  • I have same problem.

    In event log I found the culprit:

    Unknown SQL Exception 1346 occurred. Additional error information from SQL Server is included below.

    A transport-level error has occurred when sending the request to the server. (provider: Shared Memory Provider, error: 0 - Either a required impersonation level was not provided, or the provided impersonation level is invalid.)

    How do I solve this?
    Sunday, February 28, 2010 5:00 PM
  • Not sure what changed, but now I get 403 Forbidden response..
    Sunday, February 28, 2010 5:23 PM
  • Ok, it works if I put SharePoint Administration website pool identity user to local administrators group.

    Does anyone know what exact permissions are needed here?
    Sunday, February 28, 2010 5:28 PM
  • Hello,

    I'm trying to install SharePoint 2010 on my laptop which has Windows 7 Home Premium on a 64 architecture. However, I am getting the error that the product requires Windows Server 2008 (X64).

    I also read that it can't be downloaded on Windows 7 Home edition: http://msdn.microsoft.com/en-us/library/ee554869(office.14).aspx

    Would you help me with this matter please. Are there certain steps that I need to follow or is there any workaround that I can use?

    Thank you...
    • Edited by nicelily Wednesday, March 17, 2010 9:35 PM
    Wednesday, March 17, 2010 12:28 PM
  • Hi,

    I had a similar error and found that the javascript settings on my browser wasn't 100% and this caused Central Administration to return a correlation error.  Perhaps they are related?

    All the best.
    http://technicallead.wordpress.com/
    Wednesday, March 17, 2010 2:38 PM
  • I had the same Error with the RTM - Bits.

    For me it was helpful to execute this statement in the cmd prompt:

    start /w pkgmgr /iu:IIS-WebServerRole;IIS-WebServer;IIS-CommonHttpFeatures;IIS-StaticContent;IIS-DefaultDocument;IIS-DirectoryBrowsing;IIS-HttpErrors;IIS-ApplicationDevelopment;IIS-ASPNET;IIS-NetFxExtensibility;IIS-ISAPIExtensions;IIS-ISAPIFilter;IIS-HealthAndDiagnostics;IIS-HttpLogging;IIS-LoggingLibraries;IIS-RequestMonitor;IIS-HttpTracing;IIS-CustomLogging;IIS-ManagementScriptingTools;IIS-Security;IIS-BasicAuthentication;IIS-WindowsAuthentication;IIS-DigestAuthentication;IIS-RequestFiltering;IIS-Performance;IIS-HttpCompressionStatic;IIS-HttpCompressionDynamic;IIS-WebServerManagementTools;IIS-ManagementConsole;IIS-IIS6ManagementCompatibility;IIS-Metabase;IIS-WMICompatibility;WAS-WindowsActivationService;WAS-ProcessModel;WAS-NetFxEnvironment;WAS-ConfigurationAPI;WCF-HTTP-Activation;WCF-NonHTTP-Activation

    After execution i have refreshed my browser and everything works fine.


    Mit besten Grüßen, kind regards, Daniel
    Wednesday, May 19, 2010 1:14 PM
  • Has anyone solved this yet?  I'm getting same error with RTM install on a Windows 7 machine that has been upgraded from Vista x64.
    Friday, June 04, 2010 2:50 PM
  • I am having the same issue (displaying blank page) when I try to open the sharepoint central administration site on my Windows 7 Home premium edition. Can't figure out what is causing this.

    The installation was usccessful.

    Thursday, July 15, 2010 6:18 PM
  • I'm not able to install SP 2010 on Win 7 Home Premium ed. I have been trying and searching but I could not figure out how to install it. is there any way to do it? is there any web page that describes the steps for that?  I would highly appreciate your assistance..

    Kindly note that I have asked this question at: http://social.technet.microsoft.com/Forums/en/sharepoint2010setup/thread/fe85d129-c3e6-410e-8dfb-89602734e5c9

    Thank you..

    Saturday, July 17, 2010 4:24 PM
  • I'm having the same issue here. Installed SP 2010 RTM out of the box, trying to get a development environment set up on windows 7. I originally ran into a "business data connectivity metadata store unavailable" with the designer and googling that led me to the blank configuration wizard page.

    Any other ideas what could be causing this? I tried everything in this thread to no avail.

    Thanks.

    Tuesday, July 20, 2010 9:03 PM
  • Any workaround???? even i have the same issue. Getting blank page when i open central administrator. I followed all steps as mentioned in http://msdn.microsoft.com/en-us/library/ee554869(office.14).aspx 
    Monday, July 26, 2010 9:41 AM
  • Hi,

    I have the same problem, first time everthing was going perfactly but suddenly i got the error, and no website can be loaded.

    My Host System is an Windows 2008R2

    Error:

    Unknown SQL Exception 1346 occurred. Additional error information from SQL Server is included below.

    A transport-level error has occurred when sending the request to the server. (provider: Shared Memory Provider, error: 0 - Either a required impersonation level was not provided, or the provided impersonation level is invalid.)

     

    Monday, July 26, 2010 10:21 PM
  • Same issue installed SharePoint 2010 on Windows Server 2008 R2 with SQL 2008 R2.  Blank Central Admin page after setup and the "required impersonation level" message in Event Viewer.  Adding the Central Admin app pool user to my local admins and then doing an "iisreset /noforce" resolved the issue for me.
    • Proposed as answer by Milchmann Wednesday, July 28, 2010 4:01 PM
    Tuesday, July 27, 2010 11:59 PM
  • Thank you very much the was the reason and my SharePoint is now running very nice!!
    Wednesday, July 28, 2010 4:04 PM
  • I've the same problem and all the authentications  exists, and Windows Authentication is enabled. but i still get a blank page
    Monday, August 16, 2010 12:33 PM
  • I installed Sharepoint Foundation 2010 on Windows7 Home Premium following the instructions at http://msdn.microsoft.com/en-us/library/ee554869(office.14).aspx. Everything looked fine but I got a blank page when accessing the Central Admin site. I fixed this in IIS:

    1. Give iis at the command prompt
    2. In the left pane: expand until you see the Central Admin website
    3. Click on it
    4. In the middle pane: doubleclick on IIS-Authentication
    5. Enable Basic Authentication
    6. Restart IIS

    Tuesday, October 26, 2010 11:43 AM
  • Thanks Henny

    I also got the blank page when I run Central Admin Website after the installation of SharePoint on Windows 7. Steps proposed by Henny Sol resolved my issue.

    • Proposed as answer by ARLatif Sunday, December 04, 2011 8:58 AM
    • Unproposed as answer by ARLatif Sunday, December 04, 2011 8:58 AM
    Friday, December 03, 2010 10:04 AM
  • Henry Sol's Answer did the trick.
    Wednesday, December 29, 2010 10:30 PM
  • Thank you Henny Sol! This fixed my blank page problem

     

    Friday, December 31, 2010 10:36 AM
  • Hi Henny,

     

    Thanks a lot... It fixed the error.


    Harsh
    Sunday, January 09, 2011 8:21 AM
  • Thanks Henny

    It solved the blank page problem and now I am facing 404 page... Thanks for making me progress further ;)

     

    Vinod

    Saturday, January 22, 2011 11:43 AM
  • Thank you Henny Sol! This fixed my blank page problem

     

    However,  how do I get the "Welcome Page"  I can only see Central Admin.  I am not seeing like a TOP LEVEL site, like the one with the three people and it says "Welcome to your site"

    Am I missing something here? 

    Or is that what comes up when you create your first site?  I thought it was supposed to appear after install.

     

    Thanks!

    Sunday, January 30, 2011 1:07 AM
  • Thank you Henny Sol !!!

    Your steps mentioned had fixed my blank page problem.

    Monday, April 04, 2011 2:26 AM
  • Henry Sol,

    I tried your solution and voa la, it worked.  However, when I attempted to find my sharepoint site from Sharepoint Designer, it couldn't find it.  I got error message:

    Unable to open Web site. Possible causes:

    1. The Web server may not have SharePoint Server installed.
    2. The Web Server may be temporarily out of service.
    3. If you are connecting through a proxy server, the proxy settings may be incorrect.
    4. An error may have occurred in the Web server.

    After deliberating with Microsoft tech support for hours over about 3 days, the solution was finally determined.  I went into the "Windows Features Dialog" (Control panel/Programs/Turn Windows Features on or off. Open folder tree: internet information services/world wide web services/security) and checked "Windows Authorization".  Doing this allowed and required that I turn off "basic authorization" as described by Henry Sol.  Now things work right in Sharepoint Designer and as a web page.

    If you don't make any mistakes when following http://msdn.microsoft.com/en-us/library/ee554869.aspx?ppud=4 you won't have this problem.

     

    Sunday, May 22, 2011 2:09 AM
  • B Fast

     

    WIth Family Premium x64  edition of win 7  you cannot check Windows authorisation within IIS, alas, that is why there are some issues with apps requiring windows authentif. Ultimate or Pro is the best choice to install SharePoint Foundation on win 7 test machines.

    Henry solution at least make SharePoint pages work.

    Thx for the advise about SH Designer

     

    Didier


    Didier Maignan | http://didiermaignan.unblog.fr
    Wednesday, August 24, 2011 12:02 AM
  • Thanks so much, Henny! :)

    I spent and waste lot of time to find the root cause! You are the super hero!

    Friday, December 30, 2011 2:46 PM
  • Hi Henny,

    Yesterday, I followed your workaroud, it resolved my issue.

    Today, I tried to disable the Basic Authication in IIS and make IIS-Authentication to default settings, then browed to the CA, it renders well without any issues. In my opinion, I think if I disable it, it should throw the previous error: HTTP 500 ERROR.

    I am a little confused about this!

     

     

    Saturday, December 31, 2011 2:41 AM
  • I installed Sharepoint Foundation 2010 on Windows7 Home Premium following the instructions at http://msdn.microsoft.com/en-us/library/ee554869(office.14).aspx. Everything looked fine but I got a blank page when accessing the Central Admin site. I fixed this in IIS:

    1. Give iis at the command prompt
    2. In the left pane: expand until you see the Central Admin website
    3. Click on it
    4. In the middle pane: doubleclick on IIS-Authentication
    5. Enable Basic Authentication
    6. Restart IIS

    Man, I just sign up to this forum only to tell you THANK YOU and to give you 1 point, hope that I had the chance to give you 100 instead.. Thanks :)
    • Proposed as answer by Nagendra m Monday, November 05, 2012 12:49 PM
    Thursday, January 05, 2012 8:15 PM
  • This worked for me!  Thank you so much!
    Friday, January 20, 2012 2:23 AM
  • Like an idiot I had IE 9 installed but it had some conflicts with some Microsoft sites so I downgraded to IE 8 and that hosed everything. I had to reinstall then run E.Ayan's suggestion.

    Thursday, February 02, 2012 8:00 PM
  • I installed Sharepoint Foundation 2010 on Windows7 Home Premium following the instructions at http://msdn.microsoft.com/en-us/library/ee554869(office.14).aspx. Everything looked fine but I got a blank page when accessing the Central Admin site. I fixed this in IIS:

    1. Give iis at the command prompt
    2. In the left pane: expand until you see the Central Admin website
    3. Click on it
    4. In the middle pane: doubleclick on IIS-Authentication
    5. Enable Basic Authentication
    6. Restart IIS

    This did not work for me. I have sharepoint foudation 2010 installed on windows 2008 R2. I tried to patch sharepoint 2010 to SP1 and also sql server 2008 r2 to SP1. It still shows the error of SQL transport. What i can do now is add the application pool identity to local administrator group. Really wondering what kind of rights should be assigned to this domain account.
    Tuesday, February 21, 2012 3:54 AM
  • hi,

    During intallation of WIndows 7 64Bit, i had not enabled WIndows Authentication for IIS , for that reason i was getting blank screen for central admin.

    Please try following

    Control Panel --> Program & Features --> Turn Windows Features On or Off --> IIS --> WWW Services --> Security --> Select Basic & Windows Authentication

    that should help.

    regards
    Mario Fernandes

    • Proposed as answer by Nagendra m Monday, November 05, 2012 12:45 PM
    Tuesday, April 17, 2012 4:37 AM
  • Thanks Buddy :)
    Saturday, June 09, 2012 5:42 PM
  • I had the same issue with a server installed by a colleague (Windows 2008 R2/ Sharepoint 2010). What you should do is to install the Windows Authentication Role service in the server management. IMHO, it's a much more efficient approach than enabling Basic Authentication.

    Monday, June 25, 2012 12:59 PM
  • I installed Sharepoint Foundation 2010 on Windows7 Home Premium following the instructions at http://msdn.microsoft.com/en-us/library/ee554869(office.14).aspx. Everything looked fine but I got a blank page when accessing the Central Admin site. I fixed this in IIS:

    1. Give iis at the command prompt
    2. In the left pane: expand until you see the Central Admin website
    3. Click on it
    4. In the middle pane: doubleclick on IIS-Authentication
    5. Enable Basic Authentication
    6. Restart IIS

    it worked thank you 

    Sri.Tummala

    Saturday, June 30, 2012 6:01 AM
  • it works. thanks Henny  for your support.


    Monday, September 17, 2012 12:19 PM
  • hi Mario Fernandes,

            thank you mario, this is fixed my blank page problem. and i am back to work CA.

    Thanks & Regards,

    Nagendra.
    Monday, November 05, 2012 12:45 PM
  • Thanks Daniel,

    This solution worked for me. Sharepoint was installed properly on windows 7 but page was displaying blank on browser.

    Monday, December 24, 2012 8:52 PM
  • I have installed sharepoint 2010 on my windows 8, and having blank document issue. I tried your solution but no luck.
    Friday, February 01, 2013 8:38 AM
  • Thanks alot for sharing this.. It worked like a charm.. :)

    Varun Sharma

    Saturday, July 27, 2013 1:10 PM
  • hi,

    During intallation of WIndows 7 64Bit, i had not enabled WIndows Authentication for IIS , for that reason i was getting blank screen for central admin.

    Please try following

    Control Panel --> Program & Features --> Turn Windows Features On or Off --> IIS --> WWW Services --> Security --> Select Basic & Windows Authentication

    that should help.

    regards
    Mario Fernandes

    Worked for me too!
    Thursday, January 02, 2014 7:42 PM