none
"you do not have permission to do this operation + SP Designer 2010 Error

    Question

  • I am unable to access to my sharepoint site via SharePoint designer. The error is: You do not have permission to do this operation. Ask your web site administrator to change your permissions and then try again, or log on with a user account that has this permission...

     I am the site owner with full control. I get the error when I click Site Actions - Edit in SharePoint Designer. I also get the error when I open SharePoint Designer directly and click on the link that was created under Recent Sites.

    In my Central Admin, the SharePoint Designer Settings is all enabled. i am to beloning to farm administrator and i am teh site collection admin. and  in the machine admin group.

    First I created a  claims based authen.  with custom mem.ship /role providers and it was working fine. and i added  users into the users policy user1,user2, user3 etc. and later i  removed these mem.ship /role providers and removed the "Enable fba authentication " check box.

    now i am  unable to login into the  sp designer 2010 and  unable to edit master page.

    Also whenever i am trying tio change anything in the _layouts/settings.aspx, like uploading an image or adding a page etc i a egtting teh "error :access denied   sign in  as different user."

    i am not able to find out  what caused this issue till now. Did mycustom membership/role provider is causign the pblm?

     

    or Is there any place else that I should check?


    PrasadWT
    Tuesday, November 16, 2010 6:40 AM

Answers

  •  

     Hi Clayton,

     thanks for your time and reply.

    "I fear you have left artifcats of the FBA that are messing up SPD"

     You are correct. when i opened the  site in my designer  am getting  "sp foundation not isntalled", forbidden etc etc.  

    i have deleted this web app.

    now i have created a new classic mode web appln  changed my master page.

    Can you help how can i extend a classic  mode to fba based on claims mode. Somewhere i  read that  powershell cmdlets is the only way to do this "extending". any other ways i can achieve...

     

     

     

     

     

     


    PrasadWT
    • Edited by PrasadWT Wednesday, November 17, 2010 6:26 AM c
    • Marked as answer by PrasadWT Wednesday, November 17, 2010 6:46 AM
    Wednesday, November 17, 2010 6:25 AM
  • Only through PowerShell as far as I know.
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    • Marked as answer by PrasadWT Wednesday, November 17, 2010 6:46 AM
    Wednesday, November 17, 2010 6:40 AM
  • I can't clarify any of that - it's a very strange situation to add all that FBA and then remove it.  Why do you have a claims web app now if using Windows Auth.  I fear you have left artifcats of the FBA that are messing up SPD.  Have you tried extending this web app to a new web app that only uses Windows Auth so that you can see if it works with SPD?
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    • Marked as answer by PrasadWT Wednesday, November 17, 2010 6:19 AM
    Tuesday, November 16, 2010 8:15 AM

All replies

  • If you removed all the FBA stuff from your web app, then what was left?  What are you using to authenticate now?
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Tuesday, November 16, 2010 7:42 AM
  •  Hi Clayton ,

     Thanks for the reply. My assumption is that though we removed the fba settings in "unchking the Enable FBA " and removing th entries in the mem-ship provider./role provider,  I have checked the Enable windows authentication chk box and checked the enable integrated windows  authentication with NTLM from the dropdown.

    i am asking, will this be sufficient to login the website with my AD [ mydomainname\myaccoutnname] credentials? even though we dont have configured the FBA?

    if  i add the users into the users policy with fullcontrol, can i login the spd  2010 for editing teh master page with this fba user credentials?  for eg: fba users user1/user1 and user2/user2.

    in this case which account/credentials we need to to use to edit/publish the master page in SPD.

     

    Pls clarify my doubt.


    PrasadWT
    • Edited by PrasadWT Tuesday, November 16, 2010 8:06 AM added
    Tuesday, November 16, 2010 8:04 AM
  • I can't clarify any of that - it's a very strange situation to add all that FBA and then remove it.  Why do you have a claims web app now if using Windows Auth.  I fear you have left artifcats of the FBA that are messing up SPD.  Have you tried extending this web app to a new web app that only uses Windows Auth so that you can see if it works with SPD?
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    • Marked as answer by PrasadWT Wednesday, November 17, 2010 6:19 AM
    Tuesday, November 16, 2010 8:15 AM
  •  

     Hi Clayton,

     thanks for your time and reply.

    "I fear you have left artifcats of the FBA that are messing up SPD"

     You are correct. when i opened the  site in my designer  am getting  "sp foundation not isntalled", forbidden etc etc.  

    i have deleted this web app.

    now i have created a new classic mode web appln  changed my master page.

    Can you help how can i extend a classic  mode to fba based on claims mode. Somewhere i  read that  powershell cmdlets is the only way to do this "extending". any other ways i can achieve...

     

     

     

     

     

     


    PrasadWT
    • Edited by PrasadWT Wednesday, November 17, 2010 6:26 AM c
    • Marked as answer by PrasadWT Wednesday, November 17, 2010 6:46 AM
    Wednesday, November 17, 2010 6:25 AM
  • Only through PowerShell as far as I know.
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    • Marked as answer by PrasadWT Wednesday, November 17, 2010 6:46 AM
    Wednesday, November 17, 2010 6:40 AM
  • I found the following fix worked for me

    In Central Admin go to the SharePoint Designer settings page:

    http://<Your central admin site>/_admin/SharePointDesignerAdmin.aspx

    Clear all the check boxes, click ok. Then go back to the page again and check all the checkboxes (ie put the page back to its original settings).

    Wait a minute or so and then open the site in SharePoint Designer.

    Ian

    • Proposed as answer by Ian Woodgate Thursday, November 18, 2010 4:37 PM
    • Unproposed as answer by Clayton Cobb Thursday, November 18, 2010 5:29 PM
    • Proposed as answer by Homeriii Thursday, March 14, 2013 2:28 PM
    Thursday, November 18, 2010 4:33 PM
  • Ian, do not propose your own answers.  This is not much of a "fix," but if it actually does the job of completely fixing an environment that had FBA stripped, then great, but PrasadWT would have to confirm it before it's an answer.
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Thursday, November 18, 2010 5:30 PM
  • I took a

    Backup-SPSite

    Deleted the Site collection and web app

    Recreated web app

    Restore-SPSite

    That worked

    Sunday, March 20, 2011 5:45 PM

  • HI, I am facing same issue on production environment. Web application is extended and extended application site can not be able to sharepoint designer 2010.

     

    - I am using farm account to open site

    - web application has already extended.

    - As I am using farm account it has full control to application sites.

    - SharePoint designer is enabled in central admin.

    - web application using windows authentication already.

     

    Whenever I tried to open site in SPD, I am getting an error "You do not have permission to do this operation..."

     

    Please kindly assist me.

     


    Tuesday, December 13, 2011 12:14 PM
  • Dear Prasadwt,

    Please enter following command in powershell:

     Get-SPSite -Identity http://<your_site> | select *    and verify if
                 WriteLocked: FALSE
                 ReadOnly: FALSE

    I am sure WriteLocked and ReadOnly is TRUE. To fix it please enter following command in powershell:

    Set-SPSite -Identity http://<your_site> -LockState Unlock

    Hope it will help.

    BR,

    Dmytri

    Monday, April 23, 2012 4:00 PM
  • Hi Ian Wookgate,

    your suggestion worked for me.

    Thanks

    Aron

    Monday, August 27, 2012 1:13 PM
  • Seems like an extreme thing to do but these steps worked for me:

      • Obviously backing up the site collection first using Central Admin's backup site collection feature
      • Took notes of how the current web application was configured in central admin's Web Application Management |General Setting drp down for things like general & workflow settings, external email, etc
      • (optional step)  I took a copy of some bespoke settings I had in the web.config file of the web application
      • Deleted the web application from Central Admin (when deleting the web app I only deleted the IIS web site not the content db in a "just in case" operation but I don't think it matters, just remember to tidy up SQL and include any new content db in your SQL maintainance plan)
      • Checked IIS that they had been removed
      • Re-created the Web Application (and created a new content db in my case)
      • Restored the site collection backup usign Restore-SPSite command with a -Force parameter
      • Put all the web application settings back in
      • Shut down IIS for a moment to add my custom web.config settings back into the new file
      • Rebooted the server

    As I say a bit extreme but it worked...

    Monday, September 03, 2012 6:36 PM
  • This worked for me. How frustrating...
    Thursday, March 14, 2013 2:28 PM