none
soap:Server was unable to process request. ---> Value does not fall within the expected range

    Question

  • Brand spanking new Sharepoint 2010 RTM and Designer 2010 RTM install. Unable to edit any page whatsoever even when checking out. Error in SP Designer: soap:Server was unable to process request. ---> Value does not fall within the expected range.

    Like I said, this is a brand new RTM install with nothing altered yet. Why can't I edit any pages? I am using the highest credentials so there should be no permission issues. There isn't anything that is helping me on the Web for this.

    Why would I encounter a problem like this out of the box? This is not the beta - it is RTM!

    Saturday, May 01, 2010 3:15 PM

Answers

  • I had same problem.

    My site name was http://site

    I connect to my site in sharepoint designer 2010 using name http://site.domain.org and receive error "soap:ServerServer was unable to process request. ---> Value does not fall within the expected range."

    But then i complete configuring alternate access mapping as http://site.domain.org as internet zone and reconnected in sharepoint designer 2010, my problem was solved.

    • Proposed as answer by ilya k Wednesday, May 19, 2010 3:07 PM
    • Marked as answer by Peter Holdridge Thursday, May 20, 2010 2:58 PM
    Wednesday, May 19, 2010 3:07 PM
  • Yea, encountered a similar problem...tweaking the alternate access mappings seems to resolve all of the problems.
    Monday, May 10, 2010 3:41 PM
  • Friday, May 21, 2010 1:18 AM

All replies

  • I encountered the same problem you, before this option, i just changed my computer name. if i resolve it, i'll share the solution with you.

    Monday, May 10, 2010 6:42 AM
  • same problem here with RTM
    Monday, May 10, 2010 1:14 PM
  • hi,

    think i fixed the problem here ... my problem was that i was always using http://ip instead of http://hostname when connecting to sharepoint designer.

    hope that helps!

    cheers,

       chris

    Monday, May 10, 2010 1:45 PM
  • While testing an example I was working on I mistakenly did something very similar and got the same results.  Definitely check the URL you are entering to make sure the hostname is accurate or you'll see strange errors like this.
    John
    SharePoint911: SharePoint Consulting
    Blog: http://www.rossonmoss.com
    Twitter: JohnRossJr

    MOSS Explained: An Information Workers Deep Dive into Microsoft Office SharePoint Server 2007
    Monday, May 10, 2010 2:20 PM
  • Yea, encountered a similar problem...tweaking the alternate access mappings seems to resolve all of the problems.
    Monday, May 10, 2010 3:41 PM
  • I have the same problem on my Windows 7 stand-alone installation but on my development farm it works fine.
    What sort of tweaking did you do swirch?

    Friday, May 14, 2010 9:00 PM
  • Hey,

    I'm in the circumstance of doing a db attach on a new sharepoint 2010 rtm install.  Instructions say to use the original url...but it's still going under 2007.

    So, I'm using the ip address or if local localhost.  using the https://newservername.domain.com:port doesn't work so well...keeps going back to the 2007 server.

    I'm mapping the ip address to the applcation, local host, etc.   had to sort of goof around with it to get everything working.  spd seems to need the fully qualified url to have permissions to post.

    Best of luck,

    S'

    Monday, May 17, 2010 1:06 PM
  • I had same problem.

    My site name was http://site

    I connect to my site in sharepoint designer 2010 using name http://site.domain.org and receive error "soap:ServerServer was unable to process request. ---> Value does not fall within the expected range."

    But then i complete configuring alternate access mapping as http://site.domain.org as internet zone and reconnected in sharepoint designer 2010, my problem was solved.

    • Proposed as answer by ilya k Wednesday, May 19, 2010 3:07 PM
    • Marked as answer by Peter Holdridge Thursday, May 20, 2010 2:58 PM
    Wednesday, May 19, 2010 3:07 PM
  • Ilya K please, 

    Can you tell me, where exactly do I can configure alternate access mapping, I guess it would be on the IIS, but I can't figure out where to do it.

     

    Thursday, May 20, 2010 3:27 PM
  • Friday, May 21, 2010 1:18 AM
  • just to tell , it worked for me too

     

    and just to appear in searches and google, mine version is brazilian portuguese and the error message is

     

    soap:ServerO servidor não pôde processar a solicitação. ---> O valor não recai no intervalo esperado.


    Monday, May 24, 2010 1:04 AM
  • Me, too,

    It worked like a charm, I guess I need to read more carefuly the best practices on this.

     

    Thank you very much Peter.

    Monday, May 24, 2010 7:15 PM
  • Hi

    I faced to this problem. But solved it.

    http://localhost:1234    - it gives the error

    http://myweb:1234  - no error

    Thanks ,

    Thanuja Pathiraja ( Sri Lanka)

    • Proposed as answer by rkapiljith Tuesday, April 17, 2012 6:33 AM
    Tuesday, May 25, 2010 9:15 AM
  • Okay, Now I find the solution,

    I may assumed that you used http://localhost , in this case the designer can't get the full communication with the IIS with this domain.

    So the best thing is use your PC name, for example, if http://localhost, I run my designer and open http://piseth-pc or if http://localhost:1777 it'll be http://piseth-pc:1777 . This will 100% work without changing or config anything.

     

    Hope this help

    Tuesday, June 15, 2010 12:03 PM
  • Hi

    This solution is correct and works well! I used http://localhost as well and changed to http://<computername>, after that SharePoint Designer is working.

    Thanks,

    Stefan

    Tuesday, July 13, 2010 7:13 PM
  • http://localhost:1234    - it gives the error

    http://myweb:1234  - no error

    This is how it solved my problem
    Friday, April 08, 2011 11:12 AM
  • Yea, if you want it to work with local host, ip address etc. you need to add alternate access mappings...
    Friday, April 08, 2011 1:03 PM
  • thanks but what do you means by alternate access mappings. and how to create it.
    Wednesday, April 20, 2011 11:39 AM
  • I have the same problem.  I had tried to change the alternate url mapping to internet.  But no use.  Please provide step how to change the alternative url mapping.

    Or is any other steps are available.

     

    Tuesday, May 10, 2011 1:33 PM
  •  this is may be u have DNS problem with your system..so save your server ip and name in host file(system32--->drivers---->etc--->host-open with notepad)..tru to open sharepoint site and type the URL loke this http://server/

     

     

    Wednesday, June 01, 2011 11:07 AM
  • Yes this worked for me as well - thanks very much it saved me a lot of time.... Lee

    Wednesday, July 20, 2011 10:59 AM
  •  

    Go to :

     

    Site Collection Administration 

    : 

    SharePoint Designer Settings

    and Enable the following

    Enable Detaching Pages from the Site Definition
    Enable Customizing Master Pages and Page Layouts
    Enable Managing of the Web Site URL Structure

     

     

    This should resolve the SP Designer Edit Issues.


    • Edited by JaspalM Thursday, September 08, 2011 1:59 AM
    Thursday, September 08, 2011 1:57 AM
  • That worked.  Thanks for the post.
    Thursday, September 08, 2011 2:02 PM
  • Hi All

     

    opening your site using http://<systemname>:port will not give any issue. using localhost will cause problem. Hope this will help.

    Vijay K Narang

     

     

    Saturday, October 08, 2011 6:25 PM
  • I had a similar problem, I am running everything in a vmware. I tried connecting to http://localhost. That worked fine, till I wanted to edit a masterpage. When editing the masterpage i got the same error. Then I tried connecting to the ipaddress (it is a dynamic ip) that failed also. Last I tried connecting to the machine name, that solved everything... 
    • Edited by chefdog Sunday, November 13, 2011 11:38 AM
    Sunday, November 13, 2011 11:36 AM
  • I had the same issue, I replaced http://localhost:port with http://computername:port;the problem is solved.

     

    Wednesday, December 14, 2011 7:46 AM
  • If you are developer trying from a local machine try with your "system name" to resolve the problem.For getting your system name>>from the windows menu>>select "run">>msinfo32.exe(Press the enter key)>>This will help you to identify your system name.

    Say your system name is INDIANSUPERCOMPUTER then try to open it as http://INDIANSUPERCOMPUTER:25025 instead of http://localhost:25025 .


    Expect The Unexpected One.

    Tuesday, April 17, 2012 6:39 AM
  • I am currently working on a project where I access the sharepoint server remotely, and this error occurred. Solved this problem by running the following command on my machine.

    ipconfig /flushdns

    ipconfig /registerdns

    Friday, June 01, 2012 5:59 PM
  • I found the similar problem with my SharePoint designer 2010.

    I solved this one using following method:-

      • Check the URL.
        Application may have created like http://sharepoint:1255/Home.aspx and you may be using url like http://localhost:1255/Home.aspx. It was case with me.
      • Supply the same user name and password which were given during time of application creation.

    Hope this will help you to resolve your problems.

    Thanks ,

    Rajesh

    Thursday, August 30, 2012 6:05 AM
  • Mapping was my issue as well, except in my case I was forcing SSL using a URL rewrite rule in IIS and my SharePoint mappings were pointing to "http" instead of "https". So you might check to see if this is your issue too if you're forcing SSL.
    Tuesday, October 15, 2013 6:07 PM
  • Adding http://localhost as Alternate Access Mappings fixed this problem for me..
    Tuesday, December 17, 2013 6:01 AM