none
"Hidden" option not working in Word 2003 Web File Properties

    Question

  • I am using SharePoint 2007 with Word 2003.  I created a few fields (columns), added them to the appropriate content type and set 2 or the 3 columns to be Hidden (they are not required).  However, whenever I create a new doc based on the content type (using Word 2003), all 3 fields are displayed in the Web File Properties.

    Why?  How do I fix this?
    • Moved by Mike Walsh FIN Tuesday, August 04, 2009 6:11 AM admin q (From:SharePoint - Design and Customization)
    Monday, August 03, 2009 4:49 PM

Answers

  • Hello,

     

    Thanks for your clarification.

     

    Based on my research, it is a known issue occurring in Microsoft Office 2003 client and 2007 SharePoint products. It is caused by the different document metadata detectors between Office 2003 and Office 2007 products. Therefore, the issue doesn’t occur in Office 2007 client applications.

     

    Currently, I think there is no solution or fix to solve this issue based on Office 2003 clients.

     

    If there is any update on this issue, I will follow up here and let you know it. Please let us know if you need any further assistance. Thanks for your patience and understanding again.

     

    Best Regards,

    Lionel Chen

    • Marked as answer by Ruthie09 Thursday, August 06, 2009 1:51 PM
    Thursday, August 06, 2009 5:44 AM
  • After additional trial and error I did discover something that worked.  The Hidden fields showed up (using Word 2003) if no other content type was available.  However, if there was more than one content type, the hidden fields stayed hidden (however, the Content Type field WAS displayed). 

    To prevent users from associating a doc with the wrong content type, I simply created 2, named almost the same, using the same template.  Thus it wouldn't matter which one they used.

    This was an acceptable alternative for me.
    • Marked as answer by Ruthie09 Tuesday, August 11, 2009 10:30 PM
    Tuesday, August 11, 2009 10:30 PM

All replies

  • Moving to Admin.

    Not customization.
    WSS FAQ sites: http://wssv2faq.mindsharp.com and http://wssv3faq.mindsharp.com
    Total list of WSS 3.0 / MOSS 2007 Books (including foreign language) http://wssv3faq.mindsharp.com/Lists/v3%20WSS%20FAQ/V%20Books.aspx
    Tuesday, August 04, 2009 6:11 AM
  • Hello,

     

    How did you “hide” the certain fields? If you just hide it from the current view, I don’t think that will affect the fields when you submit a document.

     

    If you want to remove the columns from the list, please click List Settings and then Columns, delete the certain ones you want.

     

    Thanks.

     

    Best Regards,

    Lionel Chen

    Wednesday, August 05, 2009 6:13 AM
  • In the Library Settings, I selected the content type in question, and then clicked on the column name.  In the Column Settings, I chose "Hidden (Will not appear in forms).  I can not disassociate the columns from the content type as they are critical to the workflow.

    So why do these things still display in Word 2003 Web File Properties?
    Wednesday, August 05, 2009 1:52 PM
  • Hello,

     

    Thanks for your clarification.

     

    Based on my research, it is a known issue occurring in Microsoft Office 2003 client and 2007 SharePoint products. It is caused by the different document metadata detectors between Office 2003 and Office 2007 products. Therefore, the issue doesn’t occur in Office 2007 client applications.

     

    Currently, I think there is no solution or fix to solve this issue based on Office 2003 clients.

     

    If there is any update on this issue, I will follow up here and let you know it. Please let us know if you need any further assistance. Thanks for your patience and understanding again.

     

    Best Regards,

    Lionel Chen

    • Marked as answer by Ruthie09 Thursday, August 06, 2009 1:51 PM
    Thursday, August 06, 2009 5:44 AM
  • Drat.  That's what I was afraid of.  :(
    Thursday, August 06, 2009 1:51 PM
  • After additional trial and error I did discover something that worked.  The Hidden fields showed up (using Word 2003) if no other content type was available.  However, if there was more than one content type, the hidden fields stayed hidden (however, the Content Type field WAS displayed). 

    To prevent users from associating a doc with the wrong content type, I simply created 2, named almost the same, using the same template.  Thus it wouldn't matter which one they used.

    This was an acceptable alternative for me.
    • Marked as answer by Ruthie09 Tuesday, August 11, 2009 10:30 PM
    Tuesday, August 11, 2009 10:30 PM
  • Hi, Im new to Sharepoint dev and I also encountered a problem similar to this one.  My fields (columns) that are hidden or not defined in a content type is being displayed in the Web File Properties in Excel 2003.  But if the user has Excel 2007, it works fine (the hidden/undefined columns do not show).

    I found a fix http://support.microsoft.com/kb/934253 from Microsoft Support but I would like to confirm if anyone have used it and if it did fixed the hidden fields?  

    Thanks!

    Thursday, March 15, 2012 1:57 AM
  • There are still a lot of Office 2003 installations out there, especially in the enterprise world. MS should release a patch to fix this issue. I face web file properties dialog appearing when using Word 2003 with SharePoint 2010.
    Thursday, August 16, 2012 11:20 AM