none
sharepoint 2007 site - rename the 'home' tab

    Question

  • hi,

    i cant find anything on google that relates to this but im sure this must be a common request.

    i want to rename the 'home' tab to another name on 1 of my sharepoint 2007 sites.  i can rename the other tabs through the system but the 'home' tab is not allowed.  i want to do this on 1 site and not all sites.

    i cant see how to do it thru sharepoint designer either.

    any ideas???
    Friday, January 15, 2010 12:33 PM

Answers

All replies

  • What site template is your site based on? To change the tabs in a 'Team' site select 'Site Actions > Site Settings > Look and Feel | Top link bar'. In a Publishing/Collaboration site this can be done by changing the site 'Title' via 'Site Actions > Site Settings > Look and Feel | Title, description, and icon'. You might also want to check you have appropriate permissions on the top level site.

    • Marked as answer by Mike Walsh FIN Friday, January 15, 2010 1:30 PM
    • Unmarked as answer by Ireland75 Friday, January 15, 2010 2:03 PM
    Friday, January 15, 2010 12:51 PM
  • On WSS,Team site

    Site actions>Site settings>Top link bar>Click on "edit icon" in front of HOME
    In "Type the Description" Change Home to whatever you want and click OK

    On MOSS Publishing site:

    HOME > Site Settings > Title, Description, and Icon > TITLE

    Thanks!


    I LOVE MS..... Warm Regards, Kshitiz Posting is provided "AS IS" with no warranties, and confers no rights.
    • Edited by Kshitizs Friday, January 15, 2010 12:56 PM EASY
    Friday, January 15, 2010 12:52 PM
  • Two answers of equal merit.

    First one posted gets the marking.

    (Moderator)

    FAQ sites: (SP 2010) http://wssv4faq.mindsharp.com; (v3) http://wssv3faq.mindsharp.com and (WSS 2.0) http://wssv2faq.mindsharp.com
    Complete Book Lists (incl. foreign language) on each site.
    Friday, January 15, 2010 1:30 PM

  • sorry but this doesnt answer my question...

    my wss 3.0 site is created with the 'multipage meeting workspace' template which is under the meetings section when you go to create a site.

    'Site Actions > Site Settings > Look and Feel | Top link bar'
    i followed the above pathway but my 'look and feel' section doesnt have a link called 'top link bar'...i have listed the links below in my 'look and feel' section.


       Title, description, and icon 
       Master page 
       Navigation 
       Tree view 
       Site theme 
       Save site as template 
       Reset to site definition 
       Searchable columns 

    is there something im missing here??

    • Proposed as answer by ljenfi Thursday, October 14, 2010 2:56 PM
    Friday, January 15, 2010 2:03 PM
  • Change TITLE in the "Title, description, and icon"
    I LOVE MS..... Warm Regards, Kshitiz Posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, January 15, 2010 2:15 PM

  • i tired that but it doesnt change the 'home' tab...it only changes the name of the site.  the tab called 'home' remains as 'home'
    Friday, January 15, 2010 2:18 PM
  • This is a feature of the publishing sites.  You will notice that this menu change happens when you active the publishing infrastructure feature.  You can change the 'Home' tab using the 'Top Link' settings available under 'Look and Feel' in 'Site Settings'.
    Shannon Bray - MCT, MCPD, MCTS, MCITP Blog http://www.shannonbray.com User Group Site: http://www.cospug.com
    Friday, January 15, 2010 2:25 PM
  • Hi Ireland75,

     

    Please first make sure the Home tab is your current site or the parent site.

     

    As you said this is 'multipage meeting workspace' template and you could see the Navigation menu.

    I suppose the Home tab is a reference to the parent site, if so, you need to first navigate to the parent site and then modifying the text through Site Settings > Title, Description, and Icon.

     

    If your continues to persist, please let me know more information on your site hierarchy and the corresponding site templates in order to make a local reproduce.

     

    Lambert Qin

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact mtngfb@microsoft.com  


    Sincerely,
    Lambert Qin
    Posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, January 18, 2010 3:02 AM
  •    You cannot see the 'Top Link Bar' option at site settings under look and Feel Tab, bcoz you have publishing feature enabled.

     Deactvate the publishing infrastructure feature at site actions- site settings- site collection feature or the publishing feature at site actions - site settings- site features.

     Cheers!

    Regards, Aj (http://www.ajittgeorge.blogspot.com) MCTS
    Monday, January 18, 2010 12:52 PM
  • Hi Ireland75,

     

    Could you please let me know if above suggestions are helpful?

    If you need further assistance, please feel free to let me know.

     

    Have a nice day!

     

    Lambert Qin

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact mtngfb@microsoft.com  


    Sincerely,
    Lambert Qin
    Posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, January 20, 2010 4:45 AM
  • If you are using a Multipage Meeting Workspace you cannot change the title of the homepage OOTB but I found an article that describes how to change the title using jquery!

    Look at this: http://weblogs.asp.net/bsimser/archive/2009/10/12/changing-the-home-tab-in-mutipage-meeting-workspaces-with-jquery.aspx

    Hope this helps

    • Marked as answer by Ireland75 Wednesday, January 20, 2010 10:20 AM
    Wednesday, January 20, 2010 10:08 AM


  • thats for all help on this...the above article worked great for me.  i didnt want to deactivate the publishing feature for the entire intranet as that would be too worrying...im sure it would have worked for what i wanted...but the above article was a quick and handy solution. 
    Wednesday, January 20, 2010 10:23 AM
  •  

    In reply to all:
    It wasn't possible with any method mentioned above.

    I tried them all on our intranet.

    What DID work:

    (Publishing features ON)

    Site Actions > Edit Page

    Then on the left of the top editing pane, click on "Page"
     

    In the drop-down click on "Page Settings"

    Then fill in the name you want to see on the tab in the Title input field.

    Save.

    Friday, November 04, 2011 1:04 PM
  • As other posters have noted, there is no "Top Link" selection available under "Look and Feel" in settings.  And changing the site Title does not affect the Home tab name.

    So the question remains: is there a way to change the text of the Home tab?

    Wednesday, April 10, 2013 3:35 PM