none
scope in your query does not exist

    Question

  • i am getting "Scope in your query does not exist" when i search for a keyword in my search page and not able to go to "Search Setting" page in SharedService and showing error Exception from HRESULT.

    Till last week my search was working fine and now its not working and getting below error when i take backup of my farm server in central admin.


    [11/25/2009 3:53:03 PM]: Error: Object Shared Search Index failed in event OnBackupComplete. For more information, see the error log located in the backup directory.
     Object Shared Search Index failed in event OnPrepareBackup. For more information, see the error log located in the backup directory.
     COMException: Exception from HRESULT: 0x80040D1B
     COMException: Exception from HRESULT: 0x80040D1B
    [11/25/2009 3:53:03 PM]: Debug:    at Microsoft.Office.Server.Search.Administration.SearchApi.RunVoidOnServer(VoidCodeToRun remoteCode, VoidCodeToRun localCode, Boolean useCurrentSecurityContext, Int32 versionIn)
       at Microsoft.Office.Server.Search.Administration.SearchApi.CatalogResumeCrawlRequest(Int32 reason)
       at Microsoft.Office.Server.Search.Administration.SearchApi.CatalogResumeCrawl(GathererPauseReason reason)
       at Microsoft.Office.Server.Search.Administration.SearchSharedApplication.Microsoft.SharePoint.Administration.Backup.IBackupRestore.OnBackupComplete(Ob


    kindly help me.
    Sunday, December 06, 2009 12:31 PM

All replies


  • It should not cause this as it pauses indexing while taking farm backup. You can make sure you have following features activated on site collection level:

    Office SharePoint Server Publishing Infrastructure

    Office SharePoint Server Search WebParts

    also reboot the server if possible as it will reprovision the search service and will fix this problem

    Let me know the results:

    Best Regards,
    Yogesh.

    Monday, December 07, 2009 1:46 PM
  • Hi,

    The error “Object Shared Search Index failed in event OnBackupComplete” may be occurred when you back up the Shared Search index. This issue has been fixed in KB961749: http://support.microsoft.com/?id=961749

    You cannot access “Search Setting” in Shared Service, could you please tell me have done any setting before accessing the page?

    Is the scope a custom scope? Have you created a search center for custom scopes?

     

    Let me know the result.


    Xue-Mei Chang
    Wednesday, December 09, 2009 1:32 AM
  • Hi Xue-Mei,


    As i know i have done one search crawl rule and nothing morethan that and till that day search was working fine without any issue.

    From next day i am getting all the above said issue with Ecent id 6482 in event viewer every one minute with below error log

    Application Server Administration job failed for service instance Microsoft.Office.Server.Search.Administration.SearchServiceInstance (09b7bfc2-1cf1-442e-b910-344e153c9f13).

    Reason: Exception from HRESULT: 0x80040D1B

    Techinal Support Details:

    System.Runtime.InteropServices.COMException (0x80040D1B): Exception from HRESULT: 0x80040D1B


    Will installing security udpates could create this problem? because after long time many updates execute by Admin in my server.

    Hi Yogesh,

    Search was working fine till last week and i haven't done any setting other than the Crawl rule added.


    I am ready to reset my Search itself.

    can any one tell me the steps i need to execute  to stop and start my search and about search database also.


    Thanks

    Hari



    Wednesday, December 09, 2009 7:25 AM
  • Dear Hari2009:-

    can you plz do the following :-
    1-  firstly, go to SSP application pool then recycle it , then try to enter search setting page,.

    2- if not, stop office search service on your servers , go to , Central Administration -> operation -> services of servers , then select the server and stop it on all servers (index servers, Query servers).

    3- then start it again and configure it as your topology (indexing, crawling),
    4- go to index files often at  "C:\Program Files\Microsoft Office Servers\12.0\Data\Office Server\Applications", you will find a folder with GUID name, rename it.
    5- go to SSP and Edit SSP from Central Administration, scroll down you will find that indexer server text box is empty , then select your index server.

    Thursday, December 24, 2009 10:57 AM
  • We faced same issue during our migration from MOSS 2007 to SP2010 where search core results web part was added to one of the page, Simply deleting and adding the search core results web part did the trick for us
    Tuesday, April 30, 2013 6:19 AM