none
The workflow could not create the list item

    Question

  • Hi there, I would be grateful for any help/pointers

    I’m new to using workflows in SP2010

    I am getting “The workflow could not create the list item. Make sure the list exists and the user has permissions to add items to the list.”

    My scenario

    I’m trying to create a new document in a library (List B) using a SPD 2010 workflow.  The originating list (List A) has a status dropdown, so when the user selects “done” – A document will be created using 2 or 3 fields from the original list.

    My attempted solution

    I am using a hosted SharePoint 2010 foundation test site. I created a basic team site

    1.       Created my List A with the following fields with some dummy data

    Name

    Type

    Sales Person

    Single line of text

    Total Purchased

    Number

    Quantity Purchased

    Number

     

     

     

     

     

     

     

     

    2.       Created a site content type with the same field names from the List A

    3.       Created a document template based on this content type in which I inserted the necessary fields (using insert Quick Parts)

    4.       This template was uploaded and saved to the site and renamed from dotx to docx

    5.       Deleted the default content type for List B and replaced it with this new document

    6.       Opened SP designer 2010 to create my workflow below

    If CurrentItem:Status equals Done
     Create Item in ListB (Output to Variable:create)

    The options selected within ListB are:

    Field

    Value

    Content Type ID

    Inv001

    Path and Name(*)

    http://hostedSP2010site/MSSPD/Comp%20Invoices/Forms/AllItems.aspx

    Sales Person

    Current Item: Sales Person

    Quantity Purchased

    Current Item: Quantity Purchased

    Total Purchased

    Current Item: Total Purchased

    (I have a feeling the Path and Name field is incorrect but not sure what syntax I should be using??)

     

    7.       Checked for errors (none), saved and published (Workflow is set to start automatically when an item is created or changed)

    8.       When I change the status to “done” the workflow column initially states “In progress” then “Error occurred”

    9.       When I click on the error I get the following: “The workflow could not create the list item. Make sure the list exists and the user has permissions to add items to the list.”

    I am logged in as Site owner so have the permissions to create items in ListB

    Any help appreciated

    • Moved by Mike Walsh FIN Sunday, February 13, 2011 5:28 PM SPD 2010 q (From:SharePoint - Workflow (pre-SharePoint 2010))
    Sunday, February 13, 2011 1:46 PM

Answers

  • I managed to resolve the problem, and as suspected it was the Path and Name syntax in SPD 2010

    In the Create New List Item dialog under Path and Name, you can use the following:

    /site_or_subsite/library_name/xxx.docx

    /site_or_subsite/library_name/xxx[%Current Item:ID%].docx

    Hope this helps someone else
    • Marked as answer by Don Will Sunday, February 13, 2011 6:10 PM
    Sunday, February 13, 2011 6:10 PM

All replies

  • > I’m new to using workflows in SP2010

    Perhaps you are also new to the SharePoint forums.

    This would be the correct forum if you had a SP 2007 (0r 2003/2001) workflow question. However there are separate forums for SP 2010 users and even though none of them are specifically for workflow questions, they are the place to post SP 2010 wf questions.

    - OOB workflow questions go to Setup/admin there

    - SPD 2010 workflow questions go to the SPD 2010 forum there

    - VS 2010 workflow questions go to the VS 2010 forum there.

    As you are asking about SPD 2010 workflow, I'll move this post to the second forum listed.

    Please in future post all SP 2010 questions you have directly to a SP 2010 forum.

    Moderator pre-2010 forums


    SP 2010 "FAQ" (mainly useful links): http://wssv4faq.mindsharp.com/default.aspx
    WSS3/MOSS FAQ (FAQ and Links) http://wssv3faq.mindsharp.com/default.aspx
    Both also have links to extensive book lists and to (free) on-line chapters
    • Marked as answer by Don Will Sunday, February 13, 2011 6:04 PM
    • Unmarked as answer by Don Will Sunday, February 13, 2011 6:05 PM
    Sunday, February 13, 2011 5:28 PM
  • I managed to resolve the problem, and as suspected it was the Path and Name syntax in SPD 2010

    In the Create New List Item dialog under Path and Name, you can use the following:

    /site_or_subsite/library_name/xxx.docx

    /site_or_subsite/library_name/xxx[%Current Item:ID%].docx

    Hope this helps someone else
    • Marked as answer by Don Will Sunday, February 13, 2011 6:10 PM
    Sunday, February 13, 2011 6:10 PM
  • I have run into the very same issue - but unfortunately the above solution did not help.

    Playing around with the workflow it still produced the same error on many combinations however if I set it to another document library it created a doc file there without any issues by just supplying a simple string (without any path or whatsoever).

    The library in question is the "Pages" which holds an Enterprise Wiki library on a subsite - and I couldnt find any solution to this. I would need the workflow to create a large number of pages (based on a title list) so the editors wouldnt have to create them one by one, but cant get across this error...

    Any insights would be welcome!

    Cheers,

    Balint

    Tuesday, March 01, 2011 9:24 AM
  • Hi,

    I had the same error, but I used a variable (really a parameter that the user input). It didn't work until I chose to "Return field as" text (and not String) when setting the Path and name..

    Wednesday, March 16, 2011 2:06 PM
  • Hello,

    Unfortunately I dont have an option to set the "Return field as" to Text - only Lookup value (as text) but that causes a totally different error message.

    I am still trying to get to the end of this and found the following (maybe it helps someone to give the right solution):

    - The create item works perfectly with any list or library where there is no Content Type (and the Path and Name can be just set to xxx and it creates xxx.doc in a default doc library for example) however the error occurs where it adds the Content Type ID field to the workflow (like in my Wiki library) now while this is added, it can also be removed by choosing modify changing the field to something else, then removing the field leaving you only with the Path and Name.

    And surprise-surprise once this is done the WF runs with "completed" and creates a document (though it doesnt append the aspx extension automatically) the bad news is that the docs created this way are useless it doesnt even load the SP frame on them (I guess because they dont have any content type set), but this might point to the reason of the error...

    Thursday, March 24, 2011 12:26 PM
  • Hi,

    if I remember correctly I had to choose the ... -symbol to and then "Add Lookup" to get this option, not the fx-symbol to the right. I am not logged in right now so take my statement with some sceptisism:)

    Thursday, March 24, 2011 7:59 PM
  • Hello,

    Yes, that was correct! By choosing that option I had "Plain Text" and "Description Text" the bad news is that with either settings I still got the same error (the permission denied one). Have to look for some more - I wonder if anything else was changed in your workflow by chance at the same time

    Monday, March 28, 2011 9:46 AM
  • Hi,

    I am also running into the same error ("The workflow could not create the list item...") while trying to create new list items under "Pages". My target content type ("Resource Descriptor") is based on an .aspx template. Does anybody know if the 'create list item' in workflow doesn't support such a content type for some reason? It works fine when I switch the content type in the WF to document or folder.

    I tried several different ways of setting the 'Path and Name' including ones listed above.

    Thanks!
    Wednesday, March 30, 2011 10:39 PM
  • Hi,

    I am also running into the same error ("The workflow could not create the list item...") while trying to create new list items under "Pages". My target content type ("Resource Descriptor") is based on an .aspx template. Does anybody know if the 'create list item' in workflow doesn't support such a content type for some reason? It works fine when I switch the content type in the WF to document or folder.

    I tried several different ways of setting the 'Path and Name' including ones listed above.

    Thanks!


    Hello again,

    Not sure if anyone is still following this, but I managed to do a workaround after much frustration:

    1. Create a page with the content type you want to create via Workflow normally

    2. With SharePoint Designer open the directory, highlight the file you created and choose export - then save it to somewhere on your computer

    3. Go back to the List you will create the items in, and under "List Settings" click on the content type in question then choose "Advanced Settings"

    4. Choose "Upload a new document template" browse to the saved file and upload it

    5. Now you can create the WF in SPD - the "Path and Name" can be set normally - no need for adding relative paths, if you set it to "Something" it will create it as "Something.aspx" under the wiki library for example - content type should be of course the one we modified.

    Notes:

    - This will render the normal document creation button for some reason unusable - this is not a problem in my case, as we use it to mass upload wiki pages - but they don't seem to function parallel.

    - In the workflow you can of course set fields normally for the newly created page

    - You can also create one Workflow to create different content types based on conditions but then you have to upload a template like above for each content type (and manual creation won't work afterwards)

    - If you want to switch back from the template - under advanced settings just switch the template file to "/_layouts/CreatePage.aspx"

    Hope this will help others - it sure did to us (not having to manually create 7000 wiki pages individually)

    Thursday, June 30, 2011 9:28 AM
  • @Balint B-

    That fixed it for me, thanks.

    Tuesday, July 12, 2011 3:03 PM
  • Hi Don,

    I am stuck with similar problem. I need to copy 2 fields from Form Library to my Document Library. I am using SPD 2010 workflow. When I chooseModify on Click on Path and Type column under Create New List Item dialog window, I got Value Assignment window.

    Under Set this field was Path and Name and "To this Value" I typed /site_or_subsite/library_name/xxx.docx. But it didn't worked.

     

    Also I changed the To this Value field to other fields through fx, but getting same error. “The workflow could not create the list item. Make sure the list exists and the user has permissions to add items to the list.” \

    Please suggest what to be done.

    Thanks

     


    $hubhangi
    Thursday, December 22, 2011 1:09 PM
  • Hello Don,

    I have the same problem as $hubhangi can you please tell us how to properly implement your solution?

    Thanks,

    Jimmy

    Tuesday, June 26, 2012 8:40 AM
  • Hello,

    I've managed to get the document name by entering this code:

    [%Current Item:Title%].docx

    Instead of:

    /site_or_subsite/library_name/xxx.docx

    or

    /site_or_subsite/library_name/xxx[%Current Item:ID%].docx

    The path is not needed in my case (SharePoint Online).

    Regards,

    Jimmy

    Wednesday, June 27, 2012 11:34 AM
  • Keen Era - This worked great for me. Thanks! 
    Monday, October 01, 2012 3:42 PM
  • I am having the same problem creating a document set via a workflow - I have tried all the variations above and keep getting the make the the list exists?  I am at wits end  - any ideas!


    --Lee

    Monday, October 29, 2012 4:19 PM
  • Ok, I was trying to catenate a text field and a date returned as a string.  This of course tried to create a folder structure under the docuement set which is not allowed. OK, I feel like an idiot for this one.

    Next, I tried to create the path and name by using the ... and catenating two fields.  That did not work either.

    Last, I used set workflow variable to do the concatenation.  then in the create list item I used function rather than ...   

    That worked!!!!!


    --Lee

    Monday, November 05, 2012 10:57 PM
  • I am trying to do something similar, and none of the solutions above have worked for me.  I am simply trying to create an item on a 'Links' list to a hardcoded full path to a URL.  I cannot seem to get the Path & Name field to accept any data whatsoever.  I continue to get the: The workflow could not update the item, possibly because one or more columns for the item require a different type of information.

    Please help!!!


    Jesse A. Brandenburg


    • Edited by 1brandeja5 Friday, March 01, 2013 10:46 PM
    Friday, March 01, 2013 10:45 PM
  • Possible solution: 

    1. Open target list in designer. 

    2. Click "Edit list columns"

    3. Find column "Name" and press "Administration web page"

    4. Chose "No" in field "Require that this column contains information"

    That's all

    Thursday, April 04, 2013 2:53 PM