none
Error: Cannot update event receiver because: Could not load file or assembly 'Microsoft.Office.InfoPath.Server, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' or one of its dependencies. The system cannot find the file specified.

    Question

  • Hi - Can you please help me with the error.

    I have exported the site collection from SP2007 using the Powershell script.

    and then importing to SP2010 using the STSADM -O Import command (as lot of problems with the Powershell script for Import).
    It started importing but failed with below errors!

    [7/25/2013 3:51:26 AM] Warning: Cannot update event receiver because: Could not load file or assembly 'Microsoft.Office.InfoPath.Server, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' or one of its dependencies. The system cannot find the file specified.
    [7/25/2013 3:51:26 AM] [List] [Form Templates] Error: Cannot update event receiver because: Could not load file or assembly 'Microsoft.Office.InfoPath.Server, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' or one of its dependencies. The system cannot find the file specified.
    [7/25/2013 3:51:26 AM] FatalError: Cannot update event receiver because: Could not load file or assembly 'Microsoft.Office.InfoPath.Server, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' or one of its dependencies. The system cannot find the file specified.

    Please help me to get out of this error.

    Thanks,
    Ramesh M

    Thursday, July 25, 2013 12:01 PM

All replies

  • Hi Ramesh,

    Do you have Office 2010 or higher version installed on SharePoint 2007 server? I found some similar issue for SharePoint 2010 when Office 2013/InfoPath 2013 installed on the server. The resolve is to remove InfoPath 2013 (not need to uninstall all Office 2013).

    PS: To move SharePoint 2007 site to SharePoint 2010, usually we need to Mount-SPContentDatabase command to upgrade content database. I’m not sure if it also works with export/import command. If you have further problem to move the site, I would like suggest you try the steps in the following thread.
    http://social.technet.microsoft.com/Forums/sharepoint/en-US/c1f35ecc-d029-458c-af79-b6692bdc57dd/move-a-site-from-moss-2007-to-sharepoint-2010

    Thanks & Regards,
    Emir


    Emir Liu
    TechNet Community Support

    Friday, July 26, 2013 9:41 AM
  • Hi Emir - Thanks for your reply!<o:p></o:p>

    Everything correctly
    installed with same version.

    Thanks,

    Ramesh M<o:p></o:p>


    Monday, July 29, 2013 9:22 AM
  • Hello Ramesh,

    Please confirm if you have any custom event receiver, which the InfoPath form is referencing from the old dll. I would suggest to try the below step & check the behavior. If this also fails, then you will need to re-compile the event receiver in the 2010 bits. Also, export / import from MOSS 2007 to SPS 2010 will not work as it will fail with version mismatch. I would strongly suggest to use db attach method to upgrade to 2010 & then perform an export / import of the sub-site.

    1. Backup the content database from Moss 2007 Environment
    2. Restore the content database to new sql server instance
    3. Attach the database to SPS 2010 site collection.


    Regards, Dhiraj(DJ)-MSFT |Microsoft Online Community Support

    Monday, August 12, 2013 2:37 PM