none
Problem on Specifying Active directory group name in Web part target audience

    Question

  • Hi,
     
    Today I have a problem on specifying active directory group name in web part target audience. When we specify, it throws the error like, "No exact match was found". But if we specify the same active directory group name in advanced "permissions->Add users" page, the group name has taken. Could you please anyone explain about why it is not taken in the target audience?

    Regards,
    Prakash
    www.aristonsoft.com - .net 3.5 hosting provider in India
    Tuesday, February 24, 2009 12:46 PM

Answers

  • Hi,

    The behavior is by design. SharePoint will not unwind AD groups for audience feature to work as this will cause performance issue.

    The workarounds are:

    1.     Directly add the user to the SharePoint group or use role provider (form based authentication) and then use this for targeting.

    2.     Create Audience through SSP admin site -->Audiences link and add a rule to get the users only from a particular AD group.

    Hope it can help you.


    Xue-Mei Chang
    Thursday, February 26, 2009 4:00 AM
    Moderator

All replies

  • Hey Prakash, the Target Audience is specifically an Audience created through Central Administration.  To set up an Audience head into your SSP's Web Administration interface and set up the Audiences in the User Profiles section.  Cool?

    Here's a link to show where to create Audiences...http://technet.microsoft.com/en-us/library/cc262334.aspx#section1

    Update: In addition to the Audiences, it's also for SharePoint Groups, Distribution Lists and Security Groups...see here...http://office.microsoft.com/en-us/sharepointserver/HA101690531033.aspx

    Thanks! - M

    - Michael Mukalian - MCTS: MOSS 2007 Configuration - http://www.mukalian.com/blog
    Tuesday, February 24, 2009 1:48 PM
  • Hi Prakash,

    Try importing user profile information
     http://support.microsoft.com/kb/827754

    Thanks,
    Prasath C
    Tuesday, February 24, 2009 1:50 PM
  • Hi,

    The behavior is by design. SharePoint will not unwind AD groups for audience feature to work as this will cause performance issue.

    The workarounds are:

    1.     Directly add the user to the SharePoint group or use role provider (form based authentication) and then use this for targeting.

    2.     Create Audience through SSP admin site -->Audiences link and add a rule to get the users only from a particular AD group.

    Hope it can help you.


    Xue-Mei Chang
    Thursday, February 26, 2009 4:00 AM
    Moderator
  •   Hi Xue-Mei,

    In my case, some of AD groups (Security and Distribution groups) can populated in target audience. But some of them are not.

    As you suggested if I create the Sharepoint group and add the member as that group name, it's working. But I want to make sure, in Target audience section of the web part, even we have an option to specify Security and Distribution group name, why some group names are not coming?

    Regards,
    Prakash


    www.aristonsoft.com - .net 3.5 hosting provider in India
    Thursday, February 26, 2009 7:19 AM
  • Caused kind of trouble here: we're running a sharepoint farm with german translation. There it says "Groups" instead of "Audiences". I always wondered why SP isn't syncing the AD-groups.

    So, thanks for the explanation!

    Monday, July 02, 2012 9:39 AM