none
Sharepoint Search error and event_id 2424

    Question

  • Hi !

     

    i have a problem with the search service of sharepoint.

    looking at the logs of windows i see this error event:

     

    event_id:2424

    The update cannot be started because the content sources cannot be accessed. Fix the errors and try the update again.
      Context: Application <application name> Catalog <catalog name>. 

     

    what does that mean ?

    thank you

    Monday, May 28, 2007 3:39 PM

Answers

  • This issue occurs when the service account for the Windows SharePoint Services Search service is configured to use the Network Service account. The search service account must not use a built-in account to access the Windows SharePoint Services 3.0 database. An example of a built-in account is the Local Service account or the Network Service account.

     

    See the KB article http://support.microsoft.com/default.aspx/kb/927012

    Wednesday, May 30, 2007 11:05 PM

All replies

  • This issue occurs when the service account for the Windows SharePoint Services Search service is configured to use the Network Service account. The search service account must not use a built-in account to access the Windows SharePoint Services 3.0 database. An example of a built-in account is the Local Service account or the Network Service account.

     

    See the KB article http://support.microsoft.com/default.aspx/kb/927012

    Wednesday, May 30, 2007 11:05 PM
  • I started receiving this error on a Sharepoint Services install at the time I used SelfSSL from the IIS 6 Resource Kit to install an SSL certificate.  The first thing I did was check and use a Domain account as outlined in 927012.

     

    Any other ideas?

     

    Thanks,

    James Keirstead

    Information Technology

    Perigon Engineering

     

    Tuesday, September 11, 2007 2:11 PM
  •  

    Hi, I'm having the same problem too.

    I'm using the same domain account for the search service and content access accounts.

    Sorry I can offer any suggestions but I wanted to let you know your are not alone with this one.

    Cheers,

    Tony

    Wednesday, September 12, 2007 1:58 PM
  •  

    I've had some progress with this.

    I noticed that I had a bogus entry in the Start Address section of Shared Services Administration > Search Settings > Content Sources > Edit Content Source page.

    There was an entry of the form http://myServer:34819.

    I havn't got a virtual server running on that port so I removed the entry and did a full crawl.

    Now, I am still getting the event log entries but my index now contains the sites that were sucessfully crawled from my other virtual servers!

    I can only sucessfully search when remote desktop'd to the server.

    Searching remotely via a browser still returns an unknown error.

    A step in the right direction methinks.

    Hope this helps,

    Tony

    Wednesday, September 12, 2007 2:58 PM
  •  

    Adding a firewall exception for the central admin web application seems to have stopped the 2424's.

    But know I'm getting ID 2436  (warnings) instead.

    I still can't access mysite or search unless I'm on the server.

    Cheers,

    Tony

    Monday, September 17, 2007 12:27 PM
  •  

    I'm getting 2424 errors on a WSS 3 server that is only crawling local content. I've beed assuming they are due to a security misconfiguration of so some sort, could they be due to a network connectivity issue? Is searching/crawing done via network port/pipes?
    Wednesday, October 17, 2007 11:57 PM
  • This behavior can be produced if you use two different account for "Service Account" and "Content Access Account" in

    «Windows SharePoint Services Help Search» (Central Administration > Operations > Services on Server).

     

    Solution:

    give Read permissions to Registry key:

    HKEY_USERS\…(Service Account SID)…\Software\Microsoft\Windows\CurrentVersion\Internet Settings

    for Content Aces Account user.

    Restart "Windows SharePoint Services Search" service.

     

    This worked for me.

     

    Tuesday, November 13, 2007 1:32 PM
  • Thanks. I've seen several different answer for this type of problem, all pointing to different details in the server configuration. I've also read the documentation on setting up WSS and what accounts to use for what services.

     

    The bottom line: Microsoft could make things a lot easier on many people with better testing and documentaton and by making SharePoint less vulnerable to interactions with OS and .Net security, IIS, SQL Server, the registry ... oh, wait, I forgot they make those hard to maintain, too. Sigh ... where is the real competition from the rest of the software induware when you need it?

     

    Tuesday, November 13, 2007 7:46 PM
  • If you're still coming across this error, I've posted a resolution that has worked in all my tests:

    http://www.raregrooverider.com/post/2008/02/SharePoint-Services-Search-Error-Event-ID-2424.aspx

     

    Cheers!

    ::k::

    Wednesday, March 12, 2008 8:32 PM
  • I think that those errors are related...look this follow link to fix another issue:

    http://social.technet.microsoft.com/Forums/en/sharepointsearch/thread/84f93fbe-f4a6-4683-b25b-b595b9006ad7

    I have both erros...2424  and 2436...

    for security reasons, I can't do the step of regedit:

    "1) Click Start, click Run, type regedit, and then click OK.
    2) In Registry Editor, locate and then click the following registry key:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    3) Right-click Lsa, point to New, and then click DWORD Value.
    4) Type DisableLoopbackCheck, and then press ENTER.
    5) Right-click DisableLoopbackCheck, and then click Modify.
    6) In the Value data box, type 1, and then click OK.
    7) Quit Registry Editor, and then restart your computer."

    pls, anybody knows how we can fix those errors?

    the farm user is the same for everything and all services, and this user has all necessary permissions (SQL Server, IIS, Windows Server... ).

    tks!!!!!!

    Monday, June 07, 2010 6:19 PM