none
Installation errors in Sharepoint 2010

    Question

  •  Am trying to install Sharepoint 2010 on Windows 7 64 bit but  the setup is not getting completed and   i get an error "Microsoft SharePoint server 2010 encountered an error during setup. One or more required office components failed to complete successfully" . managed sql server installer has stopped working.  I have already installed  SQL Server 2005 and Visual Studio 2010 on my machine. Thanks.

    Friday, January 07, 2011 1:17 PM

Answers

  • Hi,

    Installing SharePoint 2010 on Windows 7 is recommended only for developer workstations and should be used only for stand-alone installations. You can use a separate Microsoft SQL Server instance, but you should not configure your installation as a SharePoint farm and you should not host active sites on this configuration, and you cannot use PrerequisiteInstaller.exe on Windows 7. For more information, please refer to: http://msdn.microsoft.com/en-us/library/ee554869.aspx

    And please go to 14\logs directory and event viewer to check if there has any error message about this issue.

    Let me know the result.


    Xue-Mei Chang
    Wednesday, January 12, 2011 3:42 AM

All replies

  • Is there anything in the event viewer?

    What is the service pack / cumulative update of the SQL Server.

    Do you have Office 2010 Beta installed?

    Did you run the pre-req for SP2010


    Alpesh Nakar's Blog Alpesh Just SharePoint Just SharePoint Updates

    SharePoint Saturday India Online Nov 20 2010 Contributing Author SharePoint 2010 Unleashed

    MCTS: SharePoint 2010 Configuration MCITP: SharePoint 2010 Administrator

    Friday, January 07, 2011 1:26 PM
  • Hi Vins10,
    Please check
    http://davidlimsharepoint.blogspot.com/2010/08/microsoft-sharepoint-server-2010.html
    Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    Friday, January 07, 2011 1:36 PM
  • can you try what is mentioned in article... thing is that you have already installed sql 2005 installed. you can try installing standalone installation type.

    What type of installation selection are doing ? standalone or farm?


    san
    Friday, January 07, 2011 1:37 PM
  • In my system there is no PendingFileRenameOperations in regedit, it is just FileRenameOperations and there is no value associated with it.  I again tried and still it is the same issue.


    I have been trying standalone  installation .

    I do not have Office 2010. I have only  Office 2007 installed on my machine.

    Also i guess there is no Pre-req for SP 2010 for Windows 7.

    Thanks

    Monday, January 10, 2011 12:33 PM
  • Hi,

    Installing SharePoint 2010 on Windows 7 is recommended only for developer workstations and should be used only for stand-alone installations. You can use a separate Microsoft SQL Server instance, but you should not configure your installation as a SharePoint farm and you should not host active sites on this configuration, and you cannot use PrerequisiteInstaller.exe on Windows 7. For more information, please refer to: http://msdn.microsoft.com/en-us/library/ee554869.aspx

    And please go to 14\logs directory and event viewer to check if there has any error message about this issue.

    Let me know the result.


    Xue-Mei Chang
    Wednesday, January 12, 2011 3:42 AM
  • I tried again  a fresh installation but it failed at the last moment. It was in the process of "applying updates" and it failed with this message

    "Microsoft Sharepoint 2010 encountered an error - one or more office components failed  to complete successfully"

    I opened the setup log file and this is the end of the file error message

     

    MSI(COMMONDATA): '1: 2 2: 0 '
    MSI(COMMONDATA): '1: 2 2: 1 '
    MSI(TERMINATE): '<NULL>'
    PERF: TickCount=780941 Name=MsiPackage::Install Description=Returned from OMsiInstaller::InstallProduct
    Successfully installed package: oserver path:D:\Sharepoint 2010\en_sharepoint_server_2010_x64_dvd_518634\Global\oserver.MSI
    Executing command path: 'C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\BIN\stsadm.exe', args: 'updateproductinfo'
    Start C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\BIN\stsadm.exe updateproductinfo
    Command 'C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\BIN\stsadm.exe' returned: 0
    Executing command path: 'C:\Program Files\Common Files\Microsoft Shared\SERVER14\Server Setup Controller\dbwrap.exe', args: 'timeout=2950'
    Start C:\Program Files\Common Files\Microsoft Shared\SERVER14\Server Setup Controller\dbwrap.exe timeout=2950
    Error: Command: 'C:\Program Files\Common Files\Microsoft Shared\SERVER14\Server Setup Controller\dbwrap.exe' failed with error code: -2068578304. Type: 8::CommandFailed.

    Showing completion dialog.
    Catalyst execution finished: 01/19/2011 17:58:38.  Return code: 8.
    PERF: TickCount=1071180 Name=RunSetup Description=End function

    Setup temp folder set to [C:\Users\vinodk7\AppData\Local\Temp\Setup0000080c].

    Let me know if  i am missing something here in this installation.

     

    Thanks,Vin

    • Proposed as answer by vishumca2003 Wednesday, November 16, 2011 10:06 AM
    • Unproposed as answer by vishumca2003 Wednesday, November 16, 2011 10:06 AM
    Wednesday, January 19, 2011 12:35 PM
  • Hi Vin,

    I faced the same issue that you mentioned. I removed the Sharepoint installation, uninstalled the SQL server 2008 installation. After that

    I installed "Windows Install Cleanup Utility" and removed Sharepoint 2010 and SQL server entries from the utility. I reinstalled Sharepoint and the error was gone.


    Vishal Sharma
    Wednesday, November 16, 2011 10:10 AM
  • I had just encountered similiar issue:

    I installed sharepoint in standalone mode in my develope machine. And i had upgraded the SQL Server express to SQL Server Developer version.

    Now i cannot run repair install for SharePoint, i will get the same error.

    dbwrap is something related to SQL Server Express installation.

    I can find DBWrapLog file in %temp% folder, which contains the following line:

    INF:0:Get value SINGLESERVER from reg HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\14.0\WSS\ServerRole.

    I changed the SINGLESERVER to APPLICATION, then the repair installation works.

    • Proposed as answer by simbur69 Friday, March 16, 2012 5:53 AM
    Friday, December 02, 2011 6:19 AM
  • GuYming, this fixed my problem.   I have SQL Server 2008 standalone on Win 7 x64.    Editing the registry entry as you indicated and running repair worked like a charm.  2 days of hair pulling!  Thanks man!
    Tuesday, February 07, 2012 2:33 PM
  • Just had this exact same error, I have just installed a single server setup with the following:

    - Win 2008 R2 Enterprise SP1

    - SQL 2008 R2

    - SharePoint 2010 SP1

    This fix has also worked for me.  Thanks for your help resolved in 15 minutes instead of 2 days!

    Cheers!

    Friday, March 16, 2012 5:53 AM
  • i would encourage doing this on a test or dev environment. I won't recommend change the registry entry in production environment since i did not see document from product group about this.

    Friday, March 16, 2012 6:12 AM
  • Wow, saved me many hours as well.

    Helped save the day.

    Tuesday, May 22, 2012 7:07 PM
  • Still work

    Many Thanks

    Thursday, July 19, 2012 6:20 PM
  • This fix also worked for me.  Thanks!

    Friday, November 02, 2012 3:18 PM
  • Worked for me - thanks!
    Saturday, November 17, 2012 10:56 PM
  • Thank you very much, this worked for me :-)
    Tuesday, March 05, 2013 1:42 PM
  • Windows 7 64bit // SQL 2008 R2 
    This registry entry worked for me.


    Wednesday, August 21, 2013 9:40 PM