none
IIS 7.0 Error ?

    Question

  • problem with iis

    HTTP Error 500.19 - Internal Server Error

    The requested page cannot be accessed because the related configuration data for the page is invalid.

     

    Module IIS Web Core
    Notification Unknown
    Handler Not yet determined
    Error Code 0x8007052e
    Config Error Can not log on locally to C:\inetpub\wwwroot\wss\VirtualDirectories\33267 as user WALCHAND\gtdeshmukh with virtual directory password
    Config File \\?\C:\inetpub\temp\apppools\SharePoint Central Administration v4\SharePoint Central Administration v4.config

     

    <application path="/" applicationPool="SharePoint Central Administration v4">
      146:                     <virtualDirectory path="/" physicalPath="C:\inetpub\wwwroot\wss\VirtualDirectories\33267" userName="WALCHAND\gtdeshmukh" password="[enc:AesProvider:OmEWegg0EC5bPF/MitVmEmDVgTI+k1nCdO66R3gL/eA=:enc]" />
      147:                     <virtualDirectory path="/_vti_bin" physicalPath="C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\isapi" />

     

     
    Thursday, August 25, 2011 12:57 PM

Answers

  • Looks like the user account you're using for your app pool doesn't have rights to the web site directory, so it can't read config from there. Check the app pool and see what user it is configured to run as. Check the directory and see if that user has appropriate rights to it. While you're at it, check the event log and see if IIS logged any more detailed diagnostic information there

    check this url

    http://stackoverflow.com/questions/929131/how-do-i-resolve-http-error-500-19-internal-server-error-on-iis7-0


    Regards, Fadi Abdulwahab. http://sqlgoogler.blogspot.com/ Please click "Propose As Answer" if a post solves your problem or "Vote As Helpful" if a post has been useful to you
    • Marked as answer by Seven M Monday, September 05, 2011 1:57 AM
    Thursday, August 25, 2011 3:05 PM
  • Hi Gajendra

    Please give me the detailed information you have been encountering now. I think you are having the error like this (http://thuansoldier.net/?p=1649). I'm not sure but I encountered HTTP 500 Internal Server Error because of the following:

    • The account, which was used for SharePoint 2010 Configuration Wizard, didn't have enough permission (a member of Local Administrator group).
    • Antivirus software prevented the host header so I couldn't run named-site collection and had HTTP 500 Internal Server Error.
    Cheers,

    SharePoint in Vietnam Blog: The SharePoint diary
    • Marked as answer by Seven M Monday, September 05, 2011 1:57 AM
    Thursday, August 25, 2011 3:38 PM

All replies

  • Looks like the user account you're using for your app pool doesn't have rights to the web site directory, so it can't read config from there. Check the app pool and see what user it is configured to run as. Check the directory and see if that user has appropriate rights to it. While you're at it, check the event log and see if IIS logged any more detailed diagnostic information there

    check this url

    http://stackoverflow.com/questions/929131/how-do-i-resolve-http-error-500-19-internal-server-error-on-iis7-0


    Regards, Fadi Abdulwahab. http://sqlgoogler.blogspot.com/ Please click "Propose As Answer" if a post solves your problem or "Vote As Helpful" if a post has been useful to you
    • Marked as answer by Seven M Monday, September 05, 2011 1:57 AM
    Thursday, August 25, 2011 3:05 PM
  • Hi Gajendra

    Please give me the detailed information you have been encountering now. I think you are having the error like this (http://thuansoldier.net/?p=1649). I'm not sure but I encountered HTTP 500 Internal Server Error because of the following:

    • The account, which was used for SharePoint 2010 Configuration Wizard, didn't have enough permission (a member of Local Administrator group).
    • Antivirus software prevented the host header so I couldn't run named-site collection and had HTTP 500 Internal Server Error.
    Cheers,

    SharePoint in Vietnam Blog: The SharePoint diary
    • Marked as answer by Seven M Monday, September 05, 2011 1:57 AM
    Thursday, August 25, 2011 3:38 PM
  • The issue here got resolved for me like below. Hope it helps someone.

    Check the credentials you have provided under 

    IIS (7.0) -> Sites -> YourSite (Right Pane) -> Manage Website -> Advanced Setting -> Physical Path Credentials 

    Reset this to appropriate 

    Wednesday, January 01, 2014 11:11 AM