none
"Document not Saved" in Excel 2007 - using Windows XP Pro and Office 2007 Pro

    Question

  •  

    Hello folks,

     

    I am having an issue with all of my Excel documents saving from the network drive.  Whether I open the document then "save as" 97- 2003 or just do a straight "save" it will always come up as "Document not saved".  I open some Word files and get a different error, "There has been a network or file permission error.  The network connection may be lost (the drive contents here)"  Now I am online and can do emails and open other documents from the network so I know my network connection is not lost.  I work right off the LAN and not wireless.

     

    I did take the file in both Excel and Word and copy them to the local drive then try the open / save as and it will work great like that no problem.  Although this is a "work around" is there something I am missing?  Our corporation has many new machines running Windows XP Pro along with Office 2007 Pro and this was the first I had seen this problem with.  This is a laptop, but again others work fine ( that I know of)

     

    Thanks,

    Mark

    Thursday, February 07, 2008 5:14 PM

Answers

  • The Way to fix this problem is to go to the

     

    Control Panel

    Select Offline Files

    Then Disable Offline Files

    Restart the computer

    Everything should work after that.

     

    • Marked as answer by Mike Walsh FIN Tuesday, February 17, 2009 5:25 PM
    Thursday, March 20, 2008 6:19 PM

All replies

  • Mark, we are experiencing the exact, same problem. 

     

    If you find a more permanent resolution, please post.  Thanks.

    Wednesday, February 13, 2008 8:00 PM
  • The Way to fix this problem is to go to the

     

    Control Panel

    Select Offline Files

    Then Disable Offline Files

    Restart the computer

    Everything should work after that.

     

    • Marked as answer by Mike Walsh FIN Tuesday, February 17, 2009 5:25 PM
    Thursday, March 20, 2008 6:19 PM
  •  

    I have the same issue. Any answers?
    Monday, March 31, 2008 11:02 PM
  • This tip fixed my problem, thank you!
    Monday, May 05, 2008 9:08 AM
  • This is not a fix but a workaround. I am having the same issue but need my offline files!!
    Wednesday, June 25, 2008 2:17 AM
  • We are seeing this also - anything new on this?  I haven't seen anything additionally posted to fix this.  The Offline Files fix didn't correct the problem in our case.

     

    Thursday, June 26, 2008 10:59 PM
  • I too have run into this problem. I am running Excel 2007 and trying to save an offline file (i.e. one that normally lives on the network but has been copied to my computer and gets synchronized with the network files) in Excell 97-03 Workbook format. I get the message "Document not saved."

    I have found that if I do a Save As and save the file to my desktop, then copy it back to the original location on my computer, it works.
    Thursday, August 28, 2008 7:51 PM
  •  To prevent this problem from occurring, you can add the NetworkResiliency and PivotTableNetworkResiliency subkeys to the registry. To do this, follow these steps.

    Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
    1. Click Start, and then click Run.
    2. In the Open box, type regedit, and then click OK.
    3. In the left pane, expand the following items in the order that they appear, as appropriate for the version of Excel that you are running.

      Microsoft Excel 2002
      HKEY_CURRENT_USER
      Software
      Microsoft
      Office
      10.0
      Excel
      Microsoft Office Excel 2003
      HKEY_CURRENT_USER
      Software
      Microsoft
      Office
      11.0
      Excel
      Microsoft Office Excel 2007
      HKEY_CURRENT_USER
      Software
      Microsoft
      Office
      12.0
      Excel
    4. In the left pane, click the Options folder.
    5. On the Edit menu, point to New, and then click DWORD Value.
    6. Type NetworkResiliency, and then press ENTER.
    7. Double-click the NetworkResiliency icon.
    8. In the Value data box, type 1, and then click OK.
    9. On the Edit menu, point to New, and then click DWORD Value.
    10. Type PivotTableNetworkResiliency, and then press ENTER.
    11. Double-click the PivotTableNetworkResiliency icon.
    12. In the Value data box, type 1, and then click OK.
    These changes take effect the next time that you start Excel. For both registry keys, setting the key to 0 turns the setting off and 1 turns the setting on. The only difference between the two registry keys is that the default value when the registry keys are not present are On for VBA and OLE, and Off for PivotTable Cache.
    • Proposed as answer by WrongfulLeaf Monday, February 16, 2009 8:46 PM
    • Unproposed as answer by Mike Walsh FIN Tuesday, February 17, 2009 5:23 PM
    • Proposed as answer by WrongfulLeaf Friday, February 20, 2009 3:47 PM
    Tuesday, January 13, 2009 5:29 PM
  • have you tried the fix that i posted about document not saved in office 2007? or did you find another fix?
    Tuesday, February 17, 2009 4:30 PM
  • have you tried the fix that i posted about document not saved in office 2007? or did you find another fix?
    They won't - it's just another PoS broken M$ application that never had any QA check.
    Monday, August 31, 2009 3:17 PM
  • We have only recently (~ second week of April, 2010) experienced this problem but it is affecting Word 2007 as well and likely all MS Office 2007 products.  Initially I thought that it may have been caused by a recent MS Security Update.

    I tried the Registry fix that was suggested but to no avail. 

    I perform a nightly backup of selected server shares to an external hard drive for redundent backups.  I recently created a folder on the ext. drive and imposed quotas on it.  It forced the quota on all users in the domain for that share.  During the backup, it copies the ntfs security properties from the server shares to the backed up folders on the ext HD.  I'm wondering if that has done something.  I disabled the quota then performed the backup and now receive an error that it cannot copy the  ntfs security to the ext HD folders.  Strangely, though, I can't save office 2007 documents to ANY folder location on the affected servers - not even folders that are omitted in the backup so I'm not sure that quotas are a part of the problem.  Whatever the problem, it appears to be server specific.  Also, the servers that are experiencing the problem have NT 4.0 OS.

    Tuesday, April 20, 2010 4:05 PM
  •  Also, the servers that are experiencing the problem have NT 4.0 OS.

    MISDir458,

     

    The issue is not related to quotas. I have two NT 4.0 servers and am having the same problem. The interesting thing is that there is one XP pro machine I am currently testing that does not have this problem of saving to theshares.

     

    I do have four other machines that do have this problem.  It may be related to XP (leaning more towards office) updates but have not fully started peeling them off. I first came accross this on this past Monday. I had never before had this type of problem. I HAVE attempted removing and recreating shares (failed). I have attempted the Microsoft Office integrated repair tool (failed). I have verified NT server privileges (failed). Any other basic troubleshooting like clearing cache, prefetch, etc. made no difference either.

     I have tested saving to NT from a Server 2003 and it was successfule.

    I have NOT attempted Office reinstallation or NT server account recreation yet.

    Tuesday, April 20, 2010 4:29 PM
  • OK, here is the solution. As is always the problem. THere is an Microsoft security update that has caused this problem. Remove it, restart machine and presto.

     

    The update to remove is KB980232.

    • Proposed as answer by kmartin2264 Thursday, June 10, 2010 1:28 PM
    Tuesday, April 20, 2010 5:01 PM
  • Thank you so much, "E".  Removing the KB980232 works for me.

    I'm using Windows XP Pro and Office 2007.  Saving to a network share giving me the "Document not saved." message. 

    Saturday, April 24, 2010 2:00 AM
  • Thank you for this solution. Resolved the problem for me where we were unable to save Office 2007 files to a DFS share. We could save the files if we used a UNC path.
    Thursday, June 10, 2010 1:29 PM
  • Some of our computers do not have the security update KB980232 installed even though they are up-to-date with the Microsoft updates.  I searched the registry and couldn't find it.  So removing the KB980232 is not a solution for me in this case.  I went to this link http://support.microsoft.com/kb/983458/en-us and downloaded the hotfix.  The problem is fixed after I installed this hotfix.  You can try to install this hotfix before removing the security update KB980232.  This hotfix also resolved the same issue for Microsoft Office 2010.  Hope this helps.
    Monday, July 26, 2010 10:24 PM
  • Finally, this solution worked.
    Wednesday, July 28, 2010 4:55 PM
  • Some of our computers do not have the security update KB980232 installed even though they are up-to-date with the Microsoft updates.  I searched the registry and couldn't find it.  So removing the KB980232 is not a solution for me in this case.  I went to this link http://support.microsoft.com/kb/983458/en-us  and downloaded the hotfix.  The problem is fixed after I installed this hotfix.  You can try to install this hotfix before removing the security update KB980232.  This hotfix also resolved the same issue for Microsoft Office 2010.  Hope this helps.

    This solution worked for me. Thanks.
    Thursday, September 09, 2010 2:16 PM
  • Yep, this helped me too - thanks very much!
    Monday, October 18, 2010 11:38 AM