none
How to create a hyperlink inside a folder?

    Question

  • Hello

    If i click "New" inside my folder in sharepoint, i can only see "new document" and "new folder".

    I need to create a hyperlink. This hyperlink opens a document that resides in another server.

    How can i create a hyperlink inside my folder?
    • Moved by Mike Walsh FIN Thursday, March 11, 2010 10:21 AM admin q (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Thursday, March 11, 2010 10:16 AM

Answers

  • If you are saying that you want the folder to allow you to store documents and also to store hyperlinks to documents that exist elsewhere, you can do the following:

    • Go to Document Library > Settings > Document Library Settings > Advanced Settings
    • Set Allow management of content types to "Yes"
    • From Document Library Settings page, under the Content Types section, click Add from existing site content types
    • Choose Link to a Document, click OK
    • Now when you click New in the document library you will have an addition option for Link to a Document

    Just keep in mind that with this option it looks like you have to specify a hyperlink as "http://...", not a network path as \\server\share\filename, which may or may not work in your scenario.

    Thursday, March 11, 2010 8:58 PM

All replies

  • Hello Poppe2,

    To create a New Column of type Hyperlink, following these steps:

    1) Goto your respective Document/List Library and choose the newly created folder.
    2) Click on Settings -> Document/List Library Settings
    3) Choose "Create column"
    4) Type the column name, and choose the type as "Hyperlink"
    5) Click OK to save.

    Now when you create a New document/list item, you will have an option to fill in the URL details too.

    Hope this helps.

    Thanks & Regards,
    Kamlesh | Blog | Twitter 
    Posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, March 11, 2010 11:22 AM
  • If you are saying that you want the folder to allow you to store documents and also to store hyperlinks to documents that exist elsewhere, you can do the following:

    • Go to Document Library > Settings > Document Library Settings > Advanced Settings
    • Set Allow management of content types to "Yes"
    • From Document Library Settings page, under the Content Types section, click Add from existing site content types
    • Choose Link to a Document, click OK
    • Now when you click New in the document library you will have an addition option for Link to a Document

    Just keep in mind that with this option it looks like you have to specify a hyperlink as "http://...", not a network path as \\server\share\filename, which may or may not work in your scenario.

    Thursday, March 11, 2010 8:58 PM
  • Thanks for the replies.

    The thing i'm trying to accomplish is just as you mentioned:

    Link should appear as document name, e.g "Installation program"

    And link should be specified as \\server\share\filename

    Is this possible?
    Should i create a "data connection library" instead of "document library"?
    Friday, March 12, 2010 6:31 AM
  • How about doing this one:

    - Site Actions -> Create -> Tracking Section - Links.

    By doing this, you can create a Links.  In the URL field, specify your server path \\server\share\filename

    I just tried this and it works.

    Hope this helps.
    Thanks & Regards,
    Kamlesh | Blog | Twitter 
    Posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, March 12, 2010 6:45 AM
  • I found out a way around the problem. Somebody had posted the guide below, and it works :)

    If i try to create a new hyperlink with "file://" prefix i will get an error saying i need to use "http:// or https://". This guide helps you to go around the problem.

    Thanks everybody for their help.

    BR,
    Poppe


    --------------

    Hi there,

    I recently ran into a very simlar problem and ended up finding a quick work around for it one which doesn't require you to insert any additional functions(i didn't have the permissions to do this on the site). Here's what I did, so far it seems to be working fine.

    1) Create a new document link (ie. New->Link to a new document...in a shared workspace)

    2) When it asks for the url enter anything that it will accept(i used http://google.com). This will get you past the error with http: not being found

    3) Now click accept and go back to the main screen. Then edit the properties of this link; here is should give you the option to change the URL again. Enter the file://<comptername><filename.xls> component here. This time when you hit accept it will not check for "http:" in your field.

    4) Give the new link a try. If it works anything like it did with me then you should be good to go

    Friday, March 12, 2010 7:05 AM