none
Programmatic webdav/unc access requires user logon to windows server 2008 R2

    Pregunta

  • I have an automated process (a .net windows service) that connects to sharepoint document library via a UNC (\\mysharepointsite\doclib).  When the machine is rebooted, accessing this folder results in a  System.IO.IOException: The network name cannot be found exception.

    However, if we log into the windows server 2008 r2 machine under the account that the service is running on, it starts working, and continues to work even when we log out.  It continues to work until we reboot the computer.

    I've already run into and solved other user-centric fixes for 2008.  For example, the "Desktop Experience" feature is required to browse the path and all, and unchecking "automatically detect settings" significantly speeds up browsing of these paths.  However, I'm not sure what user logon initializes that would be fixing this problem.

    martes, 17 de enero de 2012 13:59

Respuestas

  • We have solved the issue.  The WebClient service is set to manually start by default.  Actions like browsing thru windows explorer or using the net use command seem to cause the WebClient service to start.  We merely needed to set the WebClient service to start automatically.

    • Marcado como respuesta b_levitt lunes, 16 de abril de 2012 18:33
    lunes, 16 de abril de 2012 18:32

Todas las respuestas

  • Check in IIS if those modules RequestFilteringModule and WebDAVModule are enabled for your SharePoint web app. If yes disable them and try again.


    MCITP|MCTS SharePoint| SharePoint Performance blog
    martes, 17 de enero de 2012 20:05
  • To be clear, this is a problem only on the servers trying to access the sharepoint unc folder, not on the sharepoint server itself.  Sharepoint serves the files via UNC over webdav fine to everything but these freshly rebooted windows 2008 servers.
    miércoles, 18 de enero de 2012 22:23
  • I have the same problem. Impossible on one computer on Windows Server 2008 R2 to access to the sharepoint document library via a UNC. Have you a solution please ? 
    miércoles, 15 de febrero de 2012 10:01
  • sfantini, this thread applies to the intermittant problem that is resolved simply by logging in.  If you are constantly having this issue, my guess would be that you have not installed the "Desktop Experience" feature on your server. 
    lunes, 20 de febrero de 2012 15:03
  • Are they're any other thoughts here?  Why do I need to initialize a user session in order for unc sharepoint access to work?
    lunes, 20 de febrero de 2012 15:04
  • I can provide sample code to reproduce the issue if necessary (although it's literaly just creating a folder via standard System.IO classes in a sharepoint folder via UNC) .  But any assistance here would be grateful - monthy maintenance reboots makes this a reocurring problem for me.
    lunes, 16 de abril de 2012 13:10
  • I can further simplify this.  The following command will fail initially:

    dir \\myspserver\mypath

    However, running the same command after browsing to the same path in windows explorer succeeds.  At this point I've eliminated the programming as an issue so i will try to post a similar question on technet.  However, please let me know if anybody has any further info.

    lunes, 16 de abril de 2012 15:09
  • We have solved the issue.  The WebClient service is set to manually start by default.  Actions like browsing thru windows explorer or using the net use command seem to cause the WebClient service to start.  We merely needed to set the WebClient service to start automatically.

    • Marcado como respuesta b_levitt lunes, 16 de abril de 2012 18:33
    lunes, 16 de abril de 2012 18:32