none
Error in Search Administration - Event ID: 6482

    Question

  • Hi All,

    I could see errors in the Event Viewer with Event ID: 6482 for every minute. Following is the error message:

    Application Server Administration job failed for service instance Microsoft.Office.Server.Search.Administration.SearchServiceInstance (GUID).

    Reason: Object reference not set to an instance of an object.

    Techinal Support Details:
    System.NullReferenceException: Object reference not set to an instance of an object.
       at Microsoft.Office.Server.Search.Administration.SearchServiceInstance.InstallGathererApplicationIf()
       at Microsoft.Office.Server.Search.Administration.SearchServiceInstance.Synchronize()
       at Microsoft.Office.Server.Administration.ApplicationServerJob.ProvisionLocalSharedServiceInstances(Boolean isAdministrationServiceJob)

    and i could see all errors in Search Administration page too. Please find the figure below:

    Other than this, i could see another error with Event ID: 5214 saying 

    Insufficient SQL database permissions for user '' in database 'SharePoint_Config' on SQL Server instance 'IP address'. Additional error information from SQL Server is included below.

    The EXECUTE permission was denied on the object 'proc_GetTimerJobLastRunTime', database 'SharePoint_Config', schema 'dbo'.

    Could you please let me know what is the issue and how can i resolve it?

    Thanks in Advance.


    Success is not to be pursued; it is to be attracted by the person we become.


    • Modifié Shailu123 jeudi 17 mai 2012 11:39 Added some more information
    jeudi 17 mai 2012 11:25

Réponses

Toutes les réponses

  • Hi shailu123,

    About your first question, you can refer to some blog, the following resolution is from a link.

    http://michael-chiu.blogspot.com/2010/03/error-event-id-6482-is-logging-every.html

    Resolution
    - Stop the Office SharePoint Services Search service (net stop osearch)

    - Download and install the IIS 6.0 Resource Kit Tools.
    On each server in the farm that has Office SharePoint 2007 installed, follow these steps:
    - Launch a cmd prompt
    - Drill to C:\Program Files\IIS Resources\SelfSSL)
    - Type selfssl /s:951338967 /v:1000, and then press ENTER.
    Notes
    For 64 bit, 951338967 is the default ID of the Office Server Web Services certificate.
    For 32 bit, 1720207907 is the default ID of the Office Server Web Services certificate. You can check the ID of Office Server Web Services from IIS.
    1000 is the number of days that the certification will be valid.
    You need to execute the selfssl command on each MOSS Server in the farm which is running a "Office Server Web Services" site.
    - Start the Office SharePoint Services Search service (net start osearch)
    - Download and install the following update to the .NET Framework 3.5 SP1 and apply 959209
    update

    About your second question, may be your application pool account doesn't have enough rights in SQL.

    You can refer to the following link.

    http://office.microsoft.com/en-us/windows-sharepoint-services-it/changing-the-application-pool-identity-for-a-virtual-server-HA001160835.aspx

    Thanks,

    Jack

    vendredi 18 mai 2012 09:50
    Modérateur
  • i have search a blog which is 

    http://www.no-dumping.com/2011/03/23/sharepoint-error-event-id-6482/

    Thanks for his count..

    Affected software: Windows SharePoint Server 3.0

    Type : Error
    Date : 3/23/2011
    Time : 8:52:17 AM
    Event : 6482
    Source : Office SharePoint Server
    Category : Office Server Shared Services
    User : N/A
    Computer : xxxxxxxx
    Description:
    Application Server Administration job failed for service instance Microsoft.Office.Server.Search.Administration.SearchServiceInstance (94fda143-13d5-4bd2-bab1-d23b38f4ad95).
    Reason: The current operation timed-out after 3600 seconds
    Techinal Support Details:
    System.Net.WebException: The current operation timed-out after 3600 seconds
    at Microsoft.Office.Server.Search.Administration.SearchServiceInstance.SynchronizeDefaultContentSource(IDictionary applications)
    at Microsoft.Office.Server.Search.Administration.SearchServiceInstance.Synchronize()
    at Microsoft.Office.Server.Administration.ApplicationServerJob.ProvisionLocalSharedServiceInstances(Boolean isAdministrationServiceJob)

    Solution: This is caused by the Office Server Search Service having bad authentication information. First, go to Central Administration and click on the affected server. This should take you to the services on server view. Click on the Office SharePoint Server Search Service link and it will take you to the settings page. Enter the correct login information. On the machine itself, restart the Office SharePoint Server Search service in the Services management console. This should generate two new log entries Event IDs 10044 and 10045 indicating that changes to the configuration were successfully saved and imported. To re-enable search indexing on your site, restart IIS.


    Deepesh Yevle MCTS

    lundi 7 janvier 2013 10:05
  • This is all well and nice but, even with me being logged in as "domain admin," I get an error running the selfssl command:

    C:\Program Files\IIS Resources\SelfSSL>selfssl /s:951338967 /v:1000
    Microsoft (R) SelfSSL Version 1.0
    Copyright (C) 2003 Microsoft Corporation. All rights reserved.

    Do you want to replace the SSL settings for site 951338967 (Y/N)?y
    Error opening site metabase key: 0x80070003


    tnjman

    mercredi 13 février 2013 14:57