none
Migrating SP2010 WSS CONTENT with CLASSIC auth to SP2013 CLAIMS auth fails when logging into web site

    Question

  • After converting CONTENT database from SP2010 to SP2013, I cannot log into SharePoint site.  SP2010 is using Classic Mode authentication and the new web application defautls to CLAIMS based authentication.

    Steps

    1) Restore backup CONTENT database to SQL Server 2012 database. Set the approriate permission on databases.

    2) New-SPWebApplication -Name $WebAppName -port 80 -HostHeader $HostHeader -URL $WebAppURL -ApplicationPool $AppPoolName -ApplicationPoolAccount (Get-SPManagedAccount $AppPoolAccount) -DatabaseName $TempDB -DatabaseServer $SqlServerName

    Note: I create a new web app and use a JUNKDB for CONTENT database. The powershell command does not like using my SP2010 content database because it is classic mode. 

    3) Get-SPContentDatabase -WebApplication $WebAppURL | Dismount-SPContentDatabase 

    Note: Dismount the database just created, because it was just to build the Web application.

    4) Mount-SPContentDatabase -Name $ContentDBname -DatabaseServer $SqlServerName -WebApplication $WebAppURL
    Note: This mounts the SP2010 database to the SP2013 web applications. Messages listed indicating that content database is being convert. I assume to SP2013 format. It goes 75% thru and pauses about 15 seconds, then continues and completes

    5) Test-SPContentDatabase -name $ContentDBname -WebApplication $WebAppURL

    Note: message indicates that database is using classic authentication and web application is claims.

    5) Convert-SPWebApplication -Identity  $WebAppURL -To Claims -RetainPermissions -Force

    Note:WARNING: The conversion of web application and most of the users to Claims mode is completed. However, one or more users could not be converted to Claims mode. Refer to the ULS logs for the details. For the troubleshooting tips refer to the http://go.microsoft.com/fwlink/?LinkID=236943 article.

    Which brings me to the point of question.  The migration completes and I open the web site and it prompts for username and password.  It will not accept any username or password.

    Also, if I change site permission to ANONYMOUS, I can see all the site pages and information, but then I don't have any rights to convert to SP2013 in the site settings.


    Michael Wharton, MBA, PMP, MCT, MCSD, MCSE+I, MCDBA, MCC 2011, MCC2012
    Website http://www.WhartonComputer.com
    Blog http://MyProjectExpert.com contains my field notes and SQL queries

    mercredi 21 novembre 2012 00:57

Toutes les réponses

  • I'm assuming you're not changing domains; that the users in the classic web app are the same users after converting to claims.

    Have you created a classic-authentication application pool, as per the instructions in the linked document in step 5, Migrate from classic-mode to claims-based authentication in SharePoint 2013? It looks like you create a new web application with this app pool, attach the database, and then convert is all to claims. It's not clear from your description if you did the first step.

    Alternatively you could convert the web application in 2010 to claims before moving it, is this possible in your situation?



    Jason Warren
    Infrastructure Architect

    jeudi 22 novembre 2012 00:32
  • Hello Jason

    Thanks for your suggestions.  I found the issue and it burns me all the time.  The solution is to DISABLE the LOOPBACK Check.  Once I did that it work great.

    Oh, how that feature burns!!!

    Cheers!


    Michael Wharton, MBA, PMP, MCT, MCSD, MCSE+I, MCDBA, MCC 2011, MCC2012
    Website http://www.WhartonComputer.com
    Blog http://MyProjectExpert.com contains my field notes and SQL queries

    jeudi 22 novembre 2012 05:44
  • Hello Jason

    Thanks for your suggestions.  I found the issue and it burns me all the time.  The solution is to DISABLE the LOOPBACK Check.  Once I did that it work great.

    Oh, how that feature burns!!!

    Cheers!

    I am having this exact same issue.  How do you Disable the Loopback check?

    MCITP | VCP4 | VCP5

    jeudi 8 août 2013 13:51
  • To disable the loopbackcheck (or use the preferred BackConnectionHostNames key) see KB 896861


    • Modifié Jason WarrenMVP jeudi 8 août 2013 13:57
    • Proposé comme réponse azhskr mercredi 14 août 2013 13:06
    jeudi 8 août 2013 13:57
  •  I am getting Access denied even after adding portalusera ccount as well as disable loopback check.

    Thsi is what i tried

    • New-SPWebApplication -Name "Spdev2013Test" -ApplicationPool "spdev2013TestAppPool" -AuthenticationMethod "NTLM" -ApplicationPoolAccount(Get-SPManagedAccount "contoso\spfarm") -DatabaseName "Wss_Content_spdev2013tmp" -Port 443 -URL https://sp2013.contoso.com  -SecureSocketsLayer
    • Test-SPContentDatabase -Name WSS_Content_restore -WebApplication https://sp2013.contoso.com
    • Mount-SPContentDatabase -Name WSS_Content_restore -WebApplication https://sp2013.contoso.com
    • Convert-SPWebApplication -Identity "https://sp2013.contoso.com " -To Claims -RetainPermissions -Force
    • $wa = Get-SPWebApplication "https://sp2013.contoso.com"
      $wa.MigrateUsers($true)
      $wa.Properties["portalsuperuseraccount"] = "i:0#.w|contoso\spfarm"
      $wa.Properties["portalsuperreaderaccount"] = "i:0#.w|contoso\spfarm"
      $wa.Update()
      iisreset /noforce

    Any idea???


    mp

    lundi 23 septembre 2013 18:03
  • Did you make sure the SQL Database security settings are set properly.  They the service accounts should had have rights similar to that of the content databases.


    Michael Wharton, MVP, MBA, PMP, MCT, MCTS, MCSD, MCSE+I, MCDBA
    Website http://www.WhartonComputer.com
    Blog http://MyProjectExpert.com contains my field notes and SQL queries

    lundi 23 septembre 2013 20:36
  • Can u explain littel details on what you mean "the service accounts should had have rights similar to that of the content databases."? I am using sql2012 and checked that the account contoso\spfarm has dbowner rights. Thats the account i am i.e Farm admin account using for everything. 

    Thanks for your help.


    mp

    mardi 24 septembre 2013 16:05