none
WSS 3.0 upgrade to MOSS 2007

    Pertanyaan

  • Can someone please help me? I am in the middle of  a migration from WSS 3.0 to SharePoint 2007 SP2. I am doing this through the database attach method. After making a full backup form the old environment and restored it on the new environment.

    Everything goes swell, but it seems that I cannot open the website after attaching the database with the stsadm –o –addcontentdb command line.

    I received the following error:

     

     "The Web Cannot display the page

     Mostly likley Causes:

     • The website is under maintenance

     • The Website Has A programming error”

    500 INTERNAL SERVER ERROR

     

     Can anyone help me?  I’ve been hitting this wall for quite some time now.

    On Google, I cannot find any solution

     Server Info:

    Windows Server 2003 SP2 x64bit (Vitrual)

    SQL Server 2005

     Thank you.


    06 Januari 2012 14:31

Semua Balasan

  • Hi Kurt,

    the first step is to run ststadm -o preupgrade check and ensure you have reslved all of the errors, the second is after you create the new wep app remove the default content database prior to adding the content database you plan to upgrade.

    -Ivan


    Ivan Sanders My LinkedIn Profile, My Blog, @iasanders.

    22 Februari 2012 18:37
  • Hi Kurt

    Please try the below:

    • Detach and reattach the content db

    Is this issue with all the site collection in the respective content db, if not the try the below:

    • Run the below command if there is any orphan entries stsadm -o enumsites -url New_Web_App_URL >C:\Sites.txt. Check the output if there the site is listed.
    • Databaserepair: http://technet.microsoft.com/en-us/library/cc288636%28v=office.12%29.aspx


    Regards Ram

    23 Februari 2012 9:18
  • HI,

    As you have already attached the database first execute one configuration wizard and then try again.

    I hope this will help you out.



    Thanks, Rahul Rashu

    23 Februari 2012 19:50