none
SharePoint OpenDocuments class addon

    질문

  • I am able to upload an Exel file to SkyDive, but when I try to pull down the file to open and edit it, I get a message that I do not have a properly installed Exel Program.  I spent twelve hours today trying to through a wide range of options, including all most two hours with a Microsoft Technical Support Person without any luck.  I am running a new laptop, with System 7 (64 bit) and Office 2010 Professional, and IE 8.  Some of the suggestions were that downloading and working with a file from SkyDive which is 32 bit will not work with my 64 bit browser, so I tried both Google and Safri (32 bit) which didn't help.  The concensus is that I need to install the SharePoint OpenDocument addon, but I truely can't find it anywhere.  Any help or suggestions.
    2011년 10월 26일 수요일 오전 4:20

답변

  • Hi

     

    You can enable it in Internet Explorer with the following steps:

     

    1.         Click Tools

    2.         Go to Manage Add-ons

    3.         In the Show box, click All add-ons

    4.         In the Name column, click SharePoint OpenDocumentsClass, click Enable.

     

    But if the SharePoint OpenDocuments Class isn’t listed in the collection of add-ons on your machine, you can try to fix it with the following steps. Cause it’s possible that the add-on does exist somewhere but that it wasn’t updated when recent Office upgrades were installed on your computer.

     

    1.         From the Start menu, click Control Panel, and then click Programs.

    2.         On the Control Panel Programs page, click Programs and Features.

    3.         Scroll down the list of installed programs, select Microsoft Office, and then click Change.

    4.         In the Change dialog, click Repair and then click Continue.

     

    Little interaction is required from you until the repair operation is complete. At that time, you might need to reboot your computer so the changes can take effect.

     

    When your computer finishes rebooting, go back into Internet Explorer and repeat the procedure for enabling the add-on.

     

    Hope this helps.

     

    Thanks,

    Pengyu Zhao

    • 답변으로 표시됨 Wayne Fan 2011년 11월 4일 금요일 오전 5:46
    2011년 10월 27일 목요일 오전 9:16

모든 응답

  • Hi

     

    You can enable it in Internet Explorer with the following steps:

     

    1.         Click Tools

    2.         Go to Manage Add-ons

    3.         In the Show box, click All add-ons

    4.         In the Name column, click SharePoint OpenDocumentsClass, click Enable.

     

    But if the SharePoint OpenDocuments Class isn’t listed in the collection of add-ons on your machine, you can try to fix it with the following steps. Cause it’s possible that the add-on does exist somewhere but that it wasn’t updated when recent Office upgrades were installed on your computer.

     

    1.         From the Start menu, click Control Panel, and then click Programs.

    2.         On the Control Panel Programs page, click Programs and Features.

    3.         Scroll down the list of installed programs, select Microsoft Office, and then click Change.

    4.         In the Change dialog, click Repair and then click Continue.

     

    Little interaction is required from you until the repair operation is complete. At that time, you might need to reboot your computer so the changes can take effect.

     

    When your computer finishes rebooting, go back into Internet Explorer and repeat the procedure for enabling the add-on.

     

    Hope this helps.

     

    Thanks,

    Pengyu Zhao

    • 답변으로 표시됨 Wayne Fan 2011년 11월 4일 금요일 오전 5:46
    2011년 10월 27일 목요일 오전 9:16
  • I recently solved this problem for a user. We were getting "A Microsoft SharePoint Foundation compatible application could not be found to edit the document" and the SharePoint opendocuments class wasn't showing up in available add-ons.

    The simple solution was to use the 32-bit version of IE instead of the 64-bit one. My ah-ha moment came after reading this page: http://sharepoint.microsoft.com/Blogs/GetThePoint/Lists/Posts/Post.aspx?List=8d9e2a99-f288-47c2-916b-2f32864f7b82&ID=494&Web=5e4647a0-e7d0-4626-b71c-b1ff06402465

    • 답변으로 제안됨 Marco A Garibay 2013년 11월 6일 수요일 오전 7:25
    2012년 6월 27일 수요일 오후 8:40
  • wow, thanks! This problem has really been bugging me. I switched to the 32-bit version of IE and it works fine. 

    With MS would look into this. Every time there's a compatibility issue, I end up wasting 30-60 minutes looking for a solution. I with it just worked. 

    2012년 9월 21일 금요일 오후 2:47
  • Aaawwwwwwhh man... You just saved my life. I was looking something for my problem. I couldn't open/edit documents on sharepoint and then I found this post. It turned out that all the time when I had this problem I've been using 64bit version of IE.

    Once again thanks a lot ! :)

    P.S. sorry for my english

    2013년 8월 21일 수요일 오전 9:48
  • I have had the same issue for one of our user using SharePoint 2007 document lib containing excel files could not edit the file specifically. I tried registering SharePoint OpenDocuments class addon which was errored not sure if the addon is not registered properly.  But then I just followed what Pengyu Zhao has suggested about the office 2010 repair. it worked.
    2014년 3월 28일 금요일 오전 1:05
  • That did the trick, good call!
    2014년 4월 2일 수요일 오후 8:43