none
Open With Windows Explorer very slow

    问题

  • I am trying to troubleshoot an issue where some users of our SharePoint environment have problems using the open with windows explorer option in a document library.

     

    For some users this works fine...  the explorer opens quickly and they can manage the documents.

     

    For other users it takes up to 5 minutes before the explorer view opens.  During this time the browser becomes completly unresponsive.

     

    As part of the troubleshooting process I tried taking the UNC path that is shown in the explorer view and tried using the Start -> Run and then entering in the path.   This seems to cause the complete desktop to freeze until the explorer window displays.

     

    This is occuring on Windows XP SP Pro SP2 with both IE6 and IE7.   The desktops are on the same domain as the SharePoint servers.

     

    Any thoughts on next steps?

    2008年6月18日 15:10

答案

全部回复

  • Opening with "windows explorer" causes WebDav component to fire up, and this one has a lot of issues depending on the version and hotfixes applied to it. look into "web folders" component, compare version of it on desktops that have a quick openning of WE and Slow opening of WE. this is desktop related and not user login issue.

     

    2008年6月18日 16:29
  •  

    I found the file msdaipp.dll which I believe is part of webdav.   It is located at C:\Program Files\Common Files\System\Ole DB

     

    The version I have is 12.0.6211.1000.   My xp machine is very very slow with accessing SharePoint via webdav   I will check the version on the other systems that are running faster to see what they are running.

    2008年6月18日 16:53
  • The webfolder functionality is implemented by means of MSDAIPP.DLL. It usually resides inside "C:\Program Files\Common Files\SYSTEM\OLE DB" or it's language dependant equivalent (such as "C:\Programme\Gemeinsame Dateien\SYSTEM\OLE DB" for German Windows versions). To find the DLL version, select the file in Explorer, choose "Properties" from the right-click context menu, then select the "Version" tab.

     

     

    Here is the link to the while page http://greenbytes.de/tech/webdav/webfolder-client-list.html

     

     

     

    2008年6月18日 19:11
  • The following link worked for me (turning off the IE8 auto proxy detection):
    http://oddballupdate.com/2009/12/18/fix-slow-webdav-performance-in-windows-7/

    2010年1月7日 3:26
  • Dear All,

    After clicking the Explorer View link, the page changes to WebFldr.aspx and then the browser takes from 45 seconds to 5 minutes to render the Web Folder view.

    There are a few causes and solutions for this:

            ·         Ports 137, 138, 139 and 445 are blocked, and ICMP is not.

    ·
            
    The server is being accessed using a name other than its configured NetBIOS or Fully     Qualified Domain Name. This occurs most often in load balancing and extranet scenarios.

             ·         WebDAV is trying to use a proxy to access a server on the local network.


    the following URL have whilte paper about Understanding and Troubleshooting the SharePoint Explorer View, this very very useful for any case
    http://www.microsoft.com/downloads/details.aspx?familyid=C523AC7A-5724-48BE-B973-641E805588F4&displaylang=en


    Best Regrads, Ahmed Madany
    2010年1月11日 14:42
  • Same here.  This occurs regardless of which system I use at work or at home.  Of note, we are using a "Hosted" sharepoint service.  Ahmed Madany, is your suggestion likely an issue on the hosts end or the end user client side?
    2010年1月11日 15:00
  • My Suggestion an issue on the hosts end, but note there are some configuartion might be configured at the end user client side , let me give you an example , some users while opening explorer view of document library this take along and give you an error "the page cannot be displayed" or the explorer view page will render a blank view , this problem solve with running web client service.

    really, i advice you to download white paper talking about Understanding and Troubleshooting the SharePoint Explorer View,
    at the following url
    http://www.microsoft.com/downloads/details.aspx?familyid=C523AC7A-5724-48BE-B973-641E805588F4&displaylang=en

    you will learn more about explorer view

    Best Regrads, Ahmed Madany
    2010年1月11日 18:35
  • After making some updates to our SharePoint server last week, my mapped drives became painfully slow. This fix did the trick for me and I am back in business.

    Thanks,

    Digital

    2010年8月28日 1:37
  • Thanks for all this info folks!  Im going to forward this to my hosted provider and see what they say.  Explorer View is a great feature we have never been able to use.
    2010年8月28日 23:07
  • Hi Mike,

    Is the problem resolved? I have similiar issue. The client is running Win XP IE8.0. Opening with windows explorer takes about 20-30 seconds.

    2012年2月17日 22:05
  • This solution worked fine for me:

    Open IE, go to 'Tools', and then choose 'Internet Options'. Go to the 'Connections' tab, and then click the 'LAN settings' button. Uncheck the box next to 'Automatically detect settings'. Click 'OK' twice and you're all set.

    I don't know why, but it worked!

    Thx to Stacy DuBois!

    2012年11月2日 9:13
  • THANK YOU!!!!!!!!!!!!!!!!!!
    2012年12月10日 18:52
  • I recently had this problem at my customer only in a different flavor.  Come to find out that the load balancer would not accept the netbios requests from the clients at a remote location and would cause 15-20 second wait times between each request as it tried to resolve the netbios queries.  Once we resolved that, the requests were very fast.

    Chris Givens CEO, Architecting Connected Systems Blog Twitter

    2012年12月11日 6:30
  • THANK YOU SO MUCH. Had about two days of Headaches with Performance of Office Save to Sharepoint and Navigation with the Windows Explorer.
    2013年1月10日 13:31
  • I had similar issues with WSS 3 and MOSS 2007.  Some users would experience slow load times when using IE8. 

    A. The authentication fix for Microsoft included the following:

    1. In HKEY_LOCAL_MACHINE > SYSTEM > CurrentControlSet > Services > WebClient > Parameters, add a new Multi-String Value named "AuthForwardServerList".
    2. In the Value data field, add one URL you visit, following by the SharePoint server FQDN on the next line.  Repeat for each URL you are having long wait times for.  In the end, you'll have something like:

    https://*.yourdomain.com
    sharepointservername.yourdomain.com
    https://otherspsite.yourdomain.com
    otherspservername.yourdomain.com

    The idea behind this is to explicitly tell WebDAV where to first go for authentication.  This cleared up the majority of access speed issues with SP and we were back to sub-second access.

    B. Occasionally that access would degrade for some reason for certain users.  Turns out to be MS updates that make changes to IE settings.  We go to IE Options > Advanced Settings tab and hit RESET.  Whatever RESET does fixed the speed issues with Explorer View.

    C.  Users who installed IE9 had major problems where access would take more than one minute to access these document libraries via Explorer View.  And that's one minute for every navigation click.  Double-click on a folder, wait a minute.  IE9 must have changed the authentication methodology for WebDAV since this was universally experienced for all IE9 users.  MS couldn't provide a resolution on this.  Our fix was to remove the IE9 update and revert back to IE8.  Everything went back to normal without having to make any changes to the Registry or IE settings.  Doh!

    2013年1月10日 18:17
  • Thanks Tino!

    I had to move more than 75 MB to a SharePoint library. The transfer was going on at about 200 Bytes/sec via the Explorer view. I canceled it. After unchecking the "Automatically Detect Settings", the transfer speed went up to 35 KB/sec!


    Please mark this reply as the answer or vote as helpful, as appropriate, to make it useful for other readers.
    Thanks!
    Aalam | Blog (http://aalamrangi.wordpress.com)


    2013年2月8日 18:47
  • Thanks, it worked for me.
    2013年11月20日 13:07
  • This solution worked fine for me:

    Open IE, go to 'Tools', and then choose 'Internet Options'. Go to the 'Connections' tab, and then click the 'LAN settings' button. Uncheck the box next to 'Automatically detect settings'. Click 'OK' twice and you're all set.

    I don't know why, but it worked!

    Thx to Stacy DuBois!

    This worked for me instantly. Thanks!
    2014年3月20日 18:30