none
creating linked servers in mirrored server

    Frage

  • i am using sqlserver 2008 and configured to make my computer Mirror Principle.

    i want to create linked server from my server, but when i complete the process of creation i get the following error:

    Named Pipes Provider: Could not open a connection to SQL Server [1231].
    OLE DB provider "SQLNCLI10" for linked server "BILL" returned message "Login timeout expired".
    OLE DB provider "SQLNCLI10" for linked server "BILL" returned message "A network-related or instance-specific error has occurred while establishing a connection to SQL Server. Server is not found or not accessible. Check if instance name is correct and if SQL Server is configured to allow remote connections. For more information see SQL Server Books Online.". (.Net SqlClient Data Provider)

    so is the any help.

    best regards

    Sonntag, 6. Januar 2013 14:06

Antworten

  • Hi eng.geesey,

    Please try to set the remote query timeout to 0 (infinite wait) using this code:

    sp_configure 'remote query timeout', 0
    go
    reconfigure with override
    go

    Please refer to this issue in the following KB: http://support.microsoft.com/kb/314530.

    Thanks,
    Eileen

     


    Eileen Zhao
    TechNet Community Support

    • Als Antwort markiert Eileen Zhao Donnerstag, 24. Januar 2013 02:39
    Mittwoch, 9. Januar 2013 09:11
  • There are many reasons of SQL server connectivity issue. Refer a small checklist that helps me most of the time to find out the real cause of connectivity issue.

    1. Check SQL services are running

    2. Check SQL Browser service is running

    3. Check remote connections are enabled

    4. Network connectivity between database & application servers by TRACERT command

    5. Check TCP/IP protocol enabled at SQL server

    6. Check talent connectivity – telnet <IP address> <port no on SQL server running>

    7. Check UDP port 1434 is open or not on SQL Server

    8. Check firewall is running or not Check

    9. If firewall running, SQL Server & UDP port must be added in exception in firewall

    http://mssqlfun.com/2012/09/28/check-list-for-sql-server-connectivity-issue/


    Regards,
    Rohit Garg
    (My Blog)
    This posting is provided with no warranties and confers no rights.
    Please remember to click Mark as Answer and Vote as Helpful on posts that help you. This can be beneficial to other community members reading the thread.

    • Als Antwort markiert Eileen Zhao Donnerstag, 24. Januar 2013 02:39
    Mittwoch, 9. Januar 2013 13:33

Alle Antworten

  • Hi eng.geesey,

    Please try to set the remote query timeout to 0 (infinite wait) using this code:

    sp_configure 'remote query timeout', 0
    go
    reconfigure with override
    go

    Please refer to this issue in the following KB: http://support.microsoft.com/kb/314530.

    Thanks,
    Eileen

     


    Eileen Zhao
    TechNet Community Support

    • Als Antwort markiert Eileen Zhao Donnerstag, 24. Januar 2013 02:39
    Mittwoch, 9. Januar 2013 09:11
  • There are many reasons of SQL server connectivity issue. Refer a small checklist that helps me most of the time to find out the real cause of connectivity issue.

    1. Check SQL services are running

    2. Check SQL Browser service is running

    3. Check remote connections are enabled

    4. Network connectivity between database & application servers by TRACERT command

    5. Check TCP/IP protocol enabled at SQL server

    6. Check talent connectivity – telnet <IP address> <port no on SQL server running>

    7. Check UDP port 1434 is open or not on SQL Server

    8. Check firewall is running or not Check

    9. If firewall running, SQL Server & UDP port must be added in exception in firewall

    http://mssqlfun.com/2012/09/28/check-list-for-sql-server-connectivity-issue/


    Regards,
    Rohit Garg
    (My Blog)
    This posting is provided with no warranties and confers no rights.
    Please remember to click Mark as Answer and Vote as Helpful on posts that help you. This can be beneficial to other community members reading the thread.

    • Als Antwort markiert Eileen Zhao Donnerstag, 24. Januar 2013 02:39
    Mittwoch, 9. Januar 2013 13:33