A timeout was reached while waiting for the SQL Server service to connect


  • Several times over the past month, when our hosting server for SQL Server 2008 R2 has undergone a scheduled restart at 3:00AM, one of our 3 SQL Server instances fails to start.  This behavior has also been observed in the SQL Server Agent service (same instance), as well as the SQL Server Integration Services service.  All of these services have Start Mode set to Automatic.  For the SQL Server service that fails to restart, I found the following error in the Windows NT System log (similar errors found for SQL Server Agent service and SQL Server Integration service):

     Date  7/1/2013 3:16:56 AM
     Log  Windows NT (System)

     Source  Service Control Manager
     Category  (0)
     Event  3221232481

     A timeout was reached (30000 milliseconds) while waiting for the SQL Server (SQL2008_APPS) service to connect.

    Monday, July 01, 2013 4:06 PM


All replies

  • Hello,

    Run the Msconfig or System Configuration program and examine which programs are loading at startup. Maybe there are a good amount of programs trying to load at startup.

    Another possibility may be a security suite preventing them from start on time.

    Hope this helps.


    Alberto Morillo

    Monday, July 01, 2013 4:55 PM
  • There are only 6 programs listed in the System Configuration Startup tab, which seems like a minor amount. 
    Monday, July 01, 2013 5:40 PM
  • This is a generic message. Please look at the SQL Server error log to determine why it did not start.

    Agent and SSIS are dependent on the SQL Server service to start.

    Monday, July 01, 2013 5:52 PM
  • I am unclear as to what log you are referring to.  When I look at the SQL Server log named "Archive #1 - 7/1/2013 3:04:00 AM", I see message "SQL Server is terminating because of a system shutdown.  This is an informational message only.  No user action is required".  The next log, named "Current - 7/2/2013 4:54:00 AM" starts at  6:56:41 AM when I manually started the service.  Windows restarted at approximately 3:12 AM, and the messages in the Current log for my other 2 instances start at roughly 3:18 AM.

    When I look at the ERRORLOGs in "\Program Files\Microsoft SQL Server\MSSQL10_50.INSTANCE\MSSQL\Log" I see the same gap: ERRORLOG.1 ends with an entry at 2013-07-01 03:04:06.02 (around the time Windows was restarted), the first entry in ERRORLOG is at 2013-07-01 06:56:41.97 (when I started the instance).  There are no logs, that I can find, reporting any error with the start up, other than the error I mentioned in my original posting.

    Tuesday, July 02, 2013 12:24 PM
  • Hello,

    You may want to try the following workaround:

    Hope this helps.


    Alberto Morillo

    Wednesday, July 03, 2013 9:17 PM
  • Hi Tim,

    The services fails to start in automatic mode when starting the server, but they will be ok when you start them manually. As Alberto post, maybe there are other programs hold many resources during system startup. However, by default, the Service Control Manager will wait 30s for a service to respond. When the service take longer than 30s, the” timeout” may happen.

    There are some steps about increasing the service timeout period, you can refer to the following link.

    Sofiya Li

    Sofiya Li
    TechNet Community Support

    Thursday, July 04, 2013 6:10 AM
  • Alberto,

    I'm hoping that the workaround in the link you provided is the answer.  I've updated my registry as per the instructions in that link, but haven't yet restarted the server, preferring to wait until it's next scheduled reboot at 3AM on 8-Jul-2013.  As per the instructions in the link, I've changed the timeout setting for starting Windows services from 30 seconds to 3 minutes (180000 milliseconds).  I will update you on the results on Monday.  Thanks for your help with this.

    Friday, July 05, 2013 2:50 PM
  • Hello,

    Thank you for letting us know. Keep us posted.

    Hope this helps.


    Alberto Morillo

    Sunday, July 07, 2013 10:18 PM
  • The server rebooted, as scheduled, at 3:00AM this morning; subsequently, all of the SQL services started successfully.  I'm fairly confident that boosting the timeout value to 3 minutes will be sufficient going forward.  Thanks, again, for pointing me to the link on changing the default service start timeout value.

    Monday, July 08, 2013 11:51 AM
  • Hello,

    Thank you for visiting MSDN forums!

    Have a great day!


    Alberto Morillo

    Monday, July 08, 2013 12:27 PM