none
Which version of SQL Management Studio Express should I install?

    Question

  • Hi,

    I am working on a VB application in VS 2008 Pro.  It uses an SQL Compact 3.5 SP2 database.  On XP SP3 I used SQL Server Management Studio 2008 Express to manipulate the db.

    After an enforced move to a new platform (Windows 7 SP1 64-bit) I need to install SSMS, but SSMS 2008 Express 64-bit  (http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=7593)  will not install - the wizard fails because it is not possible to select any options at all.

    Is there another version of SSMS Express I could use that can work with an SQL Compact 3.5SP2 db?

    JPL

    • Moved by Andrew.Wu Friday, August 05, 2011 6:55 AM (From:Visual Studio Database Development Tools (Formerly "Database Edition Forum"))
    Wednesday, August 03, 2011 10:11 PM

All replies

  • Hi JPL,

    According to your description, I think your question is more related with SQL Server tools, so I'm going to help mvoe your post to the SQL Server Tools General Forum for better support.

    Thanks for your understanding.

    Best Regards,


    Andrew Wu [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, August 05, 2011 6:55 AM
  • Hi JPL5780,

    Could you please elaborate a bit or show us a screenshot?

    You can also try SQL Server 2008 R2 Management Studio Express: http://www.microsoft.com/download/en/details.aspx?id=22985


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Get or Request Code Sample from Microsoft
    If you have any feedback, please tell us.
    Friday, August 05, 2011 7:28 AM
  • Andrew & Jiang,

    Thanks for your help.

    I initially installed SQL Server 2008 R2 Express with Tools (SQLEXPRWT_x64_ENU_2008R2SP1.exe), but found that in Management Studio the Server Type drop-down listed was greyed out, i.e. fixed at Database Engine, unable to select SQL Server Compact.

    After some messing around trying to fix this, I gave up, uninstalled 2008 R2 and installed 2008 SP2 (SQLEXPR_x64_ENU_2008SP2.exe followed by SQLManagementStudio_x64_ENU.exe - I could not find  a complete With Tools installation package).  The SSMS installation suffered from the fault described above, where no options could be selected and so the installation had to be aborted.

    I then uninstalled again (getting a bit fed up with the problems by now) and tried 2008 R2 again.  This time everything worked OK and I am able to use SSMS on either SQL or SQL Compact DBs as required.

    It is not clear to me why 2008 R2 Express did not work first time but was perfectly fine the second time around.  Anyway, all OK and working properly now.

    JPL


    Saturday, August 06, 2011 2:11 PM