none
SSAS 2008R2 will not start after drive letter changed

    Question

  • Environment : 2 node cluster of SQL Server 2008 R2 SP1 (2 nameds instance + default) running on Windows 2008 R2 SP1.

    I have changed the drive letters successfully (for data and logs) on the default instance and all the databases started correctly, however SSAS will not start giving following error: 

    The service cannot be started: The following system error occurred:  The system cannot find the path specified.  File system error: Error occurred during the creation of directory: '\\?\G:\OLAP\Data'.

    1. I have scoured the registry and SS Configuration Manager and changed all the settings containing drive letters to the proper drive letters(should be E:\ for DataDir ).  The reg keys that I modified are the following;

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSAS10_50.MSSQLSERVER\CPE, key ErrorDumpDir
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSAS10_50.MSSQLSERVER\Setup, key DataDir

    What puzzles me is that the setting for the "ErrorDumpDir" key revert to the old one after attempting to start the service therefore it is obvious that SSAS does not get its settings from the registry.

    2. I have also looked at msmdsrv.ini for the <DataDir></DataDir> entry but it is not there.  I added it but no luck.

    3. I have changed the database settings of the database engine for default data and log locations in case it was the source info for SSAS data directory.

    Any help would be greatly appreciated. THANKS!


    Monday, February 20, 2012 4:40 PM

Answers

  • Just found what the problem was.  

    The msmdsrv.ini file was actually located on my backup drive, this probably occured when I was installing SSAS.  This explains why the msmdsrv.ini file that I found on the C:\ was nearly empty.

    How I discovered it is by looking in SS Configuration Manager for Analysis Services under the Service tab at the entry "Binary Path" and scrolling to the end where the file and its location is entered as a parameter for starting SSAS.  

    When I opened the file I found all the old settings, changed them to the new drive letters and bingo SSAS started.

    Thanks for anyone who would have provided help!


    • Marked as answer by Beneque79 Monday, February 20, 2012 4:52 PM
    • Edited by Beneque79 Monday, February 20, 2012 4:53 PM
    Monday, February 20, 2012 4:52 PM