none
Dimension Processing Problem - Space vs. "Tab Space"

    Question

  • Hello,

    I have a problem during dimension processing of my cube. I always receive a error message that there are duplicate keys when processing a dimension attribute.

    I already investigated on this issue and I found out that the problem is caused by the following situation:
    When processing the attribute the query to select all distinct values of the attribute is sent to the underlying database (which is Teradata in this case).
    This query is processed by Teradata without any problems and delivers all distinct values back to SSAS.

    But the problem is:
    SSAS handles tab spaces as blanks. Unfortunately there are rows that are the equal except except of the usage of blanks/tab spaces.
    Due to this reason SSAS thinks that the SELECT DISTINCT query returns non-distinct values and returns an error.

    Does anybody know this problem?
    Is there a way to change the tab space handling of the SSAS OLAP engine?

    Thanks in advance!

    Best regards,
    H.

    Monday, June 18, 2012 6:56 AM

Answers

  • Hi H.

    The only thing I can think of doing, is to test with the collation of the column, although I am not sure what to set it to. It may be worth trying to make it identical to your database collation. This is found by expanding out the KeyColumns attribute of the dimension

    The other option is to change the tab to a space or other charater ('.') within your source query.

    Hope you manage to solve the issue.

    • Marked as answer by H-e-l-m-u-t Wednesday, June 20, 2012 6:30 AM
    Monday, June 18, 2012 7:22 AM

All replies

  • Hi H.

    The only thing I can think of doing, is to test with the collation of the column, although I am not sure what to set it to. It may be worth trying to make it identical to your database collation. This is found by expanding out the KeyColumns attribute of the dimension

    The other option is to change the tab to a space or other charater ('.') within your source query.

    Hope you manage to solve the issue.

    • Marked as answer by H-e-l-m-u-t Wednesday, June 20, 2012 6:30 AM
    Monday, June 18, 2012 7:22 AM
  • So if you are saying that the only difference between some of these attribute members are characters that the users can't see - then I think the correct thing to do is to clean and normalise this column during your ETL so that you map values that only vary by whitespace to the same dimension row.

    http://darren.gosbell.com - please mark correct answers

    Tuesday, June 19, 2012 12:33 AM
  • Hi Michael,

    Thanks - setting the column collation to LATIN1_GENERAL_100 solved our isue.


    Best regards,
    H.

    Wednesday, June 20, 2012 6:30 AM