none
The permissions granted to user '' are insufficient for performing this operation. (rsAccessDenied)

    Question

  • when I try to connect to the "http://localhost:8080/ReportServer " I get this error.

    The permissions granted to user 'DOMAIN/USERNAME' are insufficient for performing this operation. (rsAccessDenied).

    I have configered the Reporting services Configuration manager.

    I am an administrator on my machine and on the reportserver DB. when I try to log on the my 2008 R2 reporting services I get a simalar error.

    does any one have an idea of what I am missing?

    thank you.

    Jeff


    Jeff

    Wednesday, July 11, 2012 7:30 PM

Answers

All replies

  • It does seem you don't have the rights.

    Check if your Login is Sysadmin on the sql server and if the database user  created on the login have datareader on the database of the report server.

    You must check both levels of security, Login and user.

    Other then that, if your windows user is admin, you should have access to the ReportManager.

    Wednesday, July 11, 2012 9:09 PM
  • Hi There

    Reporting Services uses role-based security to grant user access to a report server. For a report server that runs in native mode, there are two types of roles: Item-level roles and System-level roles.

    The Item-level roles are used to view, add, and manage report server content, subscriptions, report processing, and report history. We can assign Item-level roles on the root node (the Home folder) or on specific folders or items. In this issue, o assign Item-level role to specific user on specific items. Additionally, you can also custom Item-level roles by using specific Item-level tasks based on your requirement.

    References:

    Please follow these steps it might work for you

    1. Start Report Manager by going to http:/yourdmain/Reports

    2. Click Site Settings.

    3. Click Security.

    4.If a role assignment already exists for the user or group for which you want to configure Report, click Edit.

    Otherwise, click New Role Assignment. In Group or user, enter a Windows domain user or group account in this format: <domain>\<account>.

    5. Select System User, and then click OK.

    6. Click Home.

    7. Click the Properties tab.

    8. Click the Security tab.

    9. If a role assignment already exists for the user or group for which you want to configure Report server access, click Edit. Otherwise, click New Role Assignment. In Group or user, enter a Windows domain user or group account in this format: <domain>\<account>.

    10. Select appropriate access, and then click Apply.

    If you would like you user to give just report viewing access please just give them browser role to the report folders it will restrict them just to view the report not anything else

    Please let me know if you have any questions

    Many Thanks

    Syed Qazafi Anjum

    Please click "Mark as Answer" if this resolves your problem or "Vote as Helpful" if you find it helpful.

    Wednesday, July 11, 2012 9:24 PM
  • the problem is I get this error when I try to log onto my report manager.

    Jeff

    Wednesday, July 11, 2012 9:42 PM
  • everything looks good there.

    to expand on this,

    when I click on the report manager URL site "http://localhost:8080/Reports" I get the error:

    "Unable to connect to the remote server"

    when I click on Web service URL I get the error :

    "The permissions granted to user 'DOMAIN/USERNAME' are insufficient for performing this operation. (rsAccessDenied). "

    my machine is on the local intranet site.

    also using SQL 2008 R2 on windows 7 64 bit machine.

    thanks


    Jeff


    • Edited by js34259 Wednesday, July 11, 2012 9:46 PM
    Wednesday, July 11, 2012 9:42 PM
  • Hi There

    Thanks for your posting. T solve your permission problem you have to Connect locally to the reporting services (Connect to your report server computer by domain admin). Select the folder you want to edit, then click the properties tab. Then select Security from the left. From there you can add the users or groups that you want to access the site.

    Permission to access report server content and operations are granted through role assignments. On a new installation, only local administrators have access to a report server. To grant access to other users, a local administrator must create a role assignment that specifies a domain user or group account, one or more roles that define the tasks the user can perform, and a scope (usually the Home folder or root node of the report server folder hierarchy). You can use Report Manager to create the role assignments

    http://msdn.microsoft.com/en-us/library/aa337279.aspx

    Many thanks

    Syed Qazafi Anjum



    Wednesday, July 11, 2012 10:00 PM
  • Maybe I am not understanding you completly,

    when I try to Connect locally to the reporting services (Connect to your report server computer by domain admin). 

    http://MYCOMPUTER:8080/ReportServer

    that is when I get the error :

    "The permissions granted to user 'DOMAIN/USERNAME' are insufficient for performing this operation. (rsAccessDenied). "

    I am familar with adding roles to the reports when I can log into reporting services, I just have to get to that point.

    I am the admin on the local machine and my logins are correct on the SQL Server.

    if there a setting somewhere I am missing?


    Jeff

    Wednesday, July 11, 2012 10:17 PM
  • Hi There

    Can you please have a look whether your SSRS service in running or not ?

    Many thanks

    Syed

    Wednesday, July 11, 2012 10:24 PM
  • Hi There

    Please also have a look on this thread

    http://tanveeronline.blogspot.co.nz/2011/07/ssrs-2008-r2-unable-to-connect-to.html

    http://social.msdn.microsoft.com/Forums/hu-HU/sqlreportingservices/thread/f8a0a3f5-3985-4356-8404-3b408f790747

    http://www.networksteve.com/enterprise/topic.php?TopicId=24217

    In the last section of this thread it get resolved by

    "Changing the ports. Configured TCP port to 9000 and SSL port to 9001.
    And then

    <Add Key="SecureConnectionLevel" Value="0"/>

    Its value was 2, changed it to 0."

    Please have alook on this thread that might help you

    Many thanks

    Syed



    Wednesday, July 11, 2012 10:52 PM
  • THANK YOU! that was the key those three articles helped me out.

    Thank you very much. Up and running now.


    Jeff

    Thursday, July 12, 2012 3:23 PM
  • Hi There

    Please also have a look on this thread

    http://tanveeronline.blogspot.co.nz/2011/07/ssrs-2008-r2-unable-to-connect-to.html

    http://social.msdn.microsoft.com/Forums/hu-HU/sqlreportingservices/thread/f8a0a3f5-3985-4356-8404-3b408f790747

    http://www.networksteve.com/enterprise/topic.php?TopicId=24217

    In the last section of this thread it get resolved by

    "Changing the ports. Configured TCP port to 9000 and SSL port to 9001.
    And then

    <Add Key="SecureConnectionLevel" Value="0"/>

    Its value was 2, changed it to 0."

    Please have alook on this thread that might help you

    Many thanks

    Syed



    http://tanveeronline.blogspot.co.nz/2011/07/ssrs-2008-r2-unable-to-connect-to.html

    Does not work. I already had the settings which are mentioned in that blog - 

    Try doing the following things
    Go to Reporting Services Conf. Manager.

    1. Change the server account to local account.
    2. Remove the SSL if configured.
    3. Go to C:\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer
    4. Change the  SecureConnectionLevel value to 0 in rsreportserver.config

    Try refreshing the page, it should work now!

    Also tried answer at - http://social.msdn.microsoft.com/Forums/sqlserver/en-US/f8a0a3f5-3985-4356-8404-3b408f790747/ssrs-2008-unable-to-connect-to-remote-server?forum=sqlreportingservices

    Same thing there. SecureConnectionLevel value to 0 is already set for me.

    Third link comment at end says  - 

    Hi Chaitanya, Changing the ports worked for me. Configured TCP port to 9000 and SSL port to 9001. And then <Add Key="SecureConnectionLevel" Value="0"/> Its value was 2, changed it to 0. Thanks for all your support Best Regards, Arka Mitra.

    You can set TCP and SSL like this from Reporting services config manager - 

    Web Service URL option (left pane) > Advanced settings button > put the values.

    The TCP can be changged to 9000, but the SSL requires a certificate file. I am stuck here.

    The clue to make your own SSL certificate is here - 

    http://johnhennesey.blogspot.com/2010/10/reporting-services-2008-over-ssl.html

    But, this post is not for windows 7 64 bit, ie my personal pc os. I tried to make the cert on win, 7, but options are complicated. Lets see.

    Here is the issue for the same - https://stackoverflow.com/questions/22314341/cannot-see-self-created-certificate-in-certmanager

    • Edited by blastoSO Tuesday, March 11, 2014 12:52 AM
    Monday, March 10, 2014 11:45 PM
  • Why is it so difficult to configure SSRS for learning purposes on a personal computer ? I have never had this much suffering when installing far more complicated tools on my system. I am trying to create my own SSL certs as a shot in the dark now.


    • Edited by blastoSO Tuesday, March 11, 2014 12:57 AM
    Tuesday, March 11, 2014 12:57 AM