none
SQL Server 2005 Maintenance Plan - backup failed

    Question

  • I have updated MSSQL 2005 SP3.
    All databases have compability level SQL Server 2005 (90).

    I created Maintenance Plan to perform full daily backup of all databases and logs.
    But I get error:

    NEW COMPONENT OUTPUT
    Microsoft(R) Server Maintenance Utility (Unicode) Version 9.0.4035
    Report was generated on "SRV3".
    Maintenance Plan: Backup-Baz
    Duration: 00:00:01
    Status: Warning: One or more tasks failed..
    Details:
    Back Up Database (Full) (SRV3)
    Backup Database on Local server connection
    Databases that have a compatibility level of 70 (SQL Server version 7.0) will be skipped.
    Databases: All user databases
    Type: Full
    Append existing
    Task start: 2009-09-02T09:02:40.
    Task end: 2009-09-02T09:02:42.
    Success

    Back Up Database (Transaction Log) (SRV3)
    Backup Database on Local server connection
    Databases that have a compatibility level of 70 (SQL Server version 7.0) will be skipped.
    Databases: All user databases
    Type: Transaction Log
    Append existing
    Task start: 2009-09-02T09:02:42.
    Task end: 2009-09-02T09:02:42.
    Failed:(0) Database 'ILS' will not be backed up because it does not have its recovery model set to Full or BulkLogged.

    Back Up Database (Transaction Log) (SRV3)
    Backup Database on Local server connection
    Databases that have a compatibility level of 70 (SQL Server version 7.0) will be skipped.
    Databases: All user databases
    Type: Transaction Log
    Append existing
    Task start: 2009-09-02T09:02:42.
    Task end: 2009-09-02T09:02:42.
    Failed:(0) Database 'ILS_NLPL-Tor' will not be backed up because it does not have its recovery model set to Full or BulkLogged.

    Back Up Database (Transaction Log) (SRV3)
    Backup Database on Local server connection
    Databases that have a compatibility level of 70 (SQL Server version 7.0) will be skipped.
    Databases: All user databases
    Type: Transaction Log
    Append existing
    Task start: 2009-09-02T09:02:42.
    Task end: 2009-09-02T09:02:42.
    Success

    any ideas?
    Thursday, September 03, 2009 6:45 AM

Answers

  • check the compatability of your databases. right click -> properties -> options

    they are set to version 7.0

    the other error is the recovery model is set to simple. Set it to Full in the options tab

    ta
    • Marked as answer by sethiel Thursday, September 03, 2009 10:51 AM
    Thursday, September 03, 2009 7:06 AM
  • Hi Sethiel

    It's very simple , if you investigate the error you will get the resolution.Below are the resolution to fix the issue.Execute the script in BOLD

    Back Up Database (Full) (SRV3)
    Backup Database on Local server connection
    Databases that have a compatibility level of 70 (SQL Server version 7.0) will be skipped.

    USE

     

    [master]
    GO
    EXEC dbo.sp_dbcmptlevel @dbname=N'SRV3', @new_cmptlevel=90
    GO

    Back Up Database (Transaction Log) (SRV3)
    Backup Database on Local server connection
    Databases that have a compatibility level of 70 (SQL Server version 7.0) will be skipped.
    Databases: All user databases
    Type: Transaction Log
    Append existing
    Task start: 2009-09-02T09:02:42.
    Task end: 2009-09-02T09:02:42.
    Failed:(0) Database 'ILS' will not be backed up because it does not have its recovery model set to Full or BulkLogged.

    USE Master
    GO
    ALTER DATABASE ILS SET RECOVERY FULL



    Back Up Database (Transaction Log) (SRV3)
    Backup Database on Local server connection
    Databases that have a compatibility level of 70 (SQL Server version 7.0) will be skipped.
    Databases: All user databases
    Type: Transaction Log
    Append existing
    Task start: 2009-09-02T09:02:42.
    Task end: 2009-09-02T09:02:42.
    Failed:(0) Database 'ILS_NLPL-Tor' will not be backed up because it does not have its recovery model set to Full or BulkLogged.

    USE Master
    GO
    ALTER DATABASE ILS_NPL-Tor SET RECOVERY FULL



    Prakash Nandwana,Bangalore,India
    • Marked as answer by sethiel Thursday, September 03, 2009 10:51 AM
    Thursday, September 03, 2009 7:45 AM

All replies

  • check the compatability of your databases. right click -> properties -> options

    they are set to version 7.0

    the other error is the recovery model is set to simple. Set it to Full in the options tab

    ta
    • Marked as answer by sethiel Thursday, September 03, 2009 10:51 AM
    Thursday, September 03, 2009 7:06 AM
  • Hi Sethiel

    It's very simple , if you investigate the error you will get the resolution.Below are the resolution to fix the issue.Execute the script in BOLD

    Back Up Database (Full) (SRV3)
    Backup Database on Local server connection
    Databases that have a compatibility level of 70 (SQL Server version 7.0) will be skipped.

    USE

     

    [master]
    GO
    EXEC dbo.sp_dbcmptlevel @dbname=N'SRV3', @new_cmptlevel=90
    GO

    Back Up Database (Transaction Log) (SRV3)
    Backup Database on Local server connection
    Databases that have a compatibility level of 70 (SQL Server version 7.0) will be skipped.
    Databases: All user databases
    Type: Transaction Log
    Append existing
    Task start: 2009-09-02T09:02:42.
    Task end: 2009-09-02T09:02:42.
    Failed:(0) Database 'ILS' will not be backed up because it does not have its recovery model set to Full or BulkLogged.

    USE Master
    GO
    ALTER DATABASE ILS SET RECOVERY FULL



    Back Up Database (Transaction Log) (SRV3)
    Backup Database on Local server connection
    Databases that have a compatibility level of 70 (SQL Server version 7.0) will be skipped.
    Databases: All user databases
    Type: Transaction Log
    Append existing
    Task start: 2009-09-02T09:02:42.
    Task end: 2009-09-02T09:02:42.
    Failed:(0) Database 'ILS_NLPL-Tor' will not be backed up because it does not have its recovery model set to Full or BulkLogged.

    USE Master
    GO
    ALTER DATABASE ILS_NPL-Tor SET RECOVERY FULL



    Prakash Nandwana,Bangalore,India
    • Marked as answer by sethiel Thursday, September 03, 2009 10:51 AM
    Thursday, September 03, 2009 7:45 AM
  • Thank you very much.
    Thursday, September 03, 2009 10:50 AM