none
SSRS and SSAS - Double Hop Problem?

    Question

  • Hi All

    1. server A - runs sql server 2005, has the cube/analysis services datasources, win 2003 server r2

    2. Server B - runs sql server 2008, has reports that access server A cubes, win 2003 server r2

    Both machines in the same domain, the username has been added as domain admin and even local admin ,and it is added to the database too with proper rights. Logs dont have more info that the bottom error msg.

    from server B - through visual studio we can run the report, when from the URL we type httlp://localhost/reports (it doesnt ask for the usr,pwd) and run the report it works fine, but when we put the IP in the browser (ip of the same machine) and go to http://192.168.100.2/reports (it DOES ask for the usr,pwd) then the report gives this error:

    • An error occurred during client rendering. An error has occurred during report processing. Cannot create a connection to data source 'RD_OLAP'.The connection either timed out or was lost.Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. An existing connection was forcibly closed by the remote host
    How do we solve this issue?
    Tuesday, June 29, 2010 10:19 AM

Answers

  • Hi All

    1. server A - runs sql server 2005, has the cube/analysis services datasources, win 2003 server r2

    2. Server B - runs sql server 2008, has reports that access server A cubes, win 2003 server r2


    I don’t think it’s a Double Hop issue. This is a common scenario, just like use Report Builder (remote) to query data from SSAS. It seems this is a connections issue, could you try to connect to SSAS server in machine B via BIDS/RB/SSMS? If yes, then this could be caused by time-out.

     

    Hope this helps,

    Raymond


    Raymond Li - MSFT
    Wednesday, June 30, 2010 11:58 AM

All replies

  • Hi All

    1. server A - runs sql server 2005, has the cube/analysis services datasources, win 2003 server r2

    2. Server B - runs sql server 2008, has reports that access server A cubes, win 2003 server r2


    I don’t think it’s a Double Hop issue. This is a common scenario, just like use Report Builder (remote) to query data from SSAS. It seems this is a connections issue, could you try to connect to SSAS server in machine B via BIDS/RB/SSMS? If yes, then this could be caused by time-out.

     

    Hope this helps,

    Raymond


    Raymond Li - MSFT
    Wednesday, June 30, 2010 11:58 AM
  • Hi Sathyandra,

    We are having the same problem.  Did this issue got resolved?  Please let me know.

    Thanks.

    Friday, March 16, 2012 1:32 AM