none
PowerPivot Unable to connect to the Analysis Server

    Question

  • When launching the PowePivot Windows Excel I get the following error:

    "Unable to connect to the Analysis server. The servername '$Embedded' was not found. Please verify that the name you entered is correct, and then try again."

    Then the system gives me the option to enter the Analysis server name, but afer entering the name I get an error back "Unable to open connection".

    Neverthenless I can connect sucessfully to Analysis Server when using a regular Pivot Table.

    I do appreciate any help to fix this connectivity issue.

     

    Thanks,

    CT

    Monday, July 19, 2010 6:46 PM

Answers

  • Normally this happens when the MSOLAP OLEDB provider components are modified. Note: PowerPivot and Excel distributes this component.

    Excel 2010 distributes older version which doesn't support PowerPivot functionalities. When you install PowerPivot you will receive a newer version of MSOLAP OLEDB Provider. I think in your case by somehow the OLEDB provider version could have been modified. I couldn't guess what causes it.

    Here are some of things to try,

    1) Go to C:\program files\microsoft analysis services\AS OLEDB\10 check the version of msolap100.dll it should be 10.5.<>.<>. If it is 10.0 then it's older.

    2) You can repair PowerPivot or un-install and re-install PowerPivot should bring the correct version.

    Hope this helps!

     


    Thanks, Deva [MSFT] My blog: http://powerpivot.spaces.live.com/
    Tuesday, February 22, 2011 8:36 PM

All replies

  • Hi Cesar,

    This is usually caused by a setup issue.. what version of PowerPivot did you install? Can you verify you did not have any pre-RTM installation of PowerPivot on the machine as well?

    thanks

    ash

     

    Thursday, July 29, 2010 10:20 PM
  • I am having this same problem as well.  Version 10.50.1747.0.  Running Windows 7, Office 2010.  Pretty sure I installed the right version.  After a fresh install, the problem went away.  After a month or so of no use, the problem returned.  Is there some setup file that I can modify with this happens?

    I should add, I am not trying to connect to any servers to retrieve data.  Just looking to use local excel files.

     

    Thanks

    Friday, February 18, 2011 12:06 AM
  • Normally this happens when the MSOLAP OLEDB provider components are modified. Note: PowerPivot and Excel distributes this component.

    Excel 2010 distributes older version which doesn't support PowerPivot functionalities. When you install PowerPivot you will receive a newer version of MSOLAP OLEDB Provider. I think in your case by somehow the OLEDB provider version could have been modified. I couldn't guess what causes it.

    Here are some of things to try,

    1) Go to C:\program files\microsoft analysis services\AS OLEDB\10 check the version of msolap100.dll it should be 10.5.<>.<>. If it is 10.0 then it's older.

    2) You can repair PowerPivot or un-install and re-install PowerPivot should bring the correct version.

    Hope this helps!

     


    Thanks, Deva [MSFT] My blog: http://powerpivot.spaces.live.com/
    Tuesday, February 22, 2011 8:36 PM
  • I'm having the same problem as CesarT and Owen_2 as well

    I have version 10.50.1747.0 of MSOLAP100.DLL. I tried to un-install and re-install PowerPivot several times, but it doesn't solve the problem.

    Are there other things that I can try?

    Thanks a lot!

    Friday, March 04, 2011 9:29 PM
  • Running a repair worked a treat, thanks!

    Wednesday, February 22, 2012 9:02 AM