none
MS SQL Server Management Studio Can Not Connect

    Question

  • I made no changes since last I ran this report yet now I am getting the error message:

    MSQL Server Management Studio Can Not Connect

    What do I need to do to get these two to speak to one another?


    me

    Sunday, February 26, 2012 8:48 PM

Answers

  • It looks like everything is started (Edit: except SQL Server Agent (EMSQL08S2SEP11) and you may want to start this if you have job, alerts etc on the EMSQL08S2SEP11 instance)

    Now for your very first screen shot, in the server name you will need to enter the instance you would like to connect to.

    It appears you had entered (local) for server name, but this doesn't exist.

    You'll need to enter one of the below (substitute computername for the name of your server) which contains the BigFile database (as per your screen shot) and you should connect.

    computername\ACT7
    computername\EMSQL08S2SEP11
    computername\SQLEXPRESS
    computername\DENALI_SQL_FORCR

    Once you are connected your command should run.


    • Edited by KevinNicholas Monday, February 27, 2012 1:13 AM
    • Marked as answer by ShawnHarmon Monday, February 27, 2012 1:49 AM
    Monday, February 27, 2012 1:10 AM

All replies

  • Have you checked that the SQL Server service is started?
    Sunday, February 26, 2012 9:59 PM
  • Hi,

    also you should make sure that you have the correct instance which you want to connect to (for example with a SQL Express installation - (local)/SQLExpress - or to a named instance - YourPcName/YourInstanceName).


    Best Regards. When you see answers and helpful posts, please click Vote As Helpful, Propose As Answer, and/or Mark As Answer. This helps us build a healthy and positive community.

    Sunday, February 26, 2012 10:17 PM
  • Thank you but as mentioned I am lacking in intellect, how do I check is SQL Server service is started and how d I check the correct instance?

    This thing was working fine for 6 months.


    me

    Sunday, February 26, 2012 10:33 PM
  • You can check in the SQL Server Configuration Manager (which can be found in the SQL Server folder under "All Programs") if the service is running. The correct instance depends on your installation. If you just have installed one SQL Server instance and didn't changed the instance name during the installation you have two options:

    • if you have a SQL Server Express instance you should be able to connect to it with the following: (local)/SQLExpress
    • if you have another version of SQL Server the following should work: (local)

    You can also check in the SQL Server Configuratio Manager which version is installed.


    Best Regards. When you see answers and helpful posts, please click Vote As Helpful, Propose As Answer, and/or Mark As Answer. This helps us build a healthy and positive community.

    Sunday, February 26, 2012 10:43 PM
  • You can view the status on the services via SQL Server Configuration Manager http://technet.microsoft.com/en-us/library/ms189925.aspx.

    To connect to SQL Server you'll need to ensure that the SQL Server service is started.

    If you see SQL Server (MSSQLSERVER) then you can use (local) to connect as shown in your screen shot.

    If you see SQL Server (someothername) then you will have to use yourservername\someothername to connect and the SQL Server Browser service should be started. If you don't start the SQL Server Browser you'll have to use the port the number i.e. servername\someothername,portnumber.

    Sunday, February 26, 2012 10:50 PM
  • Okay I opened SQL Services Config and here is what it shows (also included SQL installed Discovery Report beneath the Services Screenshot):


    me

    Sunday, February 26, 2012 11:06 PM
  • That error message 0x800706be is likely an indication that you need to open another SQL Server Configuration Manager on your server as you have multiple versions installed e.g. 2008 R2 and Denali.

    The SQL Server Configuration Manager you opened cannot return the service status for the SQL Server 2008 R2 services

    Either

    • look for another SQL Server Configuration Manager, under the various versions, or
    • go to services.msc and check the SQL Service states there

    You also have this question open http://social.msdn.microsoft.com/Forums/en-US/sqltools/thread/44846adb-a215-4330-a098-d074d3e28e57/ so please ensure that you are working the correct files, i.e. the evaluation warning is not relating to Denali.

    Edit: To connect to these instances you would use the below and the SQL Server Browser service should be started.

    computername\ACT7
    computername\EMSQL08S2SEP11
    computername\SQLEXPRESS
    computername\DENALI_SQL_FORCR


    Sunday, February 26, 2012 11:16 PM
  • Hi Kevin,

    do not know my next step, see screenshot of services.msc :


    me

    Monday, February 27, 2012 12:59 AM
  • It looks like everything is started (Edit: except SQL Server Agent (EMSQL08S2SEP11) and you may want to start this if you have job, alerts etc on the EMSQL08S2SEP11 instance)

    Now for your very first screen shot, in the server name you will need to enter the instance you would like to connect to.

    It appears you had entered (local) for server name, but this doesn't exist.

    You'll need to enter one of the below (substitute computername for the name of your server) which contains the BigFile database (as per your screen shot) and you should connect.

    computername\ACT7
    computername\EMSQL08S2SEP11
    computername\SQLEXPRESS
    computername\DENALI_SQL_FORCR

    Once you are connected your command should run.


    • Edited by KevinNicholas Monday, February 27, 2012 1:13 AM
    • Marked as answer by ShawnHarmon Monday, February 27, 2012 1:49 AM
    Monday, February 27, 2012 1:10 AM
  • Got it. Seems like the whole issue was the server name.

    me

    Monday, February 27, 2012 1:49 AM