none
503 Error - The service is unavailable

    Question

  • I have recently installed SQL 2005 Express Edition with Advanced Services and, after a couple of tries, got everthing to intall - Reporting Services and Business Development Studio. The Report Server appears to have configured correctly (green check marks) except when I go to access the Report Server (http://localhost), I get the 503 Error. I have tried restarting IIS (7.0) and ASP.Net 2.0, to no avail. I am running Windows Vista Ultimate. Everything is on one machine. Thanks in advance for any help.

    Wednesday, April 23, 2008 4:57 AM

Answers

  • Hi,

    Is there any proxy server or windows policy in the scenario? First, please install the service pack 1 for Windows Vista. Then you may try to reinstall the IIS.

    Hopefully this helps.

     

    Friday, April 25, 2008 9:32 AM
  • Thank you for the suggestion. I actually upgraded to Vista Ultimate from Home Premium and the upgrade included SP1.

     

    I have discovered that although I had several indications that the localhost was running, on checking the IIS 7.0 Manager, I found it was not. That lead me to a 404.0 error indicating the report server database was missing. I am in the process of reinstalling Reporting Services (I'd rather have a root canal), so we'll see if I get it all this time.

     

    Sunday, April 27, 2008 3:28 AM

All replies

  • You can turn off 'display friendly error display' in you IE, then you can get detail error information.

    And I think if you want access report server, you should try http://localhost/reports or http://localhost/reportserver

     

    Wednesday, April 23, 2008 7:31 AM
  • Roger,

     

    Thanks for the reply. I guess I didn't mention that I am using SQL Server Express so the Report Server uses .../reports$sqlexpress or .../reportserver$sqlexpress. The only reference I found regarding "display friendly error messages" in IE was in the Advanced Settings under "Show friendly HTTP error messages". Unchecking it had no effect.

     

    Thursday, April 24, 2008 3:51 AM
  • I guess I did mention that I was using the Express edition. :-)

     

    Thursday, April 24, 2008 3:52 AM
  • Hi,

    Is there any proxy server or windows policy in the scenario? First, please install the service pack 1 for Windows Vista. Then you may try to reinstall the IIS.

    Hopefully this helps.

     

    Friday, April 25, 2008 9:32 AM
  • Thank you for the suggestion. I actually upgraded to Vista Ultimate from Home Premium and the upgrade included SP1.

     

    I have discovered that although I had several indications that the localhost was running, on checking the IIS 7.0 Manager, I found it was not. That lead me to a 404.0 error indicating the report server database was missing. I am in the process of reinstalling Reporting Services (I'd rather have a root canal), so we'll see if I get it all this time.

     

    Sunday, April 27, 2008 3:28 AM