none
SQL Network Interface, error 28

    Question

  • When I initially downloaded SQL Server Express the System tables were visible using SQL Server Management Studio Express.  I was able to create a new database and define and populate a couple of small tables.  I then attempted to set up an ODBC SQL Natvie Client connection so that I could print the table contents using Crystal Reports.  That failed with the following error message:

    "An error occurred while establishing a connection to the server.  When connecting to SQL Server 2005, this failure may be caused by the fact that under the default setting SQL Server does not allow remote connections."

     

    I subsequently uninstalled and reinstalled SQL Server Express.  Now, I get the following error message whenever I try to connect to the database using SQL Server Management Studio Express.  Additionally, the System tables are no longer visible.  However, I can access my database via the Server Explorer in VS2005.

     

    TITLE: Connect to Server
    ------------------------------

    Cannot connect to STAN-DELL\SQLEXPRESS.

    ------------------------------
    ADDITIONAL INFORMATION:

    An error has occurred while establishing a connection to the server.  When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: SQL Network Interfaces, error: 28 - Server doesn't support requested protocol) (Microsoft SQL Server, Error: -1)

    For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&EvtSrc=MSSQLServer&EvtID=-1&LinkId=20476

     

     

    Sunday, October 07, 2007 12:15 PM

All replies

  • Today atleast in 4 different posts i replied for the same issue. In sql server 2005 , after installation , you have to configure SQL server for Remote access. Thats what the first issue was and you don't had to uninstall atall.. As far as system tables are concerned... In sql server system tables are not exposed to the user. Its in the form of Catalog view/DM Views/Compatibility views.. read about these terms in BOL. You don't have to worry about that...

     

    Follow the KBs /Blogs/Thread mentioned below... you can solve this issue

    (a) Check the service is started

    (b) Configure server for remote access

    (c) Check SQL Browser Service is running

    (d) Create exception if firewall is enabled

    (e) Enable TCP/IP protoclo

     

    Refer :

    http://support.microsoft.com/kb/914277

    http://blogs.msdn.com/sql_protocols/archive/2005/12/22/506607.aspx -- Check Error Message 7 in this blog. Its clearly described.

    http://blogs.msdn.com/sql_protocols/archive/2005/09/28/474698.aspx

    http://blogs.msdn.com/sql_protocols/archive/2006/09/30/SQL-Server-2005-Remote-Connectivity-Issue-TroubleShooting.aspx

     http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=2234570&SiteID=1

     

     

    Madhu
    Sunday, October 07, 2007 3:43 PM
    Moderator
  • I am now encountering the infamous Named Pipes Provider, error 40 - Could not open a connection to SQL Server.

     

    My configuration is: Vista Home Premium, SQL Server Express and I'm trying to access a database on an instance named AxisSQLServer in a C# application.

     

    I have selected (as suggested in the previous exchange) "Local and Remote, using TCP/IP only" in the Surface Area Configuration for Services and Connections.

     

    SQL Server is started.

    SQL Server Brower is started.

     

    Both programs have been added as exceptions in the firewall (don't understand why I would need to do this since everything is on the same box).

     

    Have turned off McAfee AV. 

     

    My connection string reads:

    string connectionString = "Data Source=localhost;" +

    "Initial Catalog=AxisSQL;Integrated Security=SSPI";

    where "AxisSQL" is the database I'm trying to read.

     

    I have looked at numerous forums and blogs and nothing has helped.  I'm not a system administrator so any help that you can provide should be very explicit.

     

    Thanks....  Stan

     

    Monday, December 03, 2007 2:59 PM
  • Thanks Madhu, This solves my problems too.
    Thursday, December 20, 2012 2:53 PM
  • Would you please check-out

    http://blogs.msdn.com/b/sql_protocols/archive/2008/04/30/steps-to-troubleshoot-connectivity-issues.aspx

    Step 4


    FAQ
    ----
    Regards,
    Ahmed Ibrahim
    SQL Server Setup Team
    My Blog
    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" and "Vote as Helpful" on posts that help you.
    This can be beneficial to other community members reading the thread.
    View Ahmed Ibrahim's profile on LinkedIn

    Thursday, December 20, 2012 7:20 PM
    Moderator