none
SSIS Error Code DTS_E_CANNOTACQUIRECONNECTIONFROMCONNECTIONMANAGER. The AcquireConnection method call to the connection manager failed with error code 0xC0202009.

    Question

  • Hi,

    I have the following error while executing my package.It runs fine on my machine and also delay validation is set to true.. any inputs?

     

    Source:Data Flow Task/n/tErrorCode:-1071611876/n/tError Description:SSIS Error Code DTS_E_CANNOTACQUIRECONNECTIONFROMCONNECTIONMANAGER.  The AcquireConnection method call to the connection manager "STAGE" failed with error code 0xC0202009.  There may be error messages posted before this with more information on why the AcquireConnection method call failed.

    Monday, September 19, 2011 2:24 PM

Answers

  • Solved the issue..it was the connection string...

    "Provider=SQLNCLI10;Data Source=xxxx;Initial Catalog=xxxxx;Integrated Security=SSPI;"

    missed the provider initially...in the c# app

    now its working..

     

    • Marked as answer by RAGS1109 Monday, September 19, 2011 6:17 PM
    Monday, September 19, 2011 6:17 PM

All replies

  • You need to check the credentials that you have provided for the connections. Where are you executing the package, as you said it works on ur pc. If thats the case be sure that the SSIS package has no issues there are some issue in the environment. Check the credentials.
    My Blog    |      Ask Me     |
    Monday, September 19, 2011 2:40 PM
  • What credentials should i set?i have set the delayvalidation as true and the connection string passed to the package in this way..

    package.Connections["STAGE"].ConnectionString = STAGE_DB_CONN_STRING;

    i can connect manually to this environment...

    Monday, September 19, 2011 2:48 PM
  • Where are you setting this connection? In the connection string are you passing password or windows authentication?? If windows auth does your id have access to the resource??
    My Blog    |      Ask Me     |
    Monday, September 19, 2011 3:16 PM
  • yes,i am using windows  auth and my id has the access...
    Monday, September 19, 2011 3:29 PM
  • Where are you using the connection STAGE? What kind of connection is this??
    My Blog    |      Ask Me     |
    Monday, September 19, 2011 3:53 PM
  • this is under the connection manager in the package...which is accessed through the C# App this way:

    if (package.Connections.Contains("STAGE"))
                    {
                        package.Connections["STAGE"].ConnectionString = STAGE_DB_CONN_STRING;
                    }
                    if (package.Connections.Contains("REL"))
                    {
                        package.Connections["REL"].ConnectionString = REL_DB_CONN_STRING;
                    }

     

     

    Monday, September 19, 2011 4:34 PM
  • Is your package working on ur system with the same code?
    My Blog    |      Ask Me     |
    Monday, September 19, 2011 4:35 PM
  • yes,it works when i connect to the local sqlserver..but fails with this error connecting to dev machine...

    But dtexec runs fine...

    Monday, September 19, 2011 5:07 PM
  • Where are you executing the package? are you just changing the server from local to dev or are you executing the package on the local server?

    What about dtexec how and where with with credentials are you using?

     

    Can you state clearly what you are doing? when are you getting the error and when no error?


    My Blog    |      Ask Me     |
    Monday, September 19, 2011 5:09 PM
  • Solved the issue..it was the connection string...

    "Provider=SQLNCLI10;Data Source=xxxx;Initial Catalog=xxxxx;Integrated Security=SSPI;"

    missed the provider initially...in the c# app

    now its working..

     

    • Marked as answer by RAGS1109 Monday, September 19, 2011 6:17 PM
    Monday, September 19, 2011 6:17 PM