none
Urgent - No mapping between account names and security IDs was done error !

    Question

  • Hi There

    When i go to configuration manager and change the sql server service to run as a domain account i get the following error:

    No mapping between account names and security IDs was done.

    This is Sql Server Express running on a domain controller - Windows Server 2003 R2.

    Everything i find ont he net refer to IIS, DHCP etc etc , i cannot find the issue regrading sqls server configuration manager.

    Thanx

    Wednesday, February 28, 2007 3:18 PM

Answers

  • Two things - ensure that the user account you're starting wityh has permissions to log on locally. If in doubt, add them to a local group that can.

     

    Second - if this is a new account, make sure you wait for the account to replicate through the domain. This can take up to 15 minutes on a local network.

    Thursday, March 01, 2007 6:32 PM

All replies

  • Two things - ensure that the user account you're starting wityh has permissions to log on locally. If in doubt, add them to a local group that can.

     

    Second - if this is a new account, make sure you wait for the account to replicate through the domain. This can take up to 15 minutes on a local network.

    Thursday, March 01, 2007 6:32 PM
  • Was the machine a DC when you installed SQL Server on it, or was it made a DC afterwards?

    Thanks
    Laurentiu

    Friday, March 02, 2007 6:59 PM
    Moderator
  • I have a similar problem.   And the server was made a Domain controller after installing SQL.  Where were you going with that thought?

     

    Friday, April 25, 2008 9:08 PM
  • I'm also having this problem with SQL Server after installing the domain controller on the same server. Any solutions?
    Wednesday, November 12, 2008 9:44 AM
  • Found a solution:
    - You need to uninstall SQL Server first. But you will get errors... so first do the workaround at
    http://support.microsoft.com/kb/925976
    - Re-install SQL Server... Problem solved!
    Wednesday, November 12, 2008 11:23 AM
  • Hi, I would say uninstallation and re-installation should always be the last option. I faced the same issue while adding users in membership in SQL Server 2008 analysis Services. And the solution is - I found few users were already existing in the role membership which no longer existed in the domain and that's why when I was trying to add an user, it was trying to validate all the listed users and throwing error. I deleted the listed non-existing users and then tried to add the somain user again. this time it worked !! For more solutions, visit the scripts section of www.sqlDBAGuru.com

     

    • Proposed as answer by Sujeet Saha Tuesday, December 28, 2010 11:39 AM
    Tuesday, December 28, 2010 11:39 AM
  • hai all,

     

    there is a working scenario

    1. check the RPC service, If it is stopped start .

    2. Verify
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc\SecurityService]
    "68"="netlogon.dll"

    3. if it is not there add to registry.

    3. reboot the machine.

    I am sure it should help you

    Best luck

    Nidhin Gopalakrishnan

    Saturday, January 08, 2011 9:06 AM
  • Hi All,

    I spend two days on this issue. Finaly worked with microsoft support and if you are getting error 'No mapping between account names and security IDs was done' when attempting to change the login for sql server from SQL configuration manager then below is how to fix it. Below are all the details for you. Error was caused by Cert issue in SQL 2005. If I attempt to start sql service it does start but then when attemp to connect to it it gvies me sql server error 233. Below is what I did to fix it.

    -- Go to start run type mmc and click ok

    --Click file add snap in for certicicate

    -- Click certiicate personal certificates

    -- Export all existing certicficates that SQL uses

    -- You can check which certificates has been used by your instance from sql configuration manager click on protocol properties and certificate

    -- After exporting certificates stop SQL service for instance and delete all certs in mmnc certificates personal

    -- Attempt to start SQL service now

    -- If it still gives you error then go to following registry setting backup your registry and delete the following from registry.

    -- delete the certificate entry from hkey_local_machine\software\microsoft\microsoft sql server\mssql.1\mssqlserver\supersocketnetlib (where mssql.1 is instance of sql). You should delete the value in the certificate so it would become empty.

    -- Restart SQL Service and it worked for me

     


    syed


    Thursday, June 30, 2011 11:46 PM
  • Thank you for posting this soln!
    Sunday, July 24, 2011 2:44 PM
  • Hi, I would say uninstallation and re-installation should always be the last option. I faced the same issue while adding users in membership in SQL Server 2008 analysis Services. And the solution is - I found few users were already existing in the role membership which no longer existed in the domain and that's why when I was trying to add an user, it was trying to validate all the listed users and throwing error. I deleted the listed non-existing users and then tried to add the somain user again. this time it worked !! For more solutions, visit the scripts section of www.sqlDBAGuru.com

     

    This was my issue also, glad I didn't follow the advice ref reinstall etc !

    Another good reason to use AD Groups rather than users in Role definitions...

    Monday, March 05, 2012 11:23 AM
  • Thank you, Sujeet Saha. Your post is helpful.
    Monday, July 22, 2013 3:36 PM