none
Bar Graph spanned into multiple pages got unwanted while space in chrome/FF

    Question

  • Hi,

    I have a report with multiple bar graphs that spanned into multiple pages. Each region has got a bar graph. I have set the interactive page size property to 0 so that all graphs will be shown in one page in the reoprt viewer control on a web page. This is working perfectly fine in IE. But in Google chrome and Firefox, there is lot of unwanted while space showing up. Tried setting up all kinds of properties on Report, Body, Rectangle and Tablix but none of them are removing this while space. Can anybody help me fix this issue?

    Thanks

    Prashanth


    Prashanth Podduturi

    Saturday, August 24, 2013 1:32 AM

Answers

  • Hi Prashanth,

    In Reporting Services, we use a web browser to view reports. However, not all browsers support all report functionality. Currently, only the Internet Explorer supports all report functionality.

    From your description, you are using a ReportViewer control to display a report in an ASP .NET Web application. Due to differences in the rendering engines of the supported browsers, some advance report features may be displayed differently in different browsers. You can try to turn off/on the asynchronous rendering to see if it works. However, it’s recommended that you use IE to browse the reports.

    Reference:
    http://technet.microsoft.com/en-us/library/ms156511.aspx#bkmk_controls

    Regards,


    Mike Yin
    TechNet Community Support

    Friday, August 30, 2013 3:32 AM

All replies

  • Hi Prashanth ,

    Just a suggestion :

    Make sure you have proper spacing between Bar graphs(report items) and report body (reduce unwanted spaces).

    If possible add all bar graphs inside Rectangle and reduce space b/w rectangle and report body .

    And give a try with ConsumeContainerWhitespace property -

    http://beyondrelational.com/modules/2/blogs/115/posts/11153/consumecontainerwhitespace-property-to-remove-blank-space-in-ssrs-2008-report.aspx


    sathya --------- Mark as answered if my post solved your problem and Vote as helpful if my post was useful.

    Saturday, August 24, 2013 6:47 AM
  • Hi Sathya,

    thank you for your reply. I have already tried the ConsumeWhiteSpace set to True, it didn't worked. I have only one graph but that is placed inside a list with a group by clause. From the Db, i get some data and i am using one of the column as Group By Clause in the list control and the remaining fields are used to generate the graph.


    Prashanth Podduturi

    Saturday, August 24, 2013 7:13 PM
  • Hi Prashanth,

    In Reporting Services, we use a web browser to view reports. However, not all browsers support all report functionality. Currently, only the Internet Explorer supports all report functionality.

    From your description, you are using a ReportViewer control to display a report in an ASP .NET Web application. Due to differences in the rendering engines of the supported browsers, some advance report features may be displayed differently in different browsers. You can try to turn off/on the asynchronous rendering to see if it works. However, it’s recommended that you use IE to browse the reports.

    Reference:
    http://technet.microsoft.com/en-us/library/ms156511.aspx#bkmk_controls

    Regards,


    Mike Yin
    TechNet Community Support

    Friday, August 30, 2013 3:32 AM
  • Hi Mike,

    I tried setting the asynchronous rendering to true and false, it didn't work. I tried setting the docType also as per your link suggestion but that too didn't worked. I am using IE 9.0 with Windows 7 Prefessional (64 bit) with VS 2010. Any other suggestions to fix this problem will be greatly appreciated.

    Thanks

    Prashanth


    Prashanth Podduturi

    Friday, September 06, 2013 1:06 AM
  • Hi Prashanth,

    Thanks for your posting.

    I suggest that you walk through the following blog which should be helpful:
    http://blog.lavablast.com/post/2011/06/28/Gotcha-Reporting-Services-Viewer-bugs-on-Google-Chrome.aspx

    Regards,


    Mike Yin
    TechNet Community Support

    Friday, September 06, 2013 1:21 AM