none
SQL sever 2012 install

    Question

  • I'm getting the below error when trying to install sql2012 remotely using a service account (it works fine with my personal account) .. it also works when logging into the server with the service account.  I have enable credential delegation on my client and the remote server but still getting the error.  All files are locally on the server all i'm doing is an invoke-command and calling a script that is local to the server.  Any help is appreciated.

    Message:
            There was an error generating the XML document.
        HResult : 0x84b10001
            FacilityCode : 1201 (4b1)
            ErrorCode : 1 (0001)

    The requested operation cannot be completed. The computer must be trusted for delegation and the current user account must be configured to allow delegation.

    Thanks in advance!

    Tuesday, July 08, 2014 4:49 PM

Answers

  • Looks like this is an issue with your account , so either you can try direct remote, what is the level of permission that service account is having ? In what level you are getting error ? can you check is there anything get recorded in the setup log ?

    http://technet.microsoft.com/en-us/library/cc782684%28v=ws.10%29.aspx

    http://windowsitpro.com/windows/jsi-tip-7359-how-do-i-configure-accounts-so-they-are-trusted-delegation-windows-server-2003-

    technet2.microsoft.com/WindowsServer/en/library/bef202b0-c8e9-4999-9af7-f56b991a4fd41033.mspx?mfr=true


    Raju Rasagounder Sr MSSQL DBA

    Tuesday, July 08, 2014 10:23 PM
  • Hello,

    This issue is probably related to the .NET Framework. Try to disable and enable .NET Framework again using Control Panel -> Programs and Features. The following tool may help too:

    http://support.microsoft.com/kb/2698555



    Another way to make it work is trying to install SQL Server using another Windows account. Make sure you run setup with the “Run as Administrator” option.

    Hope this helps.

    Regards,

    Alberto Morillo
    SQLCoffee.com

    Wednesday, July 09, 2014 4:09 AM

All replies

  • Looks like this is an issue with your account , so either you can try direct remote, what is the level of permission that service account is having ? In what level you are getting error ? can you check is there anything get recorded in the setup log ?

    http://technet.microsoft.com/en-us/library/cc782684%28v=ws.10%29.aspx

    http://windowsitpro.com/windows/jsi-tip-7359-how-do-i-configure-accounts-so-they-are-trusted-delegation-windows-server-2003-

    technet2.microsoft.com/WindowsServer/en/library/bef202b0-c8e9-4999-9af7-f56b991a4fd41033.mspx?mfr=true


    Raju Rasagounder Sr MSSQL DBA

    Tuesday, July 08, 2014 10:23 PM
  • Hello,

    This issue is probably related to the .NET Framework. Try to disable and enable .NET Framework again using Control Panel -> Programs and Features. The following tool may help too:

    http://support.microsoft.com/kb/2698555



    Another way to make it work is trying to install SQL Server using another Windows account. Make sure you run setup with the “Run as Administrator” option.

    Hope this helps.

    Regards,

    Alberto Morillo
    SQLCoffee.com

    Wednesday, July 09, 2014 4:09 AM