none
Failed to load XML from the package file "" due to error 0xC00CE556 "Invalid at the top level of the document.Line.

    Question

  • Using Installation wizard to deploy SSIS packages from DEV server to QA server package store cause this error;
    Failed to load XML from the package file "" due to error 0xC00CE556 "Invalid at the top level of the document. Line 773, Column 93". This happens when loading a package and the file cannot be opened or loaded correctly into XML document.  This can be the result of either providing an incorrect file name to the LoadPackage method or the XML file specified having an incorrect format.  Please who have the idea of how this issue can be resolved?
    BI Developer
    Tuesday, June 07, 2011 3:49 PM

Answers

  • Check if the source SSIS build (e.g. SSIS 2005 was used) matched the target (e.g. you have SSIS 2008 in there).

    This error most likely is a result of some SSIS version discrepancies any way.

    Another small chance the package file which is a XML got corrupted.


    Arthur My Blog
    By: TwitterButtons.com
    • Marked as answer by Abioye Wednesday, June 08, 2011 1:39 PM
    Wednesday, June 08, 2011 2:22 AM
    Moderator

All replies

  • Check if the source SSIS build (e.g. SSIS 2005 was used) matched the target (e.g. you have SSIS 2008 in there).

    This error most likely is a result of some SSIS version discrepancies any way.

    Another small chance the package file which is a XML got corrupted.


    Arthur My Blog
    By: TwitterButtons.com
    • Marked as answer by Abioye Wednesday, June 08, 2011 1:39 PM
    Wednesday, June 08, 2011 2:22 AM
    Moderator
  • Yes for some reasons the XML got corrupted. I rebuild the packages on the dev. server again and copy to QA server and it worked. From searching through the internet I saw that this error happened mostly when packages are copied or moved from one server to another. And this reason could be SSIS version discrepancies which could result in corrupted XML And the solution mostly involved rebuilding the package on the destination server. Thanks so much


    BI Developer
    Wednesday, June 08, 2011 1:46 PM
  • Hi ,

       for this Error one and only one solution 

    go to view Code, line number and Column number shown in error message,

    and Remove code from there till last and save it,  it happens when we are moving Package from one server to another server. and VS adds some lines of code at the bottom of package

    something like this 

    andles="1" allownudging="1" isannotation="0" dontautolayout="0" groupcollapsed="0" tabstop="1" visible="1" snaptogrid="0">
        <control>
          <ddsxmlobjectstreaminitwrapper binary="00080000921400008c040000" />
        </control>
        <layoutobject>
          <ddsxmlobj>
            <property name="LogicalObject" value="{BBFB0E

    Remove this code and save package it will work.  

    hope this will help to Developers who are searching for same ......... :) 

    Monday, May 20, 2013 7:07 AM