none
Problem with valid owner

    Question

  • I have just downloaded the MS SQL Server Management Studio Express, and are following a tutorial on www.learnvisualstudio.net 

    Now I am having trouble with some owner information. The message says :

    "Database diagram support objects cannot be installed because this database does not have a valid owner. To continue, first use the Files page of the Database Properties dialog box or the ALTER AUTORIZATION statement to set the database owner to a valid login, then add the database diagram support objects"

    I should mention that my WIN XP username is "Bjørn" with the Norwegian letter "Ø" in the middle. I suspect it to have a problem with that letter?

    Any better suggestions?

    Wednesday, May 03, 2006 9:38 AM

Answers

  • http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=120849&SiteID=1

    When the database does not have a valid owner, the database dialog displays the owner as the logged in user.  (This issue will be fixed in SP1.) 

    The "no valid owner" issue usually comes up when databases are owned by SQL-authentication logins and are upgraded, detached/attached to another server, or restored from backup to another server.  The SID (a large number) doesn't match any existing login on the new server, so the owner name remains whatever it was on the old server, but it is marked invalid.  Explicitly setting the owner to a valid principal on the server solves the problem.

    There is also a known issue when the UI tries to install the database support objects on databases where the compatibility level is set to 80 (SQL Server 2000).  The installation fails and the UI incorrectly reports that the database has no valid owner.  Setting compatibility level to 90 (SQL Server 2005) before installing the diagram support objects solves this problem.  (This issue will also be fixed in SP1.)


    HTH

    Thursday, May 04, 2006 11:57 PM

All replies

  • http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=120849&SiteID=1

    When the database does not have a valid owner, the database dialog displays the owner as the logged in user.  (This issue will be fixed in SP1.) 

    The "no valid owner" issue usually comes up when databases are owned by SQL-authentication logins and are upgraded, detached/attached to another server, or restored from backup to another server.  The SID (a large number) doesn't match any existing login on the new server, so the owner name remains whatever it was on the old server, but it is marked invalid.  Explicitly setting the owner to a valid principal on the server solves the problem.

    There is also a known issue when the UI tries to install the database support objects on databases where the compatibility level is set to 80 (SQL Server 2000).  The installation fails and the UI incorrectly reports that the database has no valid owner.  Setting compatibility level to 90 (SQL Server 2005) before installing the diagram support objects solves this problem.  (This issue will also be fixed in SP1.)


    HTH

    Thursday, May 04, 2006 11:57 PM
  • Thank you for taking the time to help me.

    The compatibility level was already set to 90, so that didn't solve the problem.

    When I tried to set a new owner, I got this message:

    TITLE: Microsoft SQL Server Management Studio Express
    ------------------------------

    Set owner failed for Database 'MyCompany'.  (Microsoft.SqlServer.Express.Smo

    ------------------------------
    ADDITIONAL INFORMATION:

    An exception occurred while executing a Transact-SQL statement or batch. (Microsoft.SqlServer.Express.ConnectionInfo)

    ------------------------------

    An entity of type database cannot be owned by a role, a group, an approle, or by principals mapped to certificates or asymmetric keys. (Microsoft SQL Server, Error: 15353)

     

    Sunday, May 07, 2006 8:38 PM
  • Hi,

    Do you fin a solution ? I have the same problem ...

    Thanks

    Monday, January 29, 2007 11:00 AM
  • Yes. I think I changed the owner to sa  (server admin I think it is)
    Monday, January 29, 2007 11:06 AM