none
Microsoft SQL Server 2012 Standard Error 233 and 18456

    Question

  • SQL Server 2012 Standard on Windows Server 2012, all updates installed.

    When using Visual Studio SQL Server Management Studio and using the Connect button in an attempt to connect to the database engine or other services, I get error 18456. When trying to connect via the Connect Object Explorer button I receive error 233.

    I tried disabling Windows Firewall.

    I opened Ports 1433 & 1434

    I enabled inbound dynamic connection to application sqlserver.exe.

    I am trying to log on as the administrator with the correct administrator password.

    I am using Windows Authentication. (SQL Authentication generates Error 18456, Status 1, in all cases)

    Object Explorer will connect to the default SQL instance Integration services, but generates the same errors for all other connections.

    Any suggestions?


    • Edited by grahamvb Wednesday, December 18, 2013 9:38 PM
    Wednesday, December 18, 2013 9:37 PM

Answers

  • 8OK, let me ask: why do you think this should work? That is, did you actually add this Windows login as a login to SQL Server? By default, you are not permitted to connect to SQL 2012 just because you are a Windows administrators. When you installed SQL 2012 you were supposed to specify a user who is an admin. (In difference to SQL 2005 which had BUILTIN\Administrators as a server principal by default.)

    Also, don't forget the implications of UAC; you may want to try with "Run as Administrator".


    Erland Sommarskog, SQL Server MVP, esquel@sommarskog.se
    Thursday, December 19, 2013 8:54 AM

All replies

  • I am trying to log on as the administrator with the correct administrator password.

    I am using Windows Authentication.

    I sense a contradiction. When you use Windows authentication, you don't specify any password. Or username for that matter.

    Are you logged in as DOMAIN\someone and then specify DOMAIN\Administrator when you connect to SQL Server? That will fail, unless there happens to be an SQL login with that name. If you want to login to SQL Server with a certain Windows user, you need to be logged into Windows with that user (or at least use RunAs).


    Erland Sommarskog, SQL Server MVP, esquel@sommarskog.se
    Wednesday, December 18, 2013 10:34 PM
  • You are correct, sorry for the miscommunication, I am successfully logged in as administrator to Windows server and am attempting to log onto SQL Server using windows authentication. I was guessing, possibly incorrectly, that the administrator name and password were used/passed along in windows authentication. Yes I am logged in as DOMAIN\Administrator.

    I should also mention that it is a named instance that I am attempting to log on to. But I have the same issues attempting logon to the default instance.



    • Edited by grahamvb Thursday, December 19, 2013 1:56 AM
    Thursday, December 19, 2013 1:52 AM
  • I enabled inbound dynamic connection to application sqlserver.exe.

    Hello,

    Is it only you (the domain admin) who can't connect, but others can or can no one connect to SQL Server? Please lookup the exact error message in ERRORLOG file of SQL Server, when you logon fails; it contains more detailed informations about the reason, then it's shown up in client error message.

    It's a bidrectional communication with SQL Server, only inbound rules in firewall are not enough, you need also outbound rules, of course.


    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    Thursday, December 19, 2013 7:21 AM
    Moderator
  • Hello Graham,

    If you are connecting to the default instance, make sure that you connect using "Hostname"/ (local)/.

    Also, 18456 is a very generic error,

    http://blogs.msdn.com/b/sql_protocols/archive/2006/02/21/536201.aspx

    So what is the level and state entry you are seeing?


    Regards, Don Rohan

    Thursday, December 19, 2013 8:29 AM
  • 8OK, let me ask: why do you think this should work? That is, did you actually add this Windows login as a login to SQL Server? By default, you are not permitted to connect to SQL 2012 just because you are a Windows administrators. When you installed SQL 2012 you were supposed to specify a user who is an admin. (In difference to SQL 2005 which had BUILTIN\Administrators as a server principal by default.)

    Also, don't forget the implications of UAC; you may want to try with "Run as Administrator".


    Erland Sommarskog, SQL Server MVP, esquel@sommarskog.se
    Thursday, December 19, 2013 8:54 AM
  • Olaf, are the details about outbound rules posted somewhere?
    Saturday, January 04, 2014 1:20 AM