none
SSRS drill through - not passing last parameter

    Question

  • SSRS is not passing the last parameter in my drill through report...the first two work fine, but the 3rd requires me to select from the defined Available Values.  For some reason SSRS seems to be ignoring the value being passed for this 3rd parameter.  Omit is set to False on all 3 parameters, and the child report does not have any defined Default values.  Any suggestions?

    Below is a portion of the .rdl file for reference:

                            <Style>
                              <TextAlign>Center</TextAlign>
                            </Style>
                          </Paragraph>
                        </Paragraphs>
                        <rd:DefaultName>BusinessSection1</rd:DefaultName>
                        <ActionInfo>
                          <Actions>
                            <Action>
                              <Drillthrough>
                                <ReportName>DetailBySection</ReportName>
                                <Parameters>
                                  <Parameter Name="Method">
                                    <Value>=Fields!Method.Value</Value>
                                  </Parameter>
                                  <Parameter Name="Section">
                                    <Value>=Fields!BusinessSection.Value</Value>
                                  </Parameter>
                                  <Parameter Name="DateRangeType">
                                    <Value>=Fields!DateRangeType.Value</Value>   ***this value is not being passed***
                                  </Parameter>
                                </Parameters>
                              </Drillthrough>
                            </Action>
                          </Actions>
                        </ActionInfo>
                        <ToolTip>Click to View Detailed Report</ToolTip>

    • Edited by danawex Thursday, May 09, 2013 9:18 PM
    Thursday, May 09, 2013 6:00 PM

Answers

  • Tim, I'm giving credit to you for fixing my problem...you got me thinking, and data type was the issue. 

    The Parameter 'DateRangeType' (Text data type) only determines which date range to use, either Fiscal Year or Calendar Year, but the actual VALUE being passed is Int (the year itself).  i had to use the an expression to accurately define it and now it works!  (whew!)

    .rdl file now reads: 

    <Parameter Name="DateRangeType">
    <Value>=iif(Parameters!DateRangeType.Value="FiscalYear", "FiscalYear","CalendarYear")</Value>

    Friday, May 10, 2013 6:59 PM

All replies

  • Ensure the value you are passing is in the list of available values. Remember that it is caps-sensitive so "DateTime" is not the same as "datetime".  Also, make sure the data type of the field in the drilldown report matches the type of data you are passing.

    "You will find a fortune, though it will not be the one you seek." - Blind Seer, O Brother Where Art Thou
    Please Mark posts as answers or helpful so that others may find the fortune they seek.

    Friday, May 10, 2013 1:47 PM
  • Thanks for your reply Tim!  Great suggestions!

    the value being passed is in the list of available values, there isn't a case issue, and the data types match (both are Int).   i remain stumped!

    Friday, May 10, 2013 5:31 PM
  • Tim, I'm giving credit to you for fixing my problem...you got me thinking, and data type was the issue. 

    The Parameter 'DateRangeType' (Text data type) only determines which date range to use, either Fiscal Year or Calendar Year, but the actual VALUE being passed is Int (the year itself).  i had to use the an expression to accurately define it and now it works!  (whew!)

    .rdl file now reads: 

    <Parameter Name="DateRangeType">
    <Value>=iif(Parameters!DateRangeType.Value="FiscalYear", "FiscalYear","CalendarYear")</Value>

    Friday, May 10, 2013 6:59 PM
  • Glad you got it solved. You should mark your reply as answer and mine as helpful so others can resolve their similar problem.


    "You will find a fortune, though it will not be the one you seek." - Blind Seer, O Brother Where Art Thou
    Please Mark posts as answers or helpful so that others may find the fortune they seek.

    Friday, May 10, 2013 7:21 PM