none
SQLServer Connection issues

    Question

  • Hi All,

    Application users facing connectivity problems,timeout errors and also getting more deadlocks in SQLServer Log.

    Now,

    1. Surface Area Configuration -> only checked " Using TCP/IP Only" not " Using both TCP/IP and named pipes".
    2. SQLServer Configuration Manager - > Named Pipes was in disabled state.

     Is ( both 1 and 2 )  this causing this issue ? Please advise.

    Thanks and Regards,

    Ravi.



    Thursday, June 07, 2012 10:05 AM

Answers

  • Hi Ravi,

    There is a similar thread which describes the same error message as yours. The solution is : Disabling TCP and enabling after service restart.



    Best Regards,
    Peja

    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.


    Friday, June 08, 2012 3:25 AM

All replies

  • What error do you get exactly? 1 and 2 do not cause to deadlocks.

    Best Regards, Uri Dimant SQL Server MVP http://dimantdatabasesolutions.blogspot.com/ http://sqlblog.com/blogs/uri_dimant/

    Thursday, June 07, 2012 10:50 AM
  • Thanks for your prompt reply.

    In SQLServerAgent LOG:

    [298] SQLServer Error: 258, Unable to complete login process due to delay in prelogin response [SQLSTATE 08001]
    [165] ODBC Error: 0, Login timeout expired [SQLSTATE HYT00]
    [298] SQLServer Error: 258, Shared Memory Provider: Timeout error [258]. [SQLSTATE 08001]
    [382] Logon to server '(local)' failed (ConnUpdateStartExecutionDate)

    In SQLServer LOG:

    "New queries assigned to process on Node 0 have not been picked up by a worker thread in the last 60 seconds. Blocking or long-running queries can contribute to this condition, and may degrade client response time. Use the "max worker threads" configuration option to increase number of allowable threads, or optimize current running queries. SQL Process Utilization: 1%. System Idle: 96%. "

    Users facing connectivity problems and also there are more deadlocks.

    Please advise me.

    Thanks and Regards,

    Ravi.


    Thursday, June 07, 2012 11:18 AM
  • Have you decreased MAX Memory parameter to 22GB at least...?

    Best Regards, Uri Dimant SQL Server MVP http://dimantdatabasesolutions.blogspot.com/ http://sqlblog.com/blogs/uri_dimant/

    Thursday, June 07, 2012 11:39 AM
  • Hi Ravi,

    There is a similar thread which describes the same error message as yours. The solution is : Disabling TCP and enabling after service restart.



    Best Regards,
    Peja

    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.


    Friday, June 08, 2012 3:25 AM