none
The e-mail address of one or more recipients is not valid.

    Question

  • Hello,

    i am using SSRS 2008 and created one subscription to send email to the desired people.

    there are 3 email accounts in the recipient list and 1 account is creating a problem. although we can send to this account manually.

    even it gives same error when i specify valid email account from Gmail or Hotmail domain.

    additionally..is there any setting which allows sending mails to valid account and ignore others

    does anybody have solution to this problem?

    PS: i am not using alias in the recipient list, SendEmailToUserAlias is false and not specified any PermittedHosts.

    Thanks in Advance!!

    Deepmala

    Monday, March 12, 2012 8:36 AM

Answers

  • Hello,

    finally the problem is solved by changing Allow Relay Property on the Exchange Server by our Network Admin.

    Regards,

    Deepmala

    Thursday, March 15, 2012 10:34 AM

All replies

  • Deepmala,

    This issues has been addressed below

    Subscription Error: "The e-mail address of one or more recipients is not valid."


    Thanks,
    Sandip Shinde


    Please remember to mark the replies as answers if they help you and unmark them if they provide no help.

    Monday, March 12, 2012 9:46 AM
  • Hi Deepmala,

    I suggest you that refer to the following articles to configure E-mail deliver, please see:
    E-mail Settings: http://technet.microsoft.com/en-us/library/ms189342(v=sql.100).aspx
    Configuring a Report Server for E-Mail Delivery: http://technet.microsoft.com/en-us/library/ms159155(v=sql.100).aspx

    In your case, the subscription will deliver to several recipients. Please use “;” to separate multiple e-mail addresses. If the issue still persists, please post the complete error message to us for further investigation.

    Regards,
    Bin Long

    Bin Long

    TechNet Community Support

    Wednesday, March 14, 2012 7:49 AM
    Moderator
  • Hello Bin,

    thanks for reply.

    I have already checked both the articles specified by you and verified the required settings.

    i have also specified ";" to separate the multiple email address.

    Exact Error : "The e-mail address of one or more recipients is not valid"

    we have also asked our network admin to set the Allow Relay Properties and added IP of Report Server in the section "receive mails from remote server which has following IP". but it is still not working.

    we have noticed that it allows to send email address to accounts in the same domain only (domain where Exchange Server & Report Server are there)

    following is the settings from config file

    <RSEmailDPConfiguration>
    						<SMTPServer>192.168.15.103</SMTPServer>
    						<SMTPServerPort></SMTPServerPort>
    						<SMTPAccountName>
    						</SMTPAccountName>
    						<SMTPConnectionTimeout>
    						</SMTPConnectionTimeout>
    						<SMTPServerPickupDirectory>
    						</SMTPServerPickupDirectory>
    						<SMTPUseSSL>
    						</SMTPUseSSL>
    						<SendUsing>2</SendUsing>
    						<SMTPAuthenticate>
    						</SMTPAuthenticate>
    						<From>Team@ITStocklist.com</From>
    						<EmbeddedRenderFormats>
    							<RenderingExtension>MHTML</RenderingExtension>
    						</EmbeddedRenderFormats>
    						<PrivilegedUserRenderFormats>
    						</PrivilegedUserRenderFormats>
    						<ExcludedRenderFormats>
    							<RenderingExtension>HTMLOWC</RenderingExtension>
    							<RenderingExtension>NULL</RenderingExtension>
    							<RenderingExtension>RGDI</RenderingExtension>
    						</ExcludedRenderFormats>
    						<SendEmailToUserAlias>False</SendEmailToUserAlias>
    						<DefaultHostName>192.168.15.103</DefaultHostName>
    						<PermittedHosts></PermittedHosts>
    					</RSEmailDPConfiguration>

    do you have any idea what is wrong?

    Regards,

    Deepmala


    Wednesday, March 14, 2012 9:37 AM
  • Hello,

    finally the problem is solved by changing Allow Relay Property on the Exchange Server by our Network Admin.

    Regards,

    Deepmala

    Thursday, March 15, 2012 10:34 AM