none
Microsoft Connector by Attunity for Oracle doesn't work in scheduled job

    Question

  • Hi

    I am developing a package using Microsoft Connector by Attunity for Oracle to extract data from Oracle source.

    Server has following installation

    Windows Server 2008

    SQL Server 2008 R2

    Oracle Client 32 bit

    Oracle Client 64 bit

    Microsoft Connector by Attunity for Oracle 64 bit

    when i develop in BIDS the package runs fine and extract records from Oracle source. Now when I am scheduling this package it gives me following error:

    Description: The connection type "MSORA" specified for connection manager "AttunityProvider" is not recognized as a valid connection manager type. This error is returned when an attempt is made to create a connection manager for an unknown connection type. Check the spelling in the connection type name

     

    I need some urgent help please.

     

    Regards

    Harris

     

    Thursday, December 23, 2010 3:50 PM

Answers

  • I'm guessing its a 32/64 bit issue. If you designed the package with the 32 bit connector, the 64 bit one installed on the server may not suffice.
    Todd C - MSCTS SQL Server 2005 - Please mark posts as answered where appropriate.
    • Marked as answer by grahan007 Friday, March 16, 2012 11:06 AM
    Thursday, December 23, 2010 6:04 PM

All replies

  • I'm guessing its a 32/64 bit issue. If you designed the package with the 32 bit connector, the 64 bit one installed on the server may not suffice.
    Todd C - MSCTS SQL Server 2005 - Please mark posts as answered where appropriate.
    • Marked as answer by grahan007 Friday, March 16, 2012 11:06 AM
    Thursday, December 23, 2010 6:04 PM
  • Dear Harris,

    I am getting exactly the same problem as you describe.  I'd be extremely grateful if you could tell me how you solved this.

    Thanks in advance

    Mark Thornton


    Mark Thornton Database Developer Clinical School Computing Service University of Cambridge
    Sunday, May 01, 2011 6:08 AM
  • any answers to this problem? some link?
    Tuesday, July 02, 2013 4:22 PM
  • solution: 

    1) right click "integration service project"

    2) properties

    3) debugging

    4) set Run64BitRunTime to False


    from sql server forum

    • Proposed as answer by Leo Gonzalez Tuesday, July 02, 2013 4:37 PM
    Tuesday, July 02, 2013 4:37 PM