none
SSRS 2005 report builder cannot start application

    Question

  • When i click the report builder button, i will get an error: cannot start application.
    The user has the proper roles in both item and system level, and we are using windows authentication.

    here is the error details
    PLATFORM VERSION INFO
     Windows    : 5.1.2600.131072 (Win32NT)
     Common Language Runtime  : 2.0.50727.3603
     System.Deployment.dll   : 2.0.50727.3053 (netfxsp.050727-3000)
     mscorwks.dll    : 2.0.50727.3603 (GDR.050727-3600)
     dfdll.dll    : 2.0.50727.3053 (netfxsp.050727-3000)
     dfshim.dll    : 2.0.50727.3053 (netfxsp.050727-3000)

    SOURCES
     Deployment url   : http://OurSQLserver/ReportServer/ReportBuilder/ReportBuilder.application
          Server  : Microsoft-IIS/6.0
          X-Powered-By : ASP.NET
          X-AspNet-Version: 2.0.50727

    ERROR SUMMARY
     Below is a summary of the errors, details of these errors are listed later in the log.
     * Activation of http://OurSQLserver/ReportServer/ReportBuilder/ReportBuilder.application resulted in exception. Following failure messages were detected:
      + Your Web browser settings do not allow you to run unsigned applications.

    COMPONENT STORE TRANSACTION FAILURE SUMMARY
     No transaction error was detected.

    WARNINGS
     There were no warnings during this operation.

    OPERATION PROGRESS STATUS
     * [3/8/2010 4:39:35 PM] : Activation of http://OurSQLserver/ReportServer/ReportBuilder/ReportBuilder.application has started.

    ERROR DETAILS
     Following errors were detected during this operation.
     * [3/8/2010 4:39:36 PM] System.Deployment.Application.InvalidDeploymentException (Manifest)
      - Your Web browser settings do not allow you to run unsigned applications.
      - Source: System.Deployment
      - Stack trace:
       at System.Deployment.Application.ApplicationActivator.BrowserSettings.Validate(String manifestPath)
       at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)
       at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)

    COMPONENT STORE TRANSACTION DETAILS
     No transaction information is available.

    Monday, March 08, 2010 9:54 PM

Answers

  • Hi mike,

    The error message "Your Web Browser settings do not allow you to run unsigned applications" means your web browser does not allow to run a application which is not singed with Authenticode.

    We can follow these steps to solve the issue:
    1.Open Internet Explorer(IE)
    2.Click the menu "Tools" >> "Internet Options..."
    3.Go to "Security" tab.
    4.Select "Local Intranet" or "Trusted sites" zone.
    5.Click "Sites" to add the report server site to this zone.
    6.Click "Custom Level", and then enable this item "Run components not signed with Authenticode"
    7.Click OK to apply.

    Now, we should be able to run the Report Builder.

    By the way, this settings may overwrite by the group policy, please contact your domain admin to check this settings in domain.

    If you have any more questions, please feel free to ask.

    Thanks,
    Jin Chen
    Jin Chen - MSFT
    Wednesday, March 10, 2010 8:34 AM