none
Unable to download Microsoft SQL server 2008 R2 express in windows VISTA SP2 32bit OS

    Question

  • I am using window VISTA  SP2. I am trying to install Microsoft SQL Server 2008 R2 express in my system. First it asked me to download and  install Microsoft .Net Framework 3.5 SP1 and then to download and install Windows Installer 4.5. I downloaded it and when I tried  to install it, it showed me an error message " This program is not applicable to your system".I am not able to download sql server 2008 in my system.

    Do I need to change service pack 2 to service pack 1 inorder to download .Net Framework 3.5 SP1 and Windows Installer 4.5.

    Please help me in finding solution for this. Thanks

    Thursday, February 23, 2012 7:55 PM

Answers

  • Hi Preethy,

    Please ensure that the file you downloaded is 32bit (x86) first, the file name should be SQLEXPRWT_x86_ENU.exe. You can download it from this link

    And please also ensure you have installed .net framework 3.5 SP1 and Windows Installer 4.5 successfully.  You can check that in “start”—“control panel”—“Administrative Tools”—“services”.


    Best Regards,
    Iric
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, February 27, 2012 2:43 AM
    Moderator

All replies

  • http://www.microsoft.com/download/en/details.aspx?id=8483

    You can try installing separately (assuming the package you download went off for an install as a pre req)

    System requirements

    Supported Operating Systems: Windows Server 2003, Windows Server 2008, Windows Vista, Windows XP

    The Windows Installer 4.5 redistributable can be installed on Windows XP Service Pack 2, Windows XP Service Pack 3, Windows Server 2003 Service Pack 1, Windows Server 2003 Service Pack 2, Windows Vista, Windows Vista Service Pack 1, and Windows Server 2008 in X86, X64 and IA64 flavors.

    Above says for your Vista version

    Try the x86 Platform: Windows6.0-KB942288-v2-x86.msu file.


    Best Wishes, The Redman; If something helps, please help show it by voting, if it solves, bonus!

    Friday, February 24, 2012 6:11 AM
  • Hi Preethy,

    Please ensure that the file you downloaded is 32bit (x86) first, the file name should be SQLEXPRWT_x86_ENU.exe. You can download it from this link

    And please also ensure you have installed .net framework 3.5 SP1 and Windows Installer 4.5 successfully.  You can check that in “start”—“control panel”—“Administrative Tools”—“services”.


    Best Regards,
    Iric
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, February 27, 2012 2:43 AM
    Moderator
  • Hello,

    What about PowerShell V2 ( instead 1.0 ) ?

    Have a nice day


    Mark Post as helpful if it provides any help.Otherwise,leave it as it is.

    Monday, February 27, 2012 9:37 PM
    Moderator