none
Can't connect to remote instance of SQL Server 2012 Express

    Question

  • I'm working on a visual studio application that will store data in a SqlServer 2012 express database.  The setup includes 2 PCs running 32 bit Window 7.  Each of the PC's will run a different application and store data in the SqlServer database.  My plan was to have SqlServer Express running on one of the computers.  The 2 computers are connected via an ethernet switch which is connected the company network but the computers are not on the company's domain.  I've set up the 2 computers to be in the same workgroup.

    I've got some experience writing applications that use SQL Server but I've never installed or set up SQL Server before.

    I've gone through the SqlServer set up and set it up using mixed authentication and set up a sa account.  I am able to access the database fine from the computer on which it was installed both with the management studio and a little test app that accesses the Northwind sample database.  My problem is that I can't access the database from the remote computer via either the management studio or the test app.  I always get the error:

    "A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)"

    In the management studio on the remote computer, if I use the "browse for more" then select "network servers" I can see the instance of sql server running.

    After much googling,

    I have enabled TCP protocol in the Configuration Manager .  In the management studio connections, Allow remote connections to  this server is checked.  I've set up an inbound rule in the windows firewall to allow connection to the SQL Server.

    I'm frustrated and out of ideas.  Can someone help with this problem?

    Thanks

    Friday, April 19, 2013 3:18 PM

Answers

All replies