locked
Connection Error: (provider: Shared Memory Provider, error: 0 - No process is on the other end of the pipe.

    Pregunta

  • Hello,

    Please bear with me as I am no Sql Server guru, but am getting this error that is preventing me from continuing with my development work.  I am the only developer on my team running Sql Server 2005 and it has been working just fine for the last week.  I opened the Management Studio this morning, just like every other morning and got this error:

    TITLE: Connect to Server
    ------------------------------

    Cannot connect to (local).

    ------------------------------
    ADDITIONAL INFORMATION:

    A connection was successfully established with the server, but then an error occurred during the login process. (provider: Shared Memory Provider, error: 0 - No process is on the other end of the pipe.) (Microsoft SQL Server, Error: 233)

    Of course the help page says no help is available.  I have googled myself sick and still have not found a way so resolve this...has anyone else had this error and/or a fix?  I am using XP Pro SP2...any help would be greatly appreciated!

    Thanks!
    Steph

    miércoles, 14 de diciembre de 2005 18:06

Todas las respuestas

  • This error usually indicates that the server closed the connection, e.g. during login verification. 

    The best is to check for any messages from SQL Server correlated to the time of the failure - either in the Application EventLog or in the ERRORLOG file (by default located in the C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\LOG directory).  There is a chance they provide more information to identify the root cause of the failure. 

     

     

    sábado, 17 de diciembre de 2005 1:02
  • Did not see any weird error message may cause this problem.
    domingo, 25 de diciembre de 2005 16:41
  • Try and connecting to the SQL Server box using the DAC (Dedicated Admin Connection) e.g if your server name is "SERVER" enter "ADMIN:Server" in Server name and click connect.
    miércoles, 28 de diciembre de 2005 3:54
  • Not sure if you have resolved this or not.  I had the same error trying to connect to a new SQL Server 2005 installation with the management studio from a remote machine and discovered that the named pipes protocol was diasabled in the SQL Server network configuration protocols.  I enabled it and restarted SQL Server and the problem was resolved.

    Good Luck

    Lane

    • Propuesto como respuesta R_2 lunes, 16 de marzo de 2009 12:53
    jueves, 05 de enero de 2006 4:08
  •  

    I checked the SQL Server log (message 2 above) and realised there were too many connections opened. The error description was verbose. Closed them and it worked.

    Cheers

     

    • Propuesto como respuesta Ross Warden martes, 16 de noviembre de 2010 14:02
    miércoles, 01 de marzo de 2006 11:02
  • yaah!!!! i have done same and it worked.. but after opening 5 or 6 connection, m getting the same error message again.....

     

     

    Cheers!!

    miércoles, 10 de mayo de 2006 5:51
  • Another mistake that can cause this error is incorrect credentials in a connection string.
    martes, 01 de agosto de 2006 17:45
  • execute sp_configure and increment the conexion

    lunes, 07 de agosto de 2006 13:20
  • reboot your db server...
    viernes, 25 de agosto de 2006 23:37
  • The reason this message appears is because of the web.config connectionString. Rather than using the default authentication details of Integrated Security=True:

    connectionString="Data Source=STL-COPELAND\SQLSERVER2005;Initial Catalog=RJ;Integrated Security=True"

    Use "User ID=sa Password=test"  for example in the connection string:

    connectionString="Data Source=STL-COPELAND\SQLSERVER2005;Initial Catalog=RJ;User ID=sa Password=test"

    Rod Copeland

     

     

    martes, 12 de septiembre de 2006 16:13
  • I spent a couple hourse working on this issue until i realised my SQL Server Agent Was stopped. It wasn't set to auto start to reboots didn't help. Oddly all my win32 apps would work fine and asp.net apps running from other machines could get the SQL data but a asp.net 2.0 app running off localhost would throw this error.

    Ben

    viernes, 13 de octubre de 2006 14:33
  • I enable the Protocols "Named Pipes" and it works.

    Thanks Lane.

     

    jueves, 09 de noviembre de 2006 8:41
  • After a while like 5 hours that I tried to solve this problem Thanks Lane I found your post... & Now it works
    domingo, 31 de diciembre de 2006 1:07
  • I received this error after dropping connections while detaching a database. I restarted the SQL server service as well as agent and IIS. nothing seemed to fix it. I then logged into SQL Server under another admin login. I looked at the properties under my usual login and found that the default database was not set, which seemed strange. I reset the default database and logged back in under my account. Not quite sure what SQL Server did, but now it's fixed.
    lunes, 05 de febrero de 2007 14:30
  • Hi!

    I experience same error message.
    I have an asp application that works with a DB. The database is mirrored. At the beginning the database worked with windows authentication. Also IIS paths requests from the application with specially created user. The user was also added to the DB (in login and users). My connectionStrings element in the application was configured to work with SSPI.
    Now I need to did a next change: I want to work with sql authentication. Do do it I create new login and user that works with  the DB. I also  change connectionStrings to add user and password and remove  SSPI.
    Now I run the application. It works perfect, but if I do a failover between mirrored DBs I've go next error:
    "A transport-level error has occurred when sending the request to the server. (provider: Shared Memory Provider, error: 0 - No process is on the other end of the pipe.)"

    Now if I run create of login and user for the DB. And than I run application once again it works well.

    Any help?
    jueves, 15 de febrero de 2007 11:15
  •  

    I'm having the same problem.  The Named Pipes support is disabled, but when I enable it, I get a timeout error.  Has anyone any idea about what may be happening?

    Thanks in advance,

    Monique

    jueves, 22 de febrero de 2007 22:54
  • thanks it works when enable "namedPipes" protocols

     

    lunes, 21 de mayo de 2007 12:02
  • Open the SQL Server Configuration Manager. Expand the Network configuration and enable the Shared Memory and Named Pipes, see to it the other 2 protocols TCP/IP and VIA are disabled. The same is to be done in Client configuration in client protocol section.

    I was getting the same error and i tried this and the error went off. Hope this helps.

     

    Regards

    Jolly bzach

    • Propuesto como respuesta zingab lunes, 23 de mayo de 2011 17:33
    • Votado como útil zingab lunes, 23 de mayo de 2011 17:33
    martes, 29 de mayo de 2007 20:23
  •  

    i have this same problem

    when the name pipes was enable thwe connection is timeout

     

     

    any one could help???

     

     

    jueves, 09 de agosto de 2007 7:55
  • Disable Shared memory protocol and try !....

     

    jueves, 23 de agosto de 2007 22:24
  • One of the most common reasons for this error is that SQL authentication is not enabled on the instance that you are logging into. Enable Sql Authentication, Restart the Instance and it should go away!

     

    miércoles, 12 de septiembre de 2007 17:03
  •  

    Check your SQL Native Client Configuration in Computer Management. Check to see if there are any Aliases under Client Protocols. If there are Aliases with the name of the SQL server you try to connect, delete them. It works.
    jueves, 11 de octubre de 2007 18:18
  •  

    -------------------------------

    ASP.Net 2.0 Application

    SQL Server 2005

    Clients have a mix of IE6 and IE6

    -------------------------------

     

    My users reported this error. I checked the Event Log on the server and it gave the following message:

     

    Could not connect because the maximum number of '5' user connections has already been reached. The system administrator can use sp_configure to increase the maximum value. The connection has been closed. [CLIENT: <local machine>]

     

    The ASP.Net application gave this error message in IE:

     

    A connection was successfully established with the server, but then an error occurred during the login process. (provider: Shared Memory Provider, error: 0 - No process is on the other end of the pipe.)

     

    I had everyone disconnect so I could, then ran this statement in SQL Server Mgmt Studio:

     

    sp_configure 'user connections', 25

    reconfigure with override

     

    jueves, 15 de noviembre de 2007 20:27
  • My issue was with the connection strings was limited.  Try connecting with only one query (be sure to disconnect from all other connections to the SQL server), then run the following script:

     

    EXEC sys.sp_configure N'show advanced options', N'1' RECONFIGURE WITH OVERRIDE

    GO

    EXEC sys.sp_configure N'user connections', N'0'

    GO

    RECONFIGURE WITH OVERRIDE

    GO

    EXEC sys.sp_configure N'show advanced options', N'0' RECONFIGURE WITH OVERRIDE

    GO

     

    The problim seems to have multipule causes, but one of the causes is that a limited number of connections to the SQL database has been set.  This script will set it back to 0 which is unlimited.  This setting can be found by right clicking on the server the click Properties - Connections.  This script will allow you to reset that setting even if you can't get that far through the Object Explorer. 

     

    * Note: Be sure to disconnect from the server in Object Explore so you can run this script.

    martes, 08 de enero de 2008 16:03
  • Could you please share the steps you did to enable "named pipes protocol in SQL Server network configuration protocols?"

    Thanks!

    viernes, 11 de enero de 2008 15:19
  • I found how to enable the NP but got the new error message:

    Login failed for user 'sa'. The user is not associated with a trusted SQL Server connection. (Microsoft SQL Server, Error: 18452)

    viernes, 11 de enero de 2008 15:34
  •  

    Ryan - Thanks for the script and instructions on resetting connections back to "0" - but remember that you need to restart SQL services for it to take efffect. 

     

    It worked for me!  Thanks!

     

    viernes, 22 de febrero de 2008 19:07
  • I'm new to the forum, but i found a way to actually see the connections.  In SQL Managment Studio under the database server name expand the management tree and open the Activey Monitor.  It will then display the active connections.  I was having the same problem during development testing and sure enough i was trying to open more than 10 connections.

    miércoles, 05 de marzo de 2008 19:33
  • How was the named pipes enabled. Was this through the connect string code or is this a setting in SQLExpress

    viernes, 21 de marzo de 2008 16:45
  • goto sql server configuration manager.  it's under SQL server2005 Network configuration- protocols for (your sqlengine)

    sábado, 19 de julio de 2008 19:54

  • I had the same problem. I try to connect to SQL server using "Management Studio Express" from another computer.
    So i solved the problem. Here are steps:


    1) Start->Programs-> Microsoft SQL Server 2005 -> Configuration Tools-> SQL Server Surface Area Configuration
    2) Run "Surface Area Configuration for Services and Conections"
    3) In the tree Select "Remote Connections" and then select "Using named pipes only".
    4) Look at Start->Programs-> Microsoft SQL Server 2005 -> Configuration Tools->SQL Server Configuration Manager
    5) In the tree select "SQL Server 2005 Network Configuration->Protocols for SQL..." All protocols must be Disabled, but Named Pipes -- Enabled.

    Don't forget to restart server.
    jueves, 24 de julio de 2008 10:44
  • I found using SQL Server Management Studio Express that my newly installed SQL server was set to Windows Authentication only, so I set it to both Windows Authentication and SQL login.

     

    jueves, 31 de julio de 2008 1:29
  • After restarting the services, able to connect the SQL server from Client machines. thanks

    martes, 07 de octubre de 2008 11:45
  • This issue was posted long time ago, and many people replied with their own solutions including connection strings of the apps. This is my case and I think Steph experienced exactly same as mine.

     

    My ASP.Net app can connect and access to the database, but Management Studio gives the error expained by Steph. My solution was...

     

    Start>SQL Server 2005>Configuration Tools>Surface Area Configuration>Add New Administrator

    Then add available privileges.

     

    HTH

     

    viernes, 21 de noviembre de 2008 17:01
  • I have the same errror. I try to change the connectionString: ...Data Source=localhost --> Data Source=MAY01\SQLEXPRESS and it work. Wink
    martes, 25 de noviembre de 2008 4:46
  • I had an error that is related to this thread.

    Microsoft SQL Server 2005 -- Error 29515. SQL Server Setup could not connect to the database service for server configuration. The error was: [Microsoft][SQL Native Client]Shared Memory Provider: No process is on the other end of the pipe.

    Here is what led to the error: I had installed SQL2005 and SharePoint on a box for testing purposes. Everything went in fine and configured correctly as well as setup initial site.  After this was done I installed visual studio 2008 and called it a day.

    Came back on monday and attempted to connect to the Sharepoint central administration site and got a database not found error. No matter what I did I could not connect to it. So I uninstalled SQL and sharepoint, cleaned everything up and reinstalled.  That is when the Error 29515 first appeared.  I found this thread and tried everything listed here but nothing worked.

    Fast forward ahead 3 days . . . I was to the point of reloading Server and starting from scratch but decided to try one more install.  This time I created a new user account on the server and installed using this account.

    The SOB worked.  Not saying that this will solve all problems but it worked for me and is a quick fix to try.  I still have no idea why the error started but I suspect it had something to do with the initial install of visual studio and the sql express that comes with it.
    jueves, 12 de marzo de 2009 16:22
  • Thank you very much.  Your advice worked well.
    jueves, 16 de abril de 2009 9:18
  • Yea I got this error...and in the event log it said that my server was only configured for  Windows authentication.
    So I logged in via Windows Auth and set the server properties to allow both SQL and Windows auth and also set the primary database for the sql user in the user properties..changed it from master. restarted sql services and things worked.
    miércoles, 22 de julio de 2009 17:05
  • I have the similiar kinda of issue. but when i look into Log directory..this is what it says


    Logon       Could not connect because the maximum number of '1' user connections has already been reached. The system administrator can use sp_configure to increase the maximum value. The connection has been closed.



    whats the procedure of using sp_configure.

    thanks
    Albin

    albingorkhali
    jueves, 13 de agosto de 2009 17:14
  • My own issue is not similar to those mentioned in this forum.

    I have got some SSIS packages stored in MSDB database. Exporting some of them gives this type of error message.

    Communication link failure Shared Memory Provider: No process is on the other end of the pipe. (Microsoft SQL Native Client)

    Disabling Shared Memory Protocol and exporting the package again reports error on the other protocols (TCP and Named Pipe) depending on which of them at the top of priority list.

    I have had a look at the server and client protocols configurations. These settings seems to be working fine. I even had to disable and reorder them but the error still persists.
    The irony of it is that the error is not coming up on all the packages.
    I have restarted the engine and looked at the error log.

    The log reports are as follows:

    SQL Server is now ready for client connections. This is an informational message; no user action is required. Server is listening on [ 127.0.0.1 <ipv4> 1434]. Server named pipe provider is ready to accept connection on [ \\.\pipe\sql\query ]. Server local connection provider is ready to accept connection on [ \\.\pipe\SQLLocal\MSSQLSERVER ]. Server is listening on [ 'any' <ipv4> 1433].

    I'm suspecting these packages but they are running fine without any errors.
    There is no certificate installed on the box.

    Does anyone have a clue why this is happening?

    One more thing the server configs are:
    Win 2003 SP1, SQL 2005 RTM.

    I'm not suspecting SQL service pack since the issues are not occurring on production with the same configurations. I'm planning to apply SP3 on the box though.

    viernes, 06 de noviembre de 2009 9:35
  • I had the same issue and none of the solutions here worked.

    New install and created the first SQL Authentication user in a way that has always worked before.  Got the error initially.

    Restarted SQL Server service and tried the login on the host and still failed.

    Clicked Add New Administrator as noted above in this thread.  I was already a sysadmin so I don't think this step made any difference.

    I went to a remote computer to try the login and got a prompt that the login was expired.  No idea how it was considered expired.

    I put in a new password at that prompt and then the login worked.
    • Propuesto como respuesta srikanthmn domingo, 17 de enero de 2010 15:23
    viernes, 08 de enero de 2010 22:18
  • Login with default admin. Right click on server name and select property, Select 'security' from left panel. Select option 'SQL Server and Windows Authentication mode' under Server Authentication. After this restart your server... hope this solves the problem
    • Propuesto como respuesta SenaM miércoles, 04 de abril de 2012 3:38
    domingo, 17 de enero de 2010 15:28
  • I had the same problem but on a remote server. In case anyone else might have the same issue, here’s what solved the issue for me.

     

    1)       Go to Sql Server Surface Area Configuration Manager. Set remote connections to local only. Restart Sql Server (services manager)


    2)       Go to Sql Server Studio Manager and login as “localhost” (make sure you don’t use a network instance but localhost). Then run this query (which someone on this forum so graciously posted)

     

    EXEC sys.sp_configure N'show advanced options', N'1' RECONFIGURE WITH OVERRIDE

     

    GO

     

    EXEC sys.sp_configure N'user connections', N'0'

     

    GO

     

    RECONFIGURE WITH OVERRIDE

     

    GO

     

    EXEC sys.sp_configure N'show advanced options', N'0' RECONFIGURE WITH OVERRIDE

     

    GO

     

    3)       Go to Sql Server Surface Area Configuration Manager. Set remote connections to local and remote (i used tcp and named pipes). Restart Sql Server (services manager). The issue should now be resolved. Good luck!


    lp
    lunes, 18 de enero de 2010 16:47
  • Hi,

    I am very new to sql server.  I am facing a very strange problem with sql server.

    We have installed sql server 2005 on windows server 2003 and authentication mode is mixed.  My problem is that sql server suddenly stop taking login authentication in sql mode however we are able to login from windows mode.

    Restart the sql services does not make any difference but when we reboot our server,  problem gets solved but after sometimes we face the same problem again. 

    following is error 

    "A connection was successfully established with the server, but then an error occurred during the login process. (provider: Shared Memory Provider, error: 0 - No process is on the other end of the pipe.) (.Net SqlClient Data Provider)"

    There is no message in error log and even Named pipes enabled in my sql server. My all services are running and there is no too many connections opened.

    I don't understand where the problem lies.  any help would be greatly appreciated.

    Thanks In Advance.






    lunes, 25 de enero de 2010 12:13
  • Land thank you this work for as well.
    miércoles, 27 de enero de 2010 17:11
  • thank for the advise, works like a charm for me...
    domingo, 07 de febrero de 2010 5:59
  • Hi,

    I had the same problem but when I tried to check the ERRORLOG, I got the below error

     

     "C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL is not accessible."

    Access is denied.

    Can you please help me out now. Thanks.

    • Propuesto como respuesta Sayed Toufiq sábado, 01 de mayo de 2010 4:16
    martes, 06 de abril de 2010 10:09
  • have restarted the SQL engine service and which worked for me and able to connect to database. Thanks, Toufiq.
    sábado, 01 de mayo de 2010 4:19
  • You are a life saver!!!!
    jueves, 22 de julio de 2010 15:41
  • This is a very great way. I use it solving my problem very fast!

     

    thanks

    domingo, 25 de julio de 2010 12:56
  • Thanks a lot.. !!
    lunes, 16 de agosto de 2010 8:03
  • Hello,

    Please bear with me as I am no Sql Server guru, but am getting this error that is preventing me from continuing with my development work.  I am the only developer on my team running Sql Server 2005 and it has been working just fine for the last week.  I opened the Management Studio this morning, just like every other morning and got this error:

    TITLE: Connect to Server
    ------------------------------

    Cannot connect to (local).

    ------------------------------
    ADDITIONAL INFORMATION:

    A connection was successfully established with the server, but then an error occurred during the login process. (provider: Shared Memory Provider, error: 0 - No process is on the other end of the pipe.) (Microsoft SQL Server, Error: 233)

    Of course the help page says no help is available.  I have googled myself sick and still have not found a way so resolve this...has anyone else had this error and/or a fix?  I am using XP Pro SP2...any help would be greatly appreciated!

    Thanks!
    Steph


    Hi !   Actually the problem is that urs MS SQL didn't configure correctly .  Use the Surface Area and make sure  remote connection to SQL  is avalable.

    jueves, 09 de septiembre de 2010 11:02
  • I faced below mentioned issue today and here's the solution .  This is because sql server's "user connections' row in sp_configure was set to 2.

    1)Open the database in single login mode..

    2)  If you dont know how to open in single login mode then

             i)stop sql server agent service .This will deduct one connection to the database.

             ii)Now, use your management studio to login . You should be able to login becuase stopping the sql server agent service removes one connection to the database.

    3) type sp_configure and see for 'user connections' row..You should see 2 over there .

    4) run .... EXEC sp_configure 'user connections', 10 .

    That fixes your problem.....

    ------------------------------
    ADDITIONAL INFORMATION:

    A connection was successfully established with the server, but then an error occurred during the login process. (provider: Shared Memory Provider, error: 0 - No process is on the other end of the pipe.) (Microsoft SQL Server, Error: 233)

    For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&EvtSrc=MSSQLServer&EvtID=233&LinkId=20476

    ------------------------------
    BUTTONS:

    OK
    ------------------------------

    martes, 21 de septiembre de 2010 23:15
  • Thanks Lane! It works!
    jueves, 02 de diciembre de 2010 0:33
  • So you changed it from mater... to what???
    Samuel Miller
    martes, 15 de febrero de 2011 19:46
  • I had this problem but in my case i was not passing the db pwd .... Eu tive esse mesmo problema mas em meu caso eu não estava passando a senha....
    Marcelo Gomes
    viernes, 15 de abril de 2011 16:29
  • I am getting this error, some of the replies i tried and didnt get the solution, some are i dont know how to do it, but still i am getting the error. When i open the SQL Server Configuration Manager, SQLEXPRESS State is stopped, when i try to start the service, it showing the following error:

    The request failed or the service did not respond in a timely fashion.

    Plz anyone help me to find out the solution.

    viernes, 11 de noviembre de 2011 9:29
  • Yea I got this error...and in the event log it said that my server was only configured for  Windows authentication.
    So I logged in via Windows Auth and set the server properties to allow both SQL and Windows auth and also set the primary database for the sql user in the user properties..changed it from master. restarted sql services and things worked.

    It worked after both SQL and windows auth were set. Thanks RG-labcorp
    jueves, 22 de marzo de 2012 17:34
  • Setting proposed by Lane did it... 

    LOTS of problems connecting SQL DB to SharePoint. Error 233, No Process on end of Pipe, account login failure.... and on and on.... really..! 

    Created SQL account (not AD/NT Domain account); logged in to reset password (on first use)

    Added setting to web.config file (actually in /14 NOT /60) per this post http://support.microsoft.com/kb/831092

    <system.net> <defaultProxy> <proxy proxyaddress="http://ProxyServer:port" bypassonlocal = "true"/> </defaultProxy> </system.net>

    In SQL Config manager, enabled both TCP and Named Pipes, stopped and re-started the server

    (Lane's suggestion Named Pipes - then it worked)

    Not sure if everything else was overkill or not. But whatever the case, I now have a SPD connection to the DB. 


    Terri Morgan


    • Editado TerriMorgan sábado, 31 de marzo de 2012 19:13
    sábado, 31 de marzo de 2012 19:13
  • Hi,

    I too had the same issue. Below is the solution. If you are using PowerShell to execute sql scripts then put following code after query.

    [System.Data.SqlClient.SqlConnection]::ClearAllPools()

    or if you sing C# then.

    System.Data.SqlClient.SqlConnection.ClearAllPools();

    Thanks,

    Prakash

    viernes, 24 de agosto de 2012 6:05
  • i had the same issue but i ran the following script and then restarted the service

    declare
    @oldvalue int;
    set @oldvalue =  CONVERT(int, (select value from   sys.configurations
    where name = 'show advanced options'));
    EXEC sp_configure 'show advanced options', 1
    RECONFIGURE
    EXEC sp_configure 'user connections',0 ;
    RECONFIGURE;
    EXEC sp_configure 'show advanced options', @oldvalue
    RECONFIGURE
    GO

    • Propuesto como respuesta perezco viernes, 12 de octubre de 2012 21:07
    • Votado como útil perezco viernes, 12 de octubre de 2012 21:07
    jueves, 04 de octubre de 2012 8:52
  • I ran into this error today. I was able to resolve it by making sure the database is set to Mixed authentication. 
    martes, 30 de octubre de 2012 19:35