none
CSV output with Quotes

    Pregunta

  •  

    I am trying to get csv output from a report with the text fields having quotes around them.  Currently when I export my report from the designer I get all fields just separated by a comma with no quotes.  I have tried forcing the quotes through concatenation both in the SQL and in an expression for the field with no luck on either.  When I do that I get ""field1"", ""field2"" rather than "field1", "field2".

     

    Anyone have any ideas?  Thanks!

    lunes, 22 de septiembre de 2008 12:44

Respuestas

  •  

    The CSV renderer uses double quotes by default as a qualifier to double-escape any text which contains special characters (the double-quote character is one of them). While there is a deviceInfo that you can set to change the qualifier, whatever you set that qualifier to be will still wrap around your double-quoted text. Currently, there's no deviceInfo to disable the qualifier.

     

    For reference, you can set your qualifier in either your reportDesigner.config (for BIDS) or reportserver.config (for server) with by adding in the following configuration deviceInfo to the csv rendering extension.

     

    <Extension Name="CSV"....>

    Insert---> <Configuration>

    <DeviceInfo>

    <Qualifier>[your qualifier here]</Qualifier>

    </DeviceInfo>

    </Configuration>

    </Extension>

    miércoles, 24 de septiembre de 2008 18:19
    Usuario que responde