none
Exchange Connector and Office 365

    Question

  • Hi Guys,

    I'm really hoping someone can help! I'm setting SCSM 2012 but am having trouble with setting up the exchange connector to work with Office 365. SCSM is currently running on Windows Server 2008 Standard R2. I have been using the deployment guide like a bible for the past couple of days and still cannot figure out why this isn't working. The series of events is as follows:

    Information Events:

    1. Exchange Connector: Retrieved all MPs and classes

    2. Exchange Connector: Incident Settings. IDPrefix: IR Max File Size: 2097152 Max Number of Attachments: 10

    3. Exchange Connector: Change Request Settings. ID Prefix: CR Max File Size: 65536 Max Number of File Attachment: 10

    4. Exchange Connector: Manual activity ID Prefix: MA Review Activity ID Prefix: RA

    5. Exchange Connector: Service request ID prefix: SR

    6. Exchange Connector: Release record ID prefix: RR

    7. Exchange Connector: Problem ID prefix: PR

    8. Exchange Connector: Retrieved all work item settings

    9. Exchange Connector: Found connector 'ExchangeConnector.f7e5c06f593c4a398b54334dec94a8ed'.  Initializing its status now.

    10. Exchange Connector: Finished initializing connector status for connector: ExchangeConnector.f7e5c06f593c4a398b54334dec94a8ed

    11. Exchange Connector: Connector 'ExchangeConnector.f7e5c06f593c4a398b54334dec94a8ed' is starting at 15/05/2012 14:05:24 UTC

    12. Exchange Connector: Using credentials provided not Windows Integrated authentication

    13. Exchange Connector: Using Exchange Web Service URL: http://portal.microsoftonline.com

    14. Exchange Connector: Error while processing emails for email address 'support@lynq.co.uk'

    15. Exchange Connector: Setting status for Exchange connector 'ExchangeConnector.f7e5c06f593c4a398b54334dec94a8ed' to 'Finished With Error'

    16. Exchange Connector: Connector 'ExchangeConnector.f7e5c06f593c4a398b54334dec94a8ed' is finishing at 15/05/2012 14:05:25 UTC

    ERROR EVENT

    System

    -

    Provider

    [ Name]

    Health Service Modules

    -

    EventID

    33880

    [ Qualifiers]

    49152

    Level

    2

    Task

    0

    Keywords

    0x80000000000000

    -

    TimeCreated

    [ SystemTime]

    2012-05-15T14:05:25.000000000Z

    EventRecordID

    30356

    Channel

    Operations Manager

    Computer

    LYNQIEAPP01.Lynq.co.uk

     

    Security

     

    -

    EventData

    Microsoft.SystemCenter.ExchangeConnector.ProcessEmailsWorkflow

    402c7262-f221-fcbe-e10c-eeb68d80aa39

    Microsoft.Exchange.WebServices.Data.ServiceRequestException

    The response received from the service didn't contain valid XML.

    at Microsoft.SystemCenter.ExchangeConnector.ExchangeInbox.ProcessMail() at Microsoft.SystemCenter.ExchangeConnector.ProcessEmailsWorkflow.Execute(ActivityExecutionContext executionContext) at System.Workflow.ComponentModel.ActivityExecutor`1.Execute(T activity, ActivityExecutionContext executionContext) at System.Workflow.ComponentModel.CompositeActivityExecutor`1.Execute(T activity, ActivityExecutionContext executionContext) at System.Workflow.ComponentModel.ActivityExecutor`1.Execute(Activity activity, ActivityExecutionContext executionContext) at System.Workflow.ComponentModel.ActivityExecutorOperation.Run(IWorkflowCoreRuntime workflowCoreRuntime) at System.Workflow.Runtime.Scheduler.Run()

    I have setup the registry key per the document - it looks like this (I have changed the password but it is entered correctly into the registry!)

    Key Name:          HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\System Center Service Manager Exchange Connector
    Class Name:        <NO CLASS>
    Last Write Time:   15/05/2012 - 15:28
    Value 0
      Name:            <NO NAME>
      Type:            REG_SZ
      Data:           

    Value 1
      Name:            ExchangeURL
      Type:            REG_SZ
      Data:            http://portal.microsoftonline.com

    Value 2
      Name:            ExchangeURLLogin
      Type:            REG_SZ
      Data:            support@lynq.co.uk

    Value 3
      Name:            ExchangeURLPassword
      Type:            REG_SZ
      Data:            Password

    Value 4
      Name:            EnableEWSTracing
      Type:            REG_SZ
      Data:            1

    Value 5
      Name:            LoggingLevel
      Type:            REG_SZ
      Data:            7

    I have changed the ExchangeURL to two other values, all of which work when logging in through IE. I can't think of anything else that might be causing the problem.

    Any suggestions??

    Thank you

    Tuesday, May 15, 2012 2:33 PM

Answers

  • In case anyone comes across this in future - this is how it was fixed:

    1. Corrected ExchangeURL reg key to include /EWS/exchange.asmx suffix
    2. Observed the previous XML error was no longer happening and taking the new error below as meaning that Impersonisation needed to be set up on Hosted Exchange.

    Log Name:      Operations Manager

    Source:        Health Service Modules

    Date:          17/05/2012 16:16:36

    Event ID:      33880

    Task Category: None

    Level:         Error

    Keywords:      Classic

    User:          N/A

    Computer:      LYNQIEAPP01.Lynq.co.uk

    Description:

    A Windows Workflow Foundation workflow failed during execution.

    Workflow Type: Microsoft.SystemCenter.ExchangeConnector.ProcessEmailsWorkflow

    Workflow Identifier: 402c7262-f221-fcbe-e10c-eeb68d80aa39

    Exception Type: Microsoft.Exchange.WebServices.Data.ServiceResponseException

    Exception Message: The account does not have permission to impersonate the requested user.

    1. Set up windows powershell as described here: http://help.outlook.com/en-us/140/cc952756.aspx
    2. Connected to hosted server using powershell and admin account and enabled impersonation for monitored mailboxAs documented here: http://msdn.microsoft.com/en-us/library/gg194012%28v=exchg.140%29.aspx

    Thanks!

    Friday, May 18, 2012 6:16 AM

All replies

  • In case anyone comes across this in future - this is how it was fixed:

    1. Corrected ExchangeURL reg key to include /EWS/exchange.asmx suffix
    2. Observed the previous XML error was no longer happening and taking the new error below as meaning that Impersonisation needed to be set up on Hosted Exchange.

    Log Name:      Operations Manager

    Source:        Health Service Modules

    Date:          17/05/2012 16:16:36

    Event ID:      33880

    Task Category: None

    Level:         Error

    Keywords:      Classic

    User:          N/A

    Computer:      LYNQIEAPP01.Lynq.co.uk

    Description:

    A Windows Workflow Foundation workflow failed during execution.

    Workflow Type: Microsoft.SystemCenter.ExchangeConnector.ProcessEmailsWorkflow

    Workflow Identifier: 402c7262-f221-fcbe-e10c-eeb68d80aa39

    Exception Type: Microsoft.Exchange.WebServices.Data.ServiceResponseException

    Exception Message: The account does not have permission to impersonate the requested user.

    1. Set up windows powershell as described here: http://help.outlook.com/en-us/140/cc952756.aspx
    2. Connected to hosted server using powershell and admin account and enabled impersonation for monitored mailboxAs documented here: http://msdn.microsoft.com/en-us/library/gg194012%28v=exchg.140%29.aspx

    Thanks!

    Friday, May 18, 2012 6:16 AM
  • LynqSupport,

    Is there any chance you can provide me with the exact commands (in sequence) that you entered in Power Shell to get impersonation to work?

    I'm having trouble getting my SCSM service account to monitor a different email box to pull tickets into SCSM 2012. 

    Thursday, October 11, 2012 3:19 PM
  • I too would like to understand how you setup impersonation for the Office 365 mailbox?

    Thanks,

    Terry

    Sunday, January 27, 2013 10:45 PM