none
PXE error = PXE-E32: TFTP open timeout

    Question

  •  

    Hi Everyone,

     

    I have a switched network using CISCO switches and also CISCO CNR(Cisco Network Register 6.1) acting as DHCP on my network. I modified the policies for the scope where my clients are connected using PXE to obtain the SCCM and WDS images and i'm having the following error

     

    "PXE error = PXE-E32: TFTP open timeout"

     

    The networking guy told me that the clients using DHCP never tries to connect to the TFTP server on my SCCM and WDS server that are running on a different box than the CNR 6.1.

     

    Also i set the following parameters on my scope policy at the CNR 6.1 to the network segment where the clients are connected:

     

    [011]  resource-location-server                        <ip address of my WDS & SCCM server>

    [067] boot-file                                                     <name of my .WIM image>

    [066] tftp-server                                                  <FDQN of my WDS  & SCCM server>

     

    If there's more options to set in order to achieve the download of the images from the WDS & SCCM server?

    Could someone help?

     

    I'll appreciate your comments,

     

    Cordially,

    Oscar.

    Tuesday, July 15, 2008 8:58 PM

All replies

  • Hi Oscar,

     

    You need to apply the following options:

     

    Option 60 is PXEClient

    Option 66 will contain the ip or FQDN of your WDS server (PXE Service Point role in SCCM)

    Option 67 will contain the name of your bootfile (SMSBoot\x86\wdsnbp.com)

     

    Good Luck,

     

    Regards,

     

    Kenneth

    Wednesday, July 16, 2008 6:23 AM
  • HI Kenneth,

     

    Thanks for your answer, but the option 60 it doesn´t available at Cisco CNR (Cisco Network Register), that i used as DHCP Server. I change the other values but the problem still persists. If you have more ideas i'll appreciate..

     

    Cordially,

    Oscar.

     

    Wednesday, July 16, 2008 10:03 AM
  • Hi Oscar,

     

    I think that option 66 en 67 are important.

    Can you post your config on those options? And what kind of machines are you PXE booting?

     

    Regards,

     

    Kenneth

    Wednesday, July 16, 2008 11:01 AM
  • Hello,
    I just accidentally dropped in, searching for the name of the bootfile, that was explained here as
    SMSBoot\x86\wdsnbp.com. What is important with PXE and tftp is to understand the process, which is actually quite simple. You pass the name of the bootserver and the boot filename bye one of two methods. It is either done through Proxy DHCP, which is implemented on your SCCM server. For this towork, you do not need any changes to your DHCP scope, but you have to add a DHCP helper (also called DHCP relay or BOOTP relay) to the router that you use for the CLIENT segment. The DHCP helper has to point to the WDS/SCCM server. Do not remove any DHCP helpers that are already in the TCP segment.

    If this is not an option, you have to go the way that you currently are, and specify options 66 and 67, which point to the server and the bootloader (not the WIM-file) on your SCCM server. This has to be specified relative to the root path of the tftp service on your machine, so the value Kenneth suggested,
    SMSBoot\x86\wdsnbp.com seems correct. (I don't really know SCCM, but I really do know PXE :-) )

    To test tftp:
    1. From the client to the server: Download a tftp client (if you run Vista, it can be installed as a feature) and try to download the file. the command should be *similar* to "tftp get SMSBoot\x86\wdsnbp.com"
    2. From the server to the client: Disable Microsoft's tftp server and install a freeware/shareware tftpserver that implements logging. Configure the tftp server to use the same directory that Microsoft's tftp server uses. Start tftp server and check the real-time log to see what is going on

    Using these methods, you should normally find out quite explicitly what is wrong with your setup :-)

    Regards,

    Ole Kristian

    Tuesday, September 16, 2008 8:52 AM
  • Use IP Helpers instead, in my experience much more reliable than DHCP Scope options...

     

    Next best thing is to use a more advanced DHCP Server (like ISC) that supports the next-server option...

    Tuesday, September 16, 2008 10:45 AM
  • Enable TFTP and try below command:

    "tftp -i <server IP Address> get boot\x86\pxeboot.com"

    I know this is old post but it may help someone...

    Wednesday, March 12, 2014 4:11 PM